summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-02-07 20:03:29 +0100
committerMichał Górny <mgorny@gentoo.org>2020-02-09 17:35:27 +0100
commitbf6ba2fa05581e64b9a63a4e3f77c73f3c6218bb (patch)
treee259e5503aff447db408dbeac47165f6cc09ffbf /sci-geosciences
parentsci-geosciences/grass: Switch to PYTHON_MULTI_USEDEP API (diff)
downloadgentoo-bf6ba2fa05581e64b9a63a4e3f77c73f3c6218bb.tar.gz
gentoo-bf6ba2fa05581e64b9a63a4e3f77c73f3c6218bb.tar.bz2
gentoo-bf6ba2fa05581e64b9a63a4e3f77c73f3c6218bb.zip
sci-geosciences/qgis: Switch to PYTHON_MULTI_USEDEP API
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sci-geosciences')
-rw-r--r--sci-geosciences/qgis/qgis-3.10.2-r1.ebuild (renamed from sci-geosciences/qgis/qgis-3.10.2.ebuild)34
-rw-r--r--sci-geosciences/qgis/qgis-3.4.12.ebuild34
-rw-r--r--sci-geosciences/qgis/qgis-9999.ebuild34
3 files changed, 54 insertions, 48 deletions
diff --git a/sci-geosciences/qgis/qgis-3.10.2.ebuild b/sci-geosciences/qgis/qgis-3.10.2-r1.ebuild
index 232d4a5b49c..cc6d86b4b70 100644
--- a/sci-geosciences/qgis/qgis-3.10.2.ebuild
+++ b/sci-geosciences/qgis/qgis-3.10.2-r1.ebuild
@@ -73,22 +73,24 @@ COMMON_DEPEND="
postgres? ( dev-db/postgresql:= )
python? (
${PYTHON_DEPS}
- dev-python/future[${PYTHON_USEDEP}]
- dev-python/httplib2[${PYTHON_USEDEP}]
- dev-python/jinja[${PYTHON_USEDEP}]
- dev-python/markupsafe[${PYTHON_USEDEP}]
- dev-python/owslib[${PYTHON_USEDEP}]
- dev-python/pygments[${PYTHON_USEDEP}]
- dev-python/PyQt5[designer,network,sql,svg,webkit?,${PYTHON_USEDEP}]
- dev-python/python-dateutil[${PYTHON_USEDEP}]
- dev-python/pytz[${PYTHON_USEDEP}]
- dev-python/pyyaml[${PYTHON_USEDEP}]
- >=dev-python/qscintilla-python-2.10.1[qt5(+),${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- dev-python/sip:=[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
- >=sci-libs/gdal-2.2.3[python,${PYTHON_USEDEP}]
- postgres? ( dev-python/psycopg:2[${PYTHON_USEDEP}] )
+ $(python_gen_cond_dep '
+ dev-python/future[${PYTHON_MULTI_USEDEP}]
+ dev-python/httplib2[${PYTHON_MULTI_USEDEP}]
+ dev-python/jinja[${PYTHON_MULTI_USEDEP}]
+ dev-python/markupsafe[${PYTHON_MULTI_USEDEP}]
+ dev-python/owslib[${PYTHON_MULTI_USEDEP}]
+ dev-python/pygments[${PYTHON_MULTI_USEDEP}]
+ dev-python/PyQt5[designer,network,sql,svg,webkit?,${PYTHON_MULTI_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_MULTI_USEDEP}]
+ dev-python/pytz[${PYTHON_MULTI_USEDEP}]
+ dev-python/pyyaml[${PYTHON_MULTI_USEDEP}]
+ >=dev-python/qscintilla-python-2.10.1[qt5(+),${PYTHON_MULTI_USEDEP}]
+ dev-python/requests[${PYTHON_MULTI_USEDEP}]
+ dev-python/sip:=[${PYTHON_MULTI_USEDEP}]
+ dev-python/six[${PYTHON_MULTI_USEDEP}]
+ >=sci-libs/gdal-2.2.3[python,${PYTHON_MULTI_USEDEP}]
+ postgres? ( dev-python/psycopg:2[${PYTHON_MULTI_USEDEP}] )
+ ')
)
qml? ( >=dev-qt/qtdeclarative-${QT_MIN_VER}:5 )
webkit? ( >=dev-qt/qtwebkit-5.9.1:5 )
diff --git a/sci-geosciences/qgis/qgis-3.4.12.ebuild b/sci-geosciences/qgis/qgis-3.4.12.ebuild
index ae1b97d37ba..d5cb18ca5d4 100644
--- a/sci-geosciences/qgis/qgis-3.4.12.ebuild
+++ b/sci-geosciences/qgis/qgis-3.4.12.ebuild
@@ -71,22 +71,24 @@ COMMON_DEPEND="
postgres? ( dev-db/postgresql:= )
python? (
${PYTHON_DEPS}
- dev-python/future[${PYTHON_USEDEP}]
- dev-python/httplib2[${PYTHON_USEDEP}]
- dev-python/jinja[${PYTHON_USEDEP}]
- dev-python/markupsafe[${PYTHON_USEDEP}]
- dev-python/owslib[${PYTHON_USEDEP}]
- dev-python/pygments[${PYTHON_USEDEP}]
- dev-python/PyQt5[designer,network,sql,svg,webkit?,${PYTHON_USEDEP}]
- dev-python/python-dateutil[${PYTHON_USEDEP}]
- dev-python/pytz[${PYTHON_USEDEP}]
- dev-python/pyyaml[${PYTHON_USEDEP}]
- >=dev-python/qscintilla-python-2.10.1[qt5(+),${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- dev-python/sip:=[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
- >=sci-libs/gdal-2.2.3[python,${PYTHON_USEDEP}]
- postgres? ( dev-python/psycopg:2[${PYTHON_USEDEP}] )
+ $(python_gen_cond_dep '
+ dev-python/future[${PYTHON_MULTI_USEDEP}]
+ dev-python/httplib2[${PYTHON_MULTI_USEDEP}]
+ dev-python/jinja[${PYTHON_MULTI_USEDEP}]
+ dev-python/markupsafe[${PYTHON_MULTI_USEDEP}]
+ dev-python/owslib[${PYTHON_MULTI_USEDEP}]
+ dev-python/pygments[${PYTHON_MULTI_USEDEP}]
+ dev-python/PyQt5[designer,network,sql,svg,webkit?,${PYTHON_MULTI_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_MULTI_USEDEP}]
+ dev-python/pytz[${PYTHON_MULTI_USEDEP}]
+ dev-python/pyyaml[${PYTHON_MULTI_USEDEP}]
+ >=dev-python/qscintilla-python-2.10.1[qt5(+),${PYTHON_MULTI_USEDEP}]
+ dev-python/requests[${PYTHON_MULTI_USEDEP}]
+ dev-python/sip:=[${PYTHON_MULTI_USEDEP}]
+ dev-python/six[${PYTHON_MULTI_USEDEP}]
+ >=sci-libs/gdal-2.2.3[python,${PYTHON_MULTI_USEDEP}]
+ postgres? ( dev-python/psycopg:2[${PYTHON_MULTI_USEDEP}] )
+ ')
)
qml? ( >=dev-qt/qtdeclarative-${QT_MIN_VER}:5 )
webkit? ( >=dev-qt/qtwebkit-5.9.1:5 )
diff --git a/sci-geosciences/qgis/qgis-9999.ebuild b/sci-geosciences/qgis/qgis-9999.ebuild
index 14ca3c37210..74129055f6b 100644
--- a/sci-geosciences/qgis/qgis-9999.ebuild
+++ b/sci-geosciences/qgis/qgis-9999.ebuild
@@ -73,22 +73,24 @@ COMMON_DEPEND="
postgres? ( dev-db/postgresql:= )
python? (
${PYTHON_DEPS}
- dev-python/future[${PYTHON_USEDEP}]
- dev-python/httplib2[${PYTHON_USEDEP}]
- dev-python/jinja[${PYTHON_USEDEP}]
- dev-python/markupsafe[${PYTHON_USEDEP}]
- dev-python/owslib[${PYTHON_USEDEP}]
- dev-python/pygments[${PYTHON_USEDEP}]
- dev-python/PyQt5[designer,network,sql,svg,webkit?,${PYTHON_USEDEP}]
- dev-python/python-dateutil[${PYTHON_USEDEP}]
- dev-python/pytz[${PYTHON_USEDEP}]
- dev-python/pyyaml[${PYTHON_USEDEP}]
- >=dev-python/qscintilla-python-2.10.1[qt5(+),${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- dev-python/sip:=[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
- >=sci-libs/gdal-2.2.3[python,${PYTHON_USEDEP}]
- postgres? ( dev-python/psycopg:2[${PYTHON_USEDEP}] )
+ $(python_gen_cond_dep '
+ dev-python/future[${PYTHON_MULTI_USEDEP}]
+ dev-python/httplib2[${PYTHON_MULTI_USEDEP}]
+ dev-python/jinja[${PYTHON_MULTI_USEDEP}]
+ dev-python/markupsafe[${PYTHON_MULTI_USEDEP}]
+ dev-python/owslib[${PYTHON_MULTI_USEDEP}]
+ dev-python/pygments[${PYTHON_MULTI_USEDEP}]
+ dev-python/PyQt5[designer,network,sql,svg,webkit?,${PYTHON_MULTI_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_MULTI_USEDEP}]
+ dev-python/pytz[${PYTHON_MULTI_USEDEP}]
+ dev-python/pyyaml[${PYTHON_MULTI_USEDEP}]
+ >=dev-python/qscintilla-python-2.10.1[qt5(+),${PYTHON_MULTI_USEDEP}]
+ dev-python/requests[${PYTHON_MULTI_USEDEP}]
+ dev-python/sip:=[${PYTHON_MULTI_USEDEP}]
+ dev-python/six[${PYTHON_MULTI_USEDEP}]
+ >=sci-libs/gdal-2.2.3[python,${PYTHON_MULTI_USEDEP}]
+ postgres? ( dev-python/psycopg:2[${PYTHON_MULTI_USEDEP}] )
+ ')
)
qml? ( >=dev-qt/qtdeclarative-${QT_MIN_VER}:5 )
webkit? ( >=dev-qt/qtwebkit-5.9.1:5 )