summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2021-04-04 22:20:29 +0200
committerDavid Seifert <soap@gentoo.org>2021-04-04 22:20:29 +0200
commitc3d1b4150aa7de28de8c142b1eb1dfb187985fe4 (patch)
tree887669f01ed9a1c6e3b88893682ebdd0ebe5e08b /sci-geosciences
parentsci-geosciences/opencpn-plugin-oesenc: need-wxwidgets -> setup-wxwidgets (diff)
downloadgentoo-c3d1b4150aa7de28de8c142b1eb1dfb187985fe4.tar.gz
gentoo-c3d1b4150aa7de28de8c142b1eb1dfb187985fe4.tar.bz2
gentoo-c3d1b4150aa7de28de8c142b1eb1dfb187985fe4.zip
sci-geosciences/opencpn-plugin-otcurrent: need-wxwidgets -> setup-wxwidgets
Bug: https://bugs.gentoo.org/770622 Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sci-geosciences')
-rw-r--r--sci-geosciences/opencpn-plugin-otcurrent/opencpn-plugin-otcurrent-1.2.ebuild27
-rw-r--r--sci-geosciences/opencpn-plugin-otcurrent/opencpn-plugin-otcurrent-9999.ebuild27
2 files changed, 26 insertions, 28 deletions
diff --git a/sci-geosciences/opencpn-plugin-otcurrent/opencpn-plugin-otcurrent-1.2.ebuild b/sci-geosciences/opencpn-plugin-otcurrent/opencpn-plugin-otcurrent-1.2.ebuild
index 0d88a9a5e632..d7fcccf5a579 100644
--- a/sci-geosciences/opencpn-plugin-otcurrent/opencpn-plugin-otcurrent-1.2.ebuild
+++ b/sci-geosciences/opencpn-plugin-otcurrent/opencpn-plugin-otcurrent-1.2.ebuild
@@ -1,18 +1,18 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
WX_GTK_VER="3.0"
+inherit cmake wxwidgets
+
MY_PN="otcurrent_pi"
-if [[ ${PV} == "9999" ]] ; then
+if [[ ${PV} == *9999 ]] ; then
+ inherit git-r3
EGIT_REPO_URI="https://github.com/Rasbats/${MY_PN}.git"
- inherit git-r3 cmake-utils wxwidgets
else
- SRC_URI="
- https://github.com/Rasbats/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
- "
- inherit cmake-utils wxwidgets
+ SRC_URI="https://github.com/Rasbats/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
KEYWORDS="~amd64 ~x86"
S="${WORKDIR}/${MY_PN}-${PV}"
fi
@@ -22,15 +22,14 @@ HOMEPAGE="https://github.com/Rasbats/otcurrent_pi"
LICENSE="GPL-2+"
SLOT="0"
-IUSE=""
RDEPEND="
x11-libs/wxGTK:${WX_GTK_VER}
- >=sci-geosciences/opencpn-4.2.0
- sys-devel/gettext
-"
+ >=sci-geosciences/opencpn-4.2.0"
DEPEND="${RDEPEND}"
-src_prepare() {
- need-wxwidgets unicode
- cmake-utils_src_prepare
+BDEPEND="sys-devel/gettext"
+
+src_configure() {
+ setup-wxwidgets unicode
+ cmake_src_configure
}
diff --git a/sci-geosciences/opencpn-plugin-otcurrent/opencpn-plugin-otcurrent-9999.ebuild b/sci-geosciences/opencpn-plugin-otcurrent/opencpn-plugin-otcurrent-9999.ebuild
index 0d88a9a5e632..d7fcccf5a579 100644
--- a/sci-geosciences/opencpn-plugin-otcurrent/opencpn-plugin-otcurrent-9999.ebuild
+++ b/sci-geosciences/opencpn-plugin-otcurrent/opencpn-plugin-otcurrent-9999.ebuild
@@ -1,18 +1,18 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
WX_GTK_VER="3.0"
+inherit cmake wxwidgets
+
MY_PN="otcurrent_pi"
-if [[ ${PV} == "9999" ]] ; then
+if [[ ${PV} == *9999 ]] ; then
+ inherit git-r3
EGIT_REPO_URI="https://github.com/Rasbats/${MY_PN}.git"
- inherit git-r3 cmake-utils wxwidgets
else
- SRC_URI="
- https://github.com/Rasbats/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
- "
- inherit cmake-utils wxwidgets
+ SRC_URI="https://github.com/Rasbats/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
KEYWORDS="~amd64 ~x86"
S="${WORKDIR}/${MY_PN}-${PV}"
fi
@@ -22,15 +22,14 @@ HOMEPAGE="https://github.com/Rasbats/otcurrent_pi"
LICENSE="GPL-2+"
SLOT="0"
-IUSE=""
RDEPEND="
x11-libs/wxGTK:${WX_GTK_VER}
- >=sci-geosciences/opencpn-4.2.0
- sys-devel/gettext
-"
+ >=sci-geosciences/opencpn-4.2.0"
DEPEND="${RDEPEND}"
-src_prepare() {
- need-wxwidgets unicode
- cmake-utils_src_prepare
+BDEPEND="sys-devel/gettext"
+
+src_configure() {
+ setup-wxwidgets unicode
+ cmake_src_configure
}