summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-libs/alglib
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-libs/alglib')
-rw-r--r--sci-libs/alglib/Manifest2
-rw-r--r--sci-libs/alglib/alglib-3.7.0.ebuild27
-rw-r--r--sci-libs/alglib/alglib-3.8.2.ebuild28
-rw-r--r--sci-libs/alglib/files/CMakeLists.txt32
-rw-r--r--sci-libs/alglib/files/CMakeLists.txt-3.8.236
-rw-r--r--sci-libs/alglib/metadata.xml38
6 files changed, 163 insertions, 0 deletions
diff --git a/sci-libs/alglib/Manifest b/sci-libs/alglib/Manifest
new file mode 100644
index 000000000000..76f161451943
--- /dev/null
+++ b/sci-libs/alglib/Manifest
@@ -0,0 +1,2 @@
+DIST alglib-3.7.0.cpp.tgz 1518417 SHA256 62100afea6f3e54606031065d28b484ef82b3a96732265a23d8e0f17e34bd36c SHA512 055a292512eb6b5bdb667a2cfb8fda33237b17f1b900ba086e20a541af0f41bc85aef935c1357d780b45f3b1f2e6acddea23f19cdafa25a08f821aa391fec285 WHIRLPOOL 7dce3c5057c2b356b4f361304f2bfa6281671bb1f45204895864db0013ee18127f9cb4a64b311369debdf1adad4b4cb594514a7387adc6f9b9c21ccb4dc549f6
+DIST alglib-3.8.2.cpp.tgz 1674260 SHA256 c02944558849c8b22f32f8dea03ebf3b77a0aab9aa2518927d25f6bfe7cb06a2 SHA512 3d7b6e3b5a29f25aee476bdd69e583d7504a2e06d390822b4aa2792eeb500e08c13477176be348a9dd560bad358e423465c9086f0c7c12f73dc88024364aed50 WHIRLPOOL 8ec5a51448c00241428f3b6c6191e31f94ee09dc1d94417178a59887edb8b4e8cfd561983bc4b31686971ad27c43e957aa7c1232e500000a0ea84e763f08ddcf
diff --git a/sci-libs/alglib/alglib-3.7.0.ebuild b/sci-libs/alglib/alglib-3.7.0.ebuild
new file mode 100644
index 000000000000..d10eef749b6d
--- /dev/null
+++ b/sci-libs/alglib/alglib-3.7.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit cmake-utils
+
+DESCRIPTION="Numerical analysis and data processing library"
+HOMEPAGE="http://www.alglib.net/"
+SRC_URI="http://www.alglib.net/translator/re/${P}.cpp.tgz"
+
+SLOT="0"
+LICENSE="GPL-2+"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+"
+
+S="${WORKDIR}"/cpp/
+
+src_prepare() {
+ cp "${FILESDIR}"/CMakeLists.txt . || die
+ cmake-utils_src_prepare
+}
diff --git a/sci-libs/alglib/alglib-3.8.2.ebuild b/sci-libs/alglib/alglib-3.8.2.ebuild
new file mode 100644
index 000000000000..8a0572f9b592
--- /dev/null
+++ b/sci-libs/alglib/alglib-3.8.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit cmake-utils
+
+DESCRIPTION="Numerical analysis and data processing library"
+HOMEPAGE="http://www.alglib.net/"
+SRC_URI="http://www.alglib.net/translator/re/${P}.cpp.tgz"
+
+SLOT="0"
+LICENSE="GPL-2+"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+S="${WORKDIR}"/cpp/
+
+src_prepare() {
+ cp "${FILESDIR}"/CMakeLists.txt-${PV} CMakeLists.txt || die
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=( $(cmake-utils_use_build test) )
+ cmake-utils_src_configure
+}
diff --git a/sci-libs/alglib/files/CMakeLists.txt b/sci-libs/alglib/files/CMakeLists.txt
new file mode 100644
index 000000000000..6455423b0fe9
--- /dev/null
+++ b/sci-libs/alglib/files/CMakeLists.txt
@@ -0,0 +1,32 @@
+project(alglib CXX)
+cmake_minimum_required(VERSION 2.8)
+
+INCLUDE(GNUInstallDirs)
+INCLUDE_DIRECTORIES(${CMAKE_SOURCE_DIR}/src)
+SET(VERSION 3.7.0)
+SET(SOVERSION 3.7)
+
+FILE(GLOB ALGLIB_SRC_LIB "src/*.cpp")
+FILE(GLOB ALGLIB_HDR_LIB "src/*.h")
+
+ADD_LIBRARY(alglib SHARED ${ALGLIB_SRC_LIB})
+SET_TARGET_PROPERTIES(alglib PROPERTIES
+ VERSION ${VERSION}
+ SOVERSION ${SOVERSION})
+
+INSTALL(TARGETS alglib DESTINATION ${CMAKE_INSTALL_LIBDIR}/)
+INSTALL(FILES ${ALGLIB_HDR_LIB} DESTINATION ${CMAKE_INSTALL_INCLUDEDIR})
+
+#===========================================================
+ADD_EXECUTABLE(test_c tests/test_c.cpp)
+TARGET_LINK_LIBRARIES(test_c alglib)
+#INSTALL(TARGETS test_c DESTINATION ${CMAKE_INSTALL_BINDIR}/)
+#===========================================================
+ADD_EXECUTABLE(test_i tests/test_i.cpp)
+TARGET_LINK_LIBRARIES(test_i alglib)
+#INSTALL(TARGETS test_i DESTINATION ${CMAKE_INSTALL_BINDIR}/)
+#===========================================================
+
+enable_testing()
+add_test( test_c ${CMAKE_BUILD_DIR}/test_c)
+add_test( test_i ${CMAKE_BUILD_DIR}/test_i)
diff --git a/sci-libs/alglib/files/CMakeLists.txt-3.8.2 b/sci-libs/alglib/files/CMakeLists.txt-3.8.2
new file mode 100644
index 000000000000..483c63dc7f59
--- /dev/null
+++ b/sci-libs/alglib/files/CMakeLists.txt-3.8.2
@@ -0,0 +1,36 @@
+project(alglib CXX)
+cmake_minimum_required(VERSION 2.8)
+
+INCLUDE(GNUInstallDirs)
+INCLUDE_DIRECTORIES(${CMAKE_SOURCE_DIR}/src)
+SET(VERSION 3.8.2)
+SET(SOVERSION 3.8)
+
+option(BUILD_TEST "Build tests" OFF)
+
+FILE(GLOB ALGLIB_SRC_LIB "src/*.cpp")
+FILE(GLOB ALGLIB_HDR_LIB "src/*.h")
+
+ADD_LIBRARY(alglib SHARED ${ALGLIB_SRC_LIB})
+SET_TARGET_PROPERTIES(alglib PROPERTIES
+ VERSION ${VERSION}
+ SOVERSION ${SOVERSION})
+
+INSTALL(TARGETS alglib DESTINATION ${CMAKE_INSTALL_LIBDIR}/)
+INSTALL(FILES ${ALGLIB_HDR_LIB} DESTINATION ${CMAKE_INSTALL_INCLUDEDIR})
+
+if (BUILD_TEST)
+ #===========================================================
+ ADD_EXECUTABLE(test_c tests/test_c.cpp)
+ TARGET_LINK_LIBRARIES(test_c alglib)
+ #INSTALL(TARGETS test_c DESTINATION ${CMAKE_INSTALL_BINDIR}/)
+ #===========================================================
+ ADD_EXECUTABLE(test_i tests/test_i.cpp)
+ TARGET_LINK_LIBRARIES(test_i alglib)
+ #INSTALL(TARGETS test_i DESTINATION ${CMAKE_INSTALL_BINDIR}/)
+ #===========================================================
+
+ enable_testing()
+endif (BUILD_TEST)
+add_test( test_c ${CMAKE_BUILD_DIR}/test_c)
+add_test( test_i ${CMAKE_BUILD_DIR}/test_i)
diff --git a/sci-libs/alglib/metadata.xml b/sci-libs/alglib/metadata.xml
new file mode 100644
index 000000000000..8fa350bffef2
--- /dev/null
+++ b/sci-libs/alglib/metadata.xml
@@ -0,0 +1,38 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci</herd>
+ <maintainer>
+ <email>jlec@gentoo.org</email>
+ </maintainer>
+ <longdescription>
+ALGLIB is a cross-platform numerical analysis and data processing library. It
+supports several programming languages (C++, C#, Pascal, VBA) and several
+operating systems (Windows, Linux, Solaris). ALGLIB features include:
+
+* Linear algebra (direct algorithms, EVD/SVD)
+* Solvers (linear and nonlinear)
+* Interpolation
+* Optimization
+* Fast Fourier transforms
+* Numerical integration
+* Linear and nonlinear least-squares fitting
+* Ordinary differential equations
+* Special functions
+* Statistics (descriptive statistics, hypothesis testing)
+* Data analysis (classification/regression, including neural networks)
+* Multiple precision versions of linear algebra, interpolation optimization and
+* others algorithms (using MPFR for floating point computations)
+
+Why to choose ALGLIB? Because it is:
+
+* portable. It can be compiled almost anywhere using almost any compiler
+(see compatibility matrix for more info).
+* easy to use. It supports many programming languages. If you use one language,
+you don't need to study another (FORTRAN, for example) to compile and link an
+external library.
+* open source. It can be used for free under GPL 2+.
+* suited for commercial users too. Those who want to use ALGLIB in commercial
+applications can buy commercial license without copyleft requirement.
+</longdescription>
+</pkgmetadata>