summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-libs/camd
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-libs/camd')
-rw-r--r--sci-libs/camd/Manifest1
-rw-r--r--sci-libs/camd/camd-2.3.1.ebuild29
-rw-r--r--sci-libs/camd/files/camd-2.2.0-autotools.patch71
-rw-r--r--sci-libs/camd/metadata.xml10
4 files changed, 111 insertions, 0 deletions
diff --git a/sci-libs/camd/Manifest b/sci-libs/camd/Manifest
new file mode 100644
index 000000000000..87acde08cd65
--- /dev/null
+++ b/sci-libs/camd/Manifest
@@ -0,0 +1 @@
+DIST camd-2.3.1.tar.bz2 319766 SHA256 bb3fcb577307fa4a70281bea8db896b2300a484f27cb61b392be2c4cf7cd5a2e SHA512 13c5d687b9314f43a6c7237c7541e0c21cc544ffe52f8a984f64c5177a9f1f6b5ab07e9190388587f273424db8e6076ef050f836dbc9f33ca44e94d0034c8070 WHIRLPOOL a53b09c002b930a78055742f507b3ea7b14906378edb6808e65e4aac16dcad8178cc16de6373d633356b501fb8a5939737f8c4966d94c1162076be5b1b15c2ad
diff --git a/sci-libs/camd/camd-2.3.1.ebuild b/sci-libs/camd/camd-2.3.1.ebuild
new file mode 100644
index 000000000000..b085672fa7db
--- /dev/null
+++ b/sci-libs/camd/camd-2.3.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools-utils
+
+DESCRIPTION="Library to order a sparse matrix prior to Cholesky factorization"
+HOMEPAGE="http://www.cise.ufl.edu/research/sparse/camd/"
+SRC_URI="http://dev.gentoo.org/~bicatali/distfiles/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+
+KEYWORDS="amd64 ~arm hppa ~mips ppc ppc64 sparc x86 ~amd64-fbsd ~amd64-linux ~x86-linux ~x86-macos"
+IUSE="doc static-libs"
+
+RDEPEND="sci-libs/suitesparseconfig"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( virtual/latex-base )"
+
+src_configure() {
+ local myeconfargs=(
+ $(use_with doc)
+ )
+ autotools-utils_src_configure
+}
diff --git a/sci-libs/camd/files/camd-2.2.0-autotools.patch b/sci-libs/camd/files/camd-2.2.0-autotools.patch
new file mode 100644
index 000000000000..d112a5f17169
--- /dev/null
+++ b/sci-libs/camd/files/camd-2.2.0-autotools.patch
@@ -0,0 +1,71 @@
+--- configure.ac 1970-01-01 01:00:00.000000000 +0100
++++ configure.ac 2008-01-31 15:35:15.579030692 +0000
+@@ -0,0 +1,12 @@
++# -*- Autoconf -*-
++AC_PREREQ(2.59)
++AC_INIT(camd, 2.2.0, davis@cise.ufl.edu)
++AM_INIT_AUTOMAKE([foreign])
++AC_PROG_INSTALL
++AC_PROG_LIBTOOL
++AC_CHECK_LIB(m, sqrt)
++AC_CHECK_HEADERS(UFconfig.h)
++AC_CONFIG_FILES([Source/Makefile
++ Demo/Makefile
++ Makefile])
++AC_OUTPUT
+--- ./Demo/Makefile.am 1970-01-01 01:00:00.000000000 +0100
++++ ./Demo/Makefile.am 2008-01-31 15:36:57.492838429 +0000
+@@ -0,0 +1,27 @@
++AM_CPPFLAGS = -I$(top_srcdir)/Include
++check_PROGRAMS = \
++ camd_demo \
++ camd_demo2 \
++ camd_simple
++# test is not robust
++# camd_l_demo
++
++LDADD = $(top_builddir)/Source/libcamd.la -lm
++
++camd_demo_SOURCES = camd_demo.c
++#camd_l_demo_SOURCES = camd_l_demo.c
++camd_demo2_SOURCES = camd_demo2.c
++camd_simple_SOURCES = camd_simple.c
++
++check-local: $(check_PROGRAMS)
++ @for i in $(check_PROGRAMS); do \
++ echo "Testing $$i"; \
++ ./$$i > my_$$i.out; \
++ if ! diff $(srcdir)/$$i.out my_$$i.out; then \
++ echo "Test $$i failed!"; \
++ exit 1; \
++ fi \
++ done;
++
++clean-local:
++ rm -f my*.out
+--- ./Source/Makefile.am 1970-01-01 01:00:00.000000000 +0100
++++ ./Source/Makefile.am 2008-01-31 15:37:17.205961816 +0000
+@@ -0,0 +1,17 @@
++CAMDCSRC = \
++ camd_aat.c camd_1.c camd_2.c camd_dump.c camd_postorder.c \
++ camd_defaults.c camd_order.c camd_control.c camd_info.c \
++ camd_valid.c camd_preprocess.c
++
++lib_LTLIBRARIES = libcamd.la
++noinst_LTLIBRARIES = libcamdi.la libcamdl.la
++AM_CPPFLAGS = -I$(top_srcdir)/Include
++
++libcamdi_la_SOURCES = $(CAMDCSRC)
++libcamdi_la_CPPFLAGS = $(AM_CPPFLAGS) -DDINT
++libcamdl_la_SOURCES = $(CAMDCSRC)
++libcamdl_la_CPPFLAGS = $(AM_CPPFLAGS) -DDLONG
++
++libcamd_la_SOURCES = camd_global.c
++libcamd_la_LIBADD = libcamdl.la libcamdi.la -lm
++
+--- ./Makefile.am 1970-01-01 01:00:00.000000000 +0100
++++ ./Makefile.am 2008-01-31 15:34:59.202097424 +0000
+@@ -0,0 +1,3 @@
++SUBDIRS = Demo Source
++EXTRA_DIST = README.txt
++include_HEADERS = Include/camd.h Include/camd_internal.h
diff --git a/sci-libs/camd/metadata.xml b/sci-libs/camd/metadata.xml
new file mode 100644
index 000000000000..9c4f1c34262f
--- /dev/null
+++ b/sci-libs/camd/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci</herd>
+ <longdescription lang="en">
+ Constrained Approximate Minimum Degree ordering is a set of routines
+ for ordering a sparse matrix prior to Cholesky factorization (or for
+ LU factorization with diagonal pivoting).
+</longdescription>
+</pkgmetadata>