summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorband-a-prend <torokhov-s-a@yandex.ru>2019-06-22 00:58:53 +0300
committerMichał Górny <mgorny@gentoo.org>2019-07-19 18:44:51 +0200
commitc0a49bf0854adc1729059f952a3f051008080a7e (patch)
treed0dda00a9ddb27f8c9315c70b01448afcd8c0cbb /sci-libs/cantera/cantera-2.4.0-r1.ebuild
parentapp-admin/hddtemp: [QA] Remove pkg_config(). (diff)
downloadgentoo-c0a49bf0854adc1729059f952a3f051008080a7e.tar.gz
gentoo-c0a49bf0854adc1729059f952a3f051008080a7e.tar.bz2
gentoo-c0a49bf0854adc1729059f952a3f051008080a7e.zip
sci-libs/cantera: 2.4.0-r1. Disable default optimization flag "-O3"
By default the optimization flag "-O3" was used with warning "-Wno-inline". The addition of expicit build option optimize_flags="-Wno-inline" now disables default "-O3" optimization flag in favor of options taken from "make.conf". Signed-off-by: Sergey Torokhov <torokhov_s_a@mail.ru> Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sci-libs/cantera/cantera-2.4.0-r1.ebuild')
-rw-r--r--sci-libs/cantera/cantera-2.4.0-r1.ebuild130
1 files changed, 130 insertions, 0 deletions
diff --git a/sci-libs/cantera/cantera-2.4.0-r1.ebuild b/sci-libs/cantera/cantera-2.4.0-r1.ebuild
new file mode 100644
index 000000000000..9d31e347b028
--- /dev/null
+++ b/sci-libs/cantera/cantera-2.4.0-r1.ebuild
@@ -0,0 +1,130 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{5,6} )
+
+FORTRAN_NEEDED=fortran
+FORTRAN_STANDARD=90
+
+inherit desktop fortran-2 python-single-r1 scons-utils toolchain-funcs
+
+DESCRIPTION="Object-oriented tool suite for chemical kinetics, thermodynamics, and transport"
+HOMEPAGE="http://www.cantera.org"
+SRC_URI="https://github.com/Cantera/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+cti fortran pch +python test"
+
+REQUIRED_USE="
+ cti? ( ${PYTHON_REQUIRED_USE} )
+ python? ( cti )
+ ${PYTHON_REQUIRED_USE}
+ "
+
+RDEPEND="
+ python? (
+ dev-python/numpy[${PYTHON_USEDEP}]
+ )
+ sci-libs/sundials:0=
+"
+
+DEPEND="
+ ${RDEPEND}
+ dev-cpp/eigen
+ dev-libs/boost
+ dev-libs/libfmt
+ python? (
+ dev-python/cython[${PYTHON_USEDEP}]
+ )
+ test? (
+ >=dev-cpp/gtest-1.8.0
+ )
+"
+
+PATCHES=( "${FILESDIR}/${PN}_${PV}_libdirname_variable.patch" )
+
+pkg_setup() {
+ fortran-2_pkg_setup
+ python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+ # patch to work 'scons test' properly in case of set up 'renamed_shared_libraries="no"' option
+ sed -i "s/, libs=\['cantera_shared'\]//" "${S}"/test_problems/SConscript || die "failed to modify 'test_problems/SConscript'"
+ # patch env to pass CCACHE_DIR variable
+ sed -i "s/ENV={'PATH': os.environ\['PATH'\]}/ENV={'PATH': os.environ\['PATH'\], 'CCACHE_DIR': os.environ.get('CCACHE_DIR','')}/" "${S}"/SConstruct || die "failed to modify 'SConstruct'"
+}
+
+## Full list of configuration options of Cantera is presented here:
+## http://cantera.org/docs/sphinx/html/compiling/config-options.html
+
+src_configure() {
+ scons_vars=(
+ CC="$(tc-getCC)"
+ CXX="$(tc-getCXX)"
+ cc_flags="${CXXFLAGS}"
+ cxx_flags="-std=c++11"
+ debug="no"
+ FORTRAN="$(tc-getFC)"
+ FORTRANFLAGS="${CXXFLAGS}"
+ optimize_flags="-Wno-inline"
+ renamed_shared_libraries="no"
+ use_pch=$(usex pch)
+## In some cases other order can break the detection of right location of Boost: ##
+ system_fmt="y"
+ system_sundials="y"
+ system_eigen="y"
+ env_vars="all"
+ extra_inc_dirs="/usr/include/eigen3"
+ )
+ use test || scons_vars+=( googletest="none" )
+
+ scons_targets=(
+ f90_interface=$(usex fortran y n)
+ python2_package="none"
+ )
+
+ if use cti ; then
+ local scons_python=$(usex python full minimal)
+ scons_targets+=( python3_package="${scons_python}" python3_cmd="${EPYTHON}" )
+ else
+ scons_targets+=( python3_package="none" )
+ fi
+}
+
+src_compile() {
+ escons build "${scons_vars[@]}" "${scons_targets[@]}" prefix="/usr"
+}
+
+src_test() {
+ escons test
+}
+
+src_install() {
+ escons install stage_dir="${D%/}" libdirname="$(get_libdir)"
+ if ! use cti ; then
+ rm -r "${D%/}/usr/share/man" || die "Can't remove man files."
+ else
+ # Run the byte-compile of modules
+ python_optimize "${D%/}/$(python_get_sitedir)/${PN}"
+ fi
+}
+
+pkg_postinst() {
+ if use cti && ! use python ; then
+ elog "Cantera was build without 'python' use-flag therefore the CTI tool 'ck2cti'"
+ elog "will convert Chemkin files to Cantera format without verification of kinetic mechanism."
+ fi
+
+ local post_msg=$(usex fortran "and Fortran " "")
+ elog "C++ ${post_msg}samples are installed to '/usr/share/${PN}/samples/' directory."
+
+ if use python ; then
+ elog "Python examples are installed to '$(python_get_sitedir)/${PN}/examples/' directories."
+ fi
+}