summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-12-31 13:42:16 +0100
committerJustin Lecher <jlec@gentoo.org>2015-12-31 13:55:03 +0100
commitb71be70a5e0eee017fc3ba5d3a9952bc55c1b1c7 (patch)
treeb5aad5431a166b6224066738487e0f6b0800f658 /sci-libs/cifparse-obj
parentdev-python/mock: dev-python/unittest2 is required in all versions (diff)
downloadgentoo-b71be70a5e0eee017fc3ba5d3a9952bc55c1b1c7.tar.gz
gentoo-b71be70a5e0eee017fc3ba5d3a9952bc55c1b1c7.tar.bz2
gentoo-b71be70a5e0eee017fc3ba5d3a9952bc55c1b1c7.zip
sci-libs/cifparse-obj: Add gcc5 support
Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=570254 Package-Manager: portage-2.2.26 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'sci-libs/cifparse-obj')
-rw-r--r--sci-libs/cifparse-obj/cifparse-obj-7.025-r1.ebuild3
-rw-r--r--sci-libs/cifparse-obj/files/cifparse-obj-7.025-gcc5.patch16
2 files changed, 18 insertions, 1 deletions
diff --git a/sci-libs/cifparse-obj/cifparse-obj-7.025-r1.ebuild b/sci-libs/cifparse-obj/cifparse-obj-7.025-r1.ebuild
index be87825947b7..a30d3b402d53 100644
--- a/sci-libs/cifparse-obj/cifparse-obj-7.025-r1.ebuild
+++ b/sci-libs/cifparse-obj/cifparse-obj-7.025-r1.ebuild
@@ -28,7 +28,8 @@ src_prepare() {
epatch \
"${FILESDIR}"/${P}-makefile.patch \
"${FILESDIR}"/${P}-gcc4.3.patch \
- "${FILESDIR}"/${P}-gcc4.7.patch
+ "${FILESDIR}"/${P}-gcc4.7.patch \
+ "${FILESDIR}"/${P}-gcc5.patch
sed \
-e "s:^\(CC=\).*:\1$(tc-getCC):g" \
diff --git a/sci-libs/cifparse-obj/files/cifparse-obj-7.025-gcc5.patch b/sci-libs/cifparse-obj/files/cifparse-obj-7.025-gcc5.patch
new file mode 100644
index 000000000000..6b2f797ccc15
--- /dev/null
+++ b/sci-libs/cifparse-obj/files/cifparse-obj-7.025-gcc5.patch
@@ -0,0 +1,16 @@
+ etc/platform.sh | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/etc/platform.sh b/etc/platform.sh
+index ff0ab51..1b56ab1 100755
+--- a/etc/platform.sh
++++ b/etc/platform.sh
+@@ -60,7 +60,7 @@ case `uname -s` in
+ # Check if it is a Linux platform
+ Linux)
+ # Check if it is GCC version 4.x
+- gcc_ver=`gcc --version | grep -e " 4\."`
++ gcc_ver=`gcc --version | grep -e " [45]\."`
+ if [[ -z $gcc_ver ]]
+ then
+ # It is not GCC version 4.x. Check if it is GCC version 3.x