summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2021-03-26 12:30:34 +0100
committerDavid Seifert <soap@gentoo.org>2021-03-26 12:30:34 +0100
commit38fe117e4a812fe142f2e8f491f17f0c93f2379b (patch)
treef0f6964d59fbd4d77d985041ab23bf2e613576cd /sci-libs/cmpfit/cmpfit-1.4.ebuild
parentsci-libs/alglib: Bump to 3.17.0 (diff)
downloadgentoo-38fe117e4a812fe142f2e8f491f17f0c93f2379b.tar.gz
gentoo-38fe117e4a812fe142f2e8f491f17f0c93f2379b.tar.bz2
gentoo-38fe117e4a812fe142f2e8f491f17f0c93f2379b.zip
sci-libs/cmpfit: Bump to 1.4
Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sci-libs/cmpfit/cmpfit-1.4.ebuild')
-rw-r--r--sci-libs/cmpfit/cmpfit-1.4.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/sci-libs/cmpfit/cmpfit-1.4.ebuild b/sci-libs/cmpfit/cmpfit-1.4.ebuild
new file mode 100644
index 000000000000..ff93f77a140c
--- /dev/null
+++ b/sci-libs/cmpfit/cmpfit-1.4.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="MINPACK-1 Least Squares Fitting Library in C"
+HOMEPAGE="http://www.physics.wisc.edu/~craigm/idl/cmpfit.html"
+SRC_URI="http://www.physics.wisc.edu/~craigm/idl/down/${P}.tar.gz"
+
+LICENSE="public-domain minpack"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+DOCS=( README DISCLAIMER )
+
+src_compile() {
+ $(tc-getCC) ${CFLAGS} ${CPPFLAGS} -fPIC -c mpfit.c -o mpfit.so || die "PIC compilation failed"
+ $(tc-getCC) ${LDFLAGS} -shared -Wl,-soname=libmpfit.so mpfit.so -lm -o libmpfit.so || die "linking failed"
+}
+
+src_test() {
+ $(tc-getCC) ${CFLAGS} ${CPPFLAGS} testmpfit.c -L. -lmpfit -lm -o testmpfit || die
+ LD_LIBRARY_PATH=.:${LD_LIBRARY_PATH} ./testmpfit || die
+}
+
+src_install() {
+ dolib.so libmpfit.so
+ doheader mpfit.h
+ einstalldocs
+}