summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-libs/coinor-couenne
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-libs/coinor-couenne')
-rw-r--r--sci-libs/coinor-couenne/Manifest1
-rw-r--r--sci-libs/coinor-couenne/coinor-couenne-0.4.7.ebuild59
-rw-r--r--sci-libs/coinor-couenne/metadata.xml12
3 files changed, 72 insertions, 0 deletions
diff --git a/sci-libs/coinor-couenne/Manifest b/sci-libs/coinor-couenne/Manifest
new file mode 100644
index 000000000000..7f33efbb443d
--- /dev/null
+++ b/sci-libs/coinor-couenne/Manifest
@@ -0,0 +1 @@
+DIST Couenne-0.4.7.tgz 12487353 SHA256 23d058aba7564878ec65cdf8aaba6bec83e3809b31520be1ca014444f25badf6 SHA512 ae87ebee778d6782fffe9e6f6c7c8f604140f6134e29824f89e4f87bb86ac00ac1b2d8de274b23de16078a48a1444fbe7960b15ffefdc1798dca8972a8946deb WHIRLPOOL 21d0d1ff4f9d1ea7daf6976546faf6eeaece5205a171763c71813872bd828696bce6b99d7b222e4dd61a637ee053bf5c1271794815eb4e027e5eecac3ace70de
diff --git a/sci-libs/coinor-couenne/coinor-couenne-0.4.7.ebuild b/sci-libs/coinor-couenne/coinor-couenne-0.4.7.ebuild
new file mode 100644
index 000000000000..1c15979804a2
--- /dev/null
+++ b/sci-libs/coinor-couenne/coinor-couenne-0.4.7.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools-utils multilib
+
+MYPN=Couenne
+
+DESCRIPTION="COIN-OR Convex Over and Under ENvelopes for Nonlinear Estimation"
+HOMEPAGE="https://projects.coin-or.org/Couenne/"
+SRC_URI="http://www.coin-or.org/download/source/${MYPN}/${MYPN}-${PV}.tgz"
+
+LICENSE="EPL-1.0"
+SLOT="0/1"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc static-libs test"
+
+RDEPEND="sci-libs/coinor-bonmin:="
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S="${WORKDIR}/${MYPN}-${PV}/${MYPN}"
+
+src_prepare() {
+ # needed for the --with-coin-instdir
+ dodir /usr
+ sed -i \
+ -e "s:lib/pkgconfig:$(get_libdir)/pkgconfig:g" \
+ configure || die
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ local myeconfargs=(
+ --enable-dependency-linking
+ --with-coin-instdir="${ED}"/usr
+ )
+ autotools-utils_src_configure
+}
+
+src_compile() {
+ autotools-utils_src_compile
+ # resolve as-needed
+ # circular dependencies between libCouenne and libBonCouenne :(
+ pushd "${BUILD_DIR}"/src > /dev/null
+ rm libCouenne.la main/libBonCouenne.la || die
+ emake LIBS+=" -Lmain/.libs -lBonCouenne" libCouenne.la
+ emake -C main
+ popd > /dev/null
+}
+
+src_install() {
+ autotools-utils_src_install
+ use doc && dodoc doc/couenne-user-manual.pdf
+ # already installed
+ rm "${ED}"/usr/share/coin/doc/${MYPN}/{README,AUTHORS,LICENSE} || die
+}
diff --git a/sci-libs/coinor-couenne/metadata.xml b/sci-libs/coinor-couenne/metadata.xml
new file mode 100644
index 000000000000..77cb214ea9d7
--- /dev/null
+++ b/sci-libs/coinor-couenne/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci</herd>
+<longdescription lang="en">
+ Couenne (Convex Over and Under ENvelopes for Nonlinear Estimation)
+ is a spatial branch and bound algorithm that implements linearization, bound
+ reduction, and branching techniques for Mixed-integer, Nonlinear
+ Programming (MINLP) problems. The purpose of Couenne is to find global
+ optima of nonconvex MINLPs.
+</longdescription>
+</pkgmetadata>