summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org>2019-05-05 04:46:00 +0200
committerMike Gilbert <floppym@gentoo.org>2019-05-05 15:04:02 -0400
commit57ecc0fe4b74dbf6019c5e1931750a64a5366ae6 (patch)
tree5fbd36a4a3646a9e99191ccd36eb55ff3ba94975 /sci-libs/fftw
parentnet-wireless/aircrack-ng: Depend on sys-apps/hwloc:0=. (diff)
downloadgentoo-57ecc0fe4b74dbf6019c5e1931750a64a5366ae6.tar.gz
gentoo-57ecc0fe4b74dbf6019c5e1931750a64a5366ae6.tar.bz2
gentoo-57ecc0fe4b74dbf6019c5e1931750a64a5366ae6.zip
sci-libs/fftw: Fix usage of tc-getCC().
Fixes: https://bugs.gentoo.org/618282 Signed-off-by: Arfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org> Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'sci-libs/fftw')
-rw-r--r--sci-libs/fftw/fftw-3.3.6_p2.ebuild4
-rw-r--r--sci-libs/fftw/fftw-3.3.8.ebuild2
-rw-r--r--sci-libs/fftw/fftw-9999.ebuild4
3 files changed, 5 insertions, 5 deletions
diff --git a/sci-libs/fftw/fftw-3.3.6_p2.ebuild b/sci-libs/fftw/fftw-3.3.6_p2.ebuild
index 35d91fe43ac0..4535c715b265 100644
--- a/sci-libs/fftw/fftw-3.3.6_p2.ebuild
+++ b/sci-libs/fftw/fftw-3.3.6_p2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -130,7 +130,7 @@ multilib_src_configure() {
;;
esac
- ECONF_SOURCE="${S}" econf "${myconf[@]}" MPICC="$(tc-getCC -lmpi)"
+ ECONF_SOURCE="${S}" econf "${myconf[@]}" MPICC="$(tc-getCC) -lmpi"
}
src_configure() {
diff --git a/sci-libs/fftw/fftw-3.3.8.ebuild b/sci-libs/fftw/fftw-3.3.8.ebuild
index d345f5d141f9..c89038acc6aa 100644
--- a/sci-libs/fftw/fftw-3.3.8.ebuild
+++ b/sci-libs/fftw/fftw-3.3.8.ebuild
@@ -131,7 +131,7 @@ multilib_src_configure() {
;;
esac
- ECONF_SOURCE="${S}" econf "${myconf[@]}" MPICC="$(tc-getCC -lmpi)"
+ ECONF_SOURCE="${S}" econf "${myconf[@]}" MPICC="$(tc-getCC) -lmpi"
}
src_configure() {
diff --git a/sci-libs/fftw/fftw-9999.ebuild b/sci-libs/fftw/fftw-9999.ebuild
index c08278dde801..a43b48e5809f 100644
--- a/sci-libs/fftw/fftw-9999.ebuild
+++ b/sci-libs/fftw/fftw-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -138,7 +138,7 @@ multilib_src_configure() {
MY_S="${BUILD_DIR}"
fi
- ECONF_SOURCE="${MY_S}" econf "${myconf[@]}" MPICC="$(tc-getCC -lmpi)"
+ ECONF_SOURCE="${MY_S}" econf "${myconf[@]}" MPICC="$(tc-getCC) -lmpi"
}
src_configure() {