summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-06-12 12:00:09 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-06-12 12:02:13 +0200
commite0d7c6e5e8fa39d87e399460567bd8a405e400a9 (patch)
tree8ff0cf8a5fc32e6487ccd52c0319f5aff43f4b50 /sci-libs/gdal
parentapp-office/scribus: Drop 1.5.5_pre20190124 (diff)
downloadgentoo-e0d7c6e5e8fa39d87e399460567bd8a405e400a9.tar.gz
gentoo-e0d7c6e5e8fa39d87e399460567bd8a405e400a9.tar.bz2
gentoo-e0d7c6e5e8fa39d87e399460567bd8a405e400a9.zip
sci-libs/gdal: Drop 2.4.0
Broken by current stable poppler. Package-Manager: Portage-2.3.67, Repoman-2.3.14 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'sci-libs/gdal')
-rw-r--r--sci-libs/gdal/Manifest1
-rw-r--r--sci-libs/gdal/files/gdal-2.3.1-poppler-0.72.0.patch58
-rw-r--r--sci-libs/gdal/files/gdal-2.3.1-poppler-0.73.0.patch35
-rw-r--r--sci-libs/gdal/gdal-2.4.0.ebuild323
4 files changed, 0 insertions, 417 deletions
diff --git a/sci-libs/gdal/Manifest b/sci-libs/gdal/Manifest
index 9c6acf61b8c..a20b22bcb90 100644
--- a/sci-libs/gdal/Manifest
+++ b/sci-libs/gdal/Manifest
@@ -1,2 +1 @@
-DIST gdal-2.4.0.tar.gz 14533664 BLAKE2B ec10a4a9ba438a758131c1b80286b27ee17f1f270e77af61d70ed4149d63b9224c98db9c55156075ebd86b5f0875c626d87df3779f0b981895ff1c00786f908e SHA512 9517b23009621ed2622a460dc813b30de726d293531c6f107fb308a31e45a143e67e71aa3af3d1faed554ad516a35924973d714c63ee41445ac8d3b2da61dd10
DIST gdal-2.4.1.tar.gz 14546610 BLAKE2B 92404336339c6f46877f3e6599af6fc67a53714888ff66fc0142efa8ddf185ad34d9ec337dcbad67f059041da31e70073a9e41872a7332fd9977552d79fcbc61 SHA512 b25e49f343986af6f37e0bec6dc3084cbcf1a0080da5cfd91d1a58c1d9ffd2ac355299d66534e63e89358cbb15ecd0f2ae934d91bbd2a3749889dadaf266e483
diff --git a/sci-libs/gdal/files/gdal-2.3.1-poppler-0.72.0.patch b/sci-libs/gdal/files/gdal-2.3.1-poppler-0.72.0.patch
deleted file mode 100644
index 3302df9100d..00000000000
--- a/sci-libs/gdal/files/gdal-2.3.1-poppler-0.72.0.patch
+++ /dev/null
@@ -1,58 +0,0 @@
-From b471814ef406582f2b1bc0aabbe430c0026608c7 Mon Sep 17 00:00:00 2001
-From: Andreas Sturmlechner <andreas.sturmlechner@gmail.com>
-Date: Sat, 12 Jan 2019 17:21:54 +0100
-Subject: [PATCH] Fix build with poppler-0.72.0
-
-Non-upstreamable patch that breaks backward compatibility.
----
- frmts/pdf/pdfdataset.cpp | 4 ++--
- frmts/pdf/pdfobject.cpp | 4 ++--
- 2 files changed, 4 insertions(+), 4 deletions(-)
-
-diff --git a/frmts/pdf/pdfdataset.cpp b/frmts/pdf/pdfdataset.cpp
-index 84fe1fe..38b8c30 100644
---- a/frmts/pdf/pdfdataset.cpp
-+++ b/frmts/pdf/pdfdataset.cpp
-@@ -3459,7 +3459,7 @@ void PDFDataset::FindLayersPoppler()
- #endif
- if( ocg != nullptr && ocg->getName() != nullptr )
- {
-- const char* pszLayerName = (const char*)ocg->getName()->getCString();
-+ const char* pszLayerName = (const char*)ocg->getName()->c_str();
- AddLayer(pszLayerName);
- oLayerOCGMapPoppler[pszLayerName] = ocg;
- }
-@@ -4787,7 +4787,7 @@ GDALDataset *PDFDataset::Open( GDALOpenInfo * poOpenInfo )
- GooString* poMetadata = poCatalogPoppler->readMetadata();
- if (poMetadata)
- {
-- const char* pszContent = poMetadata->getCString();
-+ const char* pszContent = poMetadata->c_str();
- if (pszContent != nullptr &&
- STARTS_WITH(pszContent, "<?xpacket begin="))
- {
-diff --git a/frmts/pdf/pdfobject.cpp b/frmts/pdf/pdfobject.cpp
-index 0a5f907..9bed6c1 100644
---- a/frmts/pdf/pdfobject.cpp
-+++ b/frmts/pdf/pdfobject.cpp
-@@ -1061,7 +1061,7 @@ const CPLString& GDALPDFObjectPoppler::GetString()
- #else
- GooString* gooString = m_po->getString();
- #endif
-- return (osStr = GDALPDFGetUTF8StringFromBytes(reinterpret_cast<const GByte*>(gooString->getCString()),
-+ return (osStr = GDALPDFGetUTF8StringFromBytes(reinterpret_cast<const GByte*>(gooString->c_str()),
- static_cast<int>(gooString->getLength())));
- }
- else
-@@ -1422,7 +1422,7 @@ char* GDALPDFStreamPoppler::GetBytes()
- char* pszContent = (char*) VSIMalloc(m_nLength + 1);
- if (pszContent)
- {
-- memcpy(pszContent, gstr->getCString(), m_nLength);
-+ memcpy(pszContent, gstr->c_str(), m_nLength);
- pszContent[m_nLength] = '\0';
- }
- delete gstr;
---
-2.20.1
-
diff --git a/sci-libs/gdal/files/gdal-2.3.1-poppler-0.73.0.patch b/sci-libs/gdal/files/gdal-2.3.1-poppler-0.73.0.patch
deleted file mode 100644
index 8529d99e735..00000000000
--- a/sci-libs/gdal/files/gdal-2.3.1-poppler-0.73.0.patch
+++ /dev/null
@@ -1,35 +0,0 @@
-From 77ea05388924fcf2a8c9fd4a777c97e4d69f5e17 Mon Sep 17 00:00:00 2001
-From: Andreas Sturmlechner <asturm@gentoo.org>
-Date: Wed, 16 Jan 2019 20:52:59 +0100
-Subject: [PATCH] Fix build with poppler-0.73
-
----
- gdal/frmts/pdf/pdfsdk_headers.h | 5 ++++-
- 1 file changed, 4 insertions(+), 1 deletion(-)
-
-diff --git a/frmts/pdf/pdfsdk_headers.h b/frmts/pdf/pdfsdk_headers.h
-index 9150b0f410..574943b41f 100644
---- a/frmts/pdf/pdfsdk_headers.h
-+++ b/frmts/pdf/pdfsdk_headers.h
-@@ -50,7 +50,6 @@
- #pragma warning( disable : 4244 ) /* conversion from 'const int' to 'Guchar', possible loss of data */
- #endif
-
--#include <goo/gtypes.h>
- #include <goo/GooList.h>
-
- /* begin of poppler xpdf includes */
-@@ -79,6 +78,10 @@
-
- /* end of poppler xpdf includes */
-
-+/* poppler-0.73 compatibility */
-+#define Guchar unsigned char
-+#define Guint unsigned int
-+
- #ifdef _MSC_VER
- #pragma warning( pop )
- #endif
---
-2.20.1
-
diff --git a/sci-libs/gdal/gdal-2.4.0.ebuild b/sci-libs/gdal/gdal-2.4.0.ebuild
deleted file mode 100644
index 999f213aac7..00000000000
--- a/sci-libs/gdal/gdal-2.4.0.ebuild
+++ /dev/null
@@ -1,323 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-GENTOO_DEPEND_ON_PERL="no"
-PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
-DISTUTILS_OPTIONAL=1
-
-inherit autotools perl-module distutils-r1 toolchain-funcs flag-o-matic java-pkg-opt-2
-
-DESCRIPTION="Translator library for raster geospatial data formats (includes OGR support)"
-HOMEPAGE="https://gdal.org/"
-SRC_URI="https://download.osgeo.org/${PN}/${PV}/${P}.tar.gz"
-
-SLOT="0/2.3"
-LICENSE="BSD Info-ZIP MIT"
-KEYWORDS="amd64 ~arm arm64 ~ia64 ppc ppc64 ~sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
-IUSE="armadillo +aux_xml curl debug doc fits geos gif gml hdf5 java jpeg jpeg2k lzma mdb mysql netcdf odbc ogdi opencl oracle pdf perl png postgres python spatialite sqlite threads webp xls zstd"
-
-COMMON_DEPEND="
- dev-libs/expat
- dev-libs/json-c:=
- dev-libs/libpcre
- dev-libs/libxml2:=
- media-libs/tiff:0=
- sci-libs/libgeotiff
- sys-libs/zlib:=[minizip(+)]
- armadillo? ( sci-libs/armadillo:=[lapack] )
- curl? ( net-misc/curl )
- fits? ( sci-libs/cfitsio:= )
- geos? ( >=sci-libs/geos-2.2.1 )
- gif? ( media-libs/giflib:= )
- gml? ( >=dev-libs/xerces-c-3.1 )
- hdf5? ( >=sci-libs/hdf5-1.6.4:=[szip] )
- jpeg? ( virtual/jpeg:0= )
- jpeg2k? ( media-libs/openjpeg:2= )
- lzma? ( || (
- app-arch/xz-utils
- app-arch/lzma
- ) )
- mdb? ( dev-java/jackcess:1 )
- mysql? ( virtual/mysql )
- netcdf? ( sci-libs/netcdf:= )
- odbc? ( dev-db/unixODBC )
- ogdi? ( sci-libs/ogdi )
- opencl? ( virtual/opencl )
- oracle? ( dev-db/oracle-instantclient:= )
- pdf? ( app-text/poppler:= )
- perl? ( dev-lang/perl:= )
- png? ( media-libs/libpng:0= )
- postgres? ( >=dev-db/postgresql-8.4:= )
- python? (
- ${PYTHON_DEPS}
- dev-python/numpy[${PYTHON_USEDEP}]
- )
- spatialite? ( dev-db/spatialite )
- sqlite? ( dev-db/sqlite:3 )
- webp? ( media-libs/libwebp:= )
- xls? ( dev-libs/freexl )
- zstd? ( app-arch/zstd:= )"
-
-RDEPEND="${COMMON_DEPEND}
- java? ( >=virtual/jre-1.7:* )"
-
-DEPEND="${COMMON_DEPEND}
- doc? ( app-doc/doxygen )
- java? ( >=virtual/jdk-1.7:* )
- perl? ( dev-lang/swig:0 )
- python? (
- dev-lang/swig:0
- dev-python/setuptools[${PYTHON_USEDEP}]
- )"
-
-REQUIRED_USE="
- mdb? ( java )
- python? ( ${PYTHON_REQUIRED_USE} )
- spatialite? ( sqlite )
-"
-
-PATCHES=(
- "${FILESDIR}/${PN}-2.2.3-soname.patch"
- "${FILESDIR}/${PN}-2.2.3-bashcomp-path.patch" # bug 641866
- "${FILESDIR}/${PN}-2.3.0-curl.patch" # bug 659840
-)
-
-src_prepare() {
- # fix datadir and docdir placement
- sed -e "s:@datadir@:@datadir@/gdal:" \
- -e "s:@exec_prefix@/doc:@exec_prefix@/share/doc/${PF}/html:g" \
- -i "${S}"/GDALmake.opt.in || die
-
- # the second sed expression should fix bug 371075
- sed -e "s:setup.py install:setup.py install --root=\$(DESTDIR):" \
- -e "s:--prefix=\$(DESTDIR):--prefix=:" \
- -i "${S}"/swig/python/GNUmakefile || die
-
- # Fix spatialite/sqlite include issue
- sed -e 's:spatialite/sqlite3.h:sqlite3.h:g' \
- -i ogr/ogrsf_frmts/sqlite/ogr_sqlite.h || die
-
- # Fix freexl configure check
- sed -e 's:FREEXL_LIBS=missing):FREEXL_LIBS=missing,-lm):g' \
- -i configure.ac || die
-
- sed -e "s: /usr/: \"${EPREFIX}\"/usr/:g" \
- -i configure.ac || die
-
- sed -e 's:^ar:$(AR):g' \
- -i ogr/ogrsf_frmts/sdts/install-libs.sh || die
-
- # updated for newer swig (must specify the path to input files)
- sed -e "s: gdal_array.i: ../include/gdal_array.i:" \
- -e "s:\$(DESTDIR)\$(prefix):\$(DESTDIR)\$(INST_PREFIX):g" \
- -i swig/python/GNUmakefile || die "sed python makefile failed"
- sed -e "s:library_dirs = :library_dirs = /usr/$(get_libdir):g" \
- -i swig/python/setup.cfg || die "sed python setup.cfg failed"
-
- default
-
- # fixed in git master or what will become 2.4.1:
- has_version ">=app-text/poppler-0.72.0" && eapply "${FILESDIR}/${PN}-2.3.1-poppler-0.72.0.patch"
- has_version ">=app-text/poppler-0.73.0" && eapply "${FILESDIR}/${PN}-2.3.1-poppler-0.73.0.patch"
-
- eautoreconf
-}
-
-src_configure() {
- # bug 619148
- append-cxxflags -std=c++14
-
- local myconf=(
- # charls - not packaged in Gentoo ebuild repository
- # kakadu, mrsid jp2mrsid - another jpeg2k stuff, ignore
- # bsb - legal issues
- # ingres - same story as oracle oci
- # jasper - disabled because unmaintained and vulnerable; openjpeg will be used as JPEG-2000 provider instead
- # podofo - we use poppler instead they are exclusive for each other
- # tiff is a hard dep
- --includedir="${EPREFIX}/usr/include/${PN}"
- --disable-pdf-plugin
- --disable-static
- --enable-shared
- --with-expat
- --with-cryptopp=no
- --with-geotiff
- --with-grib
- --with-hide-internal-symbols
- --with-libjson-c="${EPREFIX}/usr/"
- --with-libtiff
- --with-libtool
- --with-libz="${EPREFIX}/usr/"
- --with-gnm
- --without-bsb
- --without-charls
- --without-dods-root
- --without-ecw
- --without-epsilon
- --without-fgdb
- --without-fme
- --without-gta
- --without-grass
- --without-hdf4
- --without-idb
- --without-ingres
- --without-jasper
- --without-jp2lura
- --without-jp2mrsid
- --without-kakadu
- --without-kea
- --without-libkml
- --without-mongocxx
- --without-mrsid
- --without-mrsid_lidar
- --without-msg
- --without-mrf
- --without-rasdaman
- --without-rasterlite2
- --without-pcraster
- --without-pdfium
- --without-php
- --without-podofo
- --without-qhull
- --without-sde
- --without-sfcgal
- --without-sosi
- --without-teigha
- --disable-lto
- $(use_enable debug)
- $(use_with armadillo)
- $(use_with aux_xml pam)
- $(use_with curl)
- $(use_with fits cfitsio)
- $(use_with geos)
- $(use_with gif)
- $(use_with gml xerces)
- $(use_with hdf5)
- $(use_with jpeg pcidsk) # pcidsk is internal, because there is no such library yreleased developer by gdal
- $(use_with jpeg)
- $(use_with jpeg2k openjpeg)
- $(use_with lzma liblzma)
- $(use_with mysql mysql "${EPREFIX}"/usr/bin/mysql_config)
- $(use_with netcdf)
- $(use_with oracle oci)
- $(use_with odbc)
- $(use_with ogdi ogdi "${EPREFIX}"/usr)
- $(use_with opencl)
- $(use_with pdf poppler)
- $(use_with perl)
- $(use_with png)
- $(use_with postgres pg)
- $(use_with python)
- $(use_with spatialite)
- $(use_with sqlite sqlite3 "${EPREFIX}"/usr)
- $(use_with threads)
- $(use_with webp)
- $(use_with xls freexl)
- $(use_with zstd)
- )
-
- tc-export AR RANLIB
-
- if use java; then
- myconf+=(
- --with-java=$(java-config --jdk-home 2>/dev/null)
- --with-jvm-lib=dlopen
- $(use_with mdb)
- )
- else
- myconf+=( --without-java --without-mdb )
- fi
-
- if use sqlite; then
- append-libs -lsqlite3
- fi
-
- # bug #632660
- if use ogdi; then
- tc-export PKG_CONFIG
- append-cflags $(${PKG_CONFIG} --cflags libtirpc)
- append-cxxflags $(${PKG_CONFIG} --cflags libtirpc)
- fi
-
- ECONF_SOURCE="${S}" econf "${myconf[@]}"
-
- # mysql-config puts this in (and boy is it a PITA to get it out)
- if use mysql; then
- sed -e "s: -rdynamic : :" \
- -i GDALmake.opt || die "sed LIBS failed"
- fi
-}
-
-src_compile() {
- if use perl; then
- rm "${S}"/swig/perl/*_wrap.cpp || die
- emake -C "${S}"/swig/perl generate
- fi
-
- # gdal-config needed before generating Python bindings
- default
-
- if use perl ; then
- pushd "${S}"/swig/perl > /dev/null || die
- perl-module_src_configure
- perl-module_src_compile
- popd > /dev/null || die
- fi
-
- if use python; then
- rm -f "${S}"/swig/python/*_wrap.cpp || die
- emake -C "${S}"/swig/python generate
- pushd "${S}"/swig/python > /dev/null || die
- distutils-r1_src_compile
- popd > /dev/null || die
- fi
-
- use doc && emake docs
-}
-
-src_install() {
- if use perl ; then
- pushd "${S}"/swig/perl > /dev/null || die
- myinst=( DESTDIR="${D}" )
- perl-module_src_install
- popd > /dev/null || die
- sed -e 's:BINDINGS = \(.*\) perl:BINDINGS = \1:g' \
- -i GDALmake.opt || die
- fi
-
- use perl && perl_delete_localpod
-
- local DOCS=( Doxyfile HOWTO-RELEASE NEWS )
- use doc && HTML_DOCS=( html/. )
-
- default
-
- python_install() {
- distutils-r1_python_install
- python_doscript scripts/*.py
- }
-
- if use python; then
- # Don't clash with gdal's docs
- unset DOCS HTML_DOCS
-
- pushd "${S}"/swig/python > /dev/null || die
- distutils-r1_src_install
- popd > /dev/null || die
-
- newdoc swig/python/README.txt README-python.txt
-
- insinto /usr/share/${PN}/samples
- doins -r swig/python/samples/
- fi
-
- doman "${S}"/man/man*/*
- find "${ED}" -name '*.la' -delete || die
-}
-
-pkg_postinst() {
- elog "Check available image and data formats after building with"
- elog "gdalinfo and ogrinfo (using the --formats switch)."
-}