summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-05-19 22:11:04 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-05-19 22:55:13 +0200
commite1ee563d35d85e2ded85e14b200f45de464e7a29 (patch)
tree12bb4965ad912a34b72d743c758ae9d1725153bf /sci-libs/gdal
parentapp-admin/radmind: amd64 stable wrt bug #684598 (diff)
downloadgentoo-e1ee563d35d85e2ded85e14b200f45de464e7a29.tar.gz
gentoo-e1ee563d35d85e2ded85e14b200f45de464e7a29.tar.bz2
gentoo-e1ee563d35d85e2ded85e14b200f45de464e7a29.zip
sci-libs/gdal: Drop 2.3.1
Package-Manager: Portage-2.3.66, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'sci-libs/gdal')
-rw-r--r--sci-libs/gdal/Manifest1
-rw-r--r--sci-libs/gdal/files/gdal-2.3.1-poppler-0.69.0.patch301
-rw-r--r--sci-libs/gdal/files/gdal-2.3.1-poppler-0.71.0.patch82
-rw-r--r--sci-libs/gdal/gdal-2.3.1.ebuild326
4 files changed, 0 insertions, 710 deletions
diff --git a/sci-libs/gdal/Manifest b/sci-libs/gdal/Manifest
index e439b182d20..9c6acf61b8c 100644
--- a/sci-libs/gdal/Manifest
+++ b/sci-libs/gdal/Manifest
@@ -1,3 +1,2 @@
-DIST gdal-2.3.1.tar.gz 14450452 BLAKE2B 226ddf80ff8b9e3d420ac717b245a09fe3daa0331931f4d371b62ab9fa9bb0735ca11e1e045398de92d61b68815aa1dc3e7b6568f4853964cf42d188e46e6eb7 SHA512 0c5bb515dd2a9ad3110421b39bd680ce7e9de68e969cf35a7e63118965dbe193d25a7720a525e53af153de3e78f76ccc6983f4dcdfa6ba429d732a7a47a35d57
DIST gdal-2.4.0.tar.gz 14533664 BLAKE2B ec10a4a9ba438a758131c1b80286b27ee17f1f270e77af61d70ed4149d63b9224c98db9c55156075ebd86b5f0875c626d87df3779f0b981895ff1c00786f908e SHA512 9517b23009621ed2622a460dc813b30de726d293531c6f107fb308a31e45a143e67e71aa3af3d1faed554ad516a35924973d714c63ee41445ac8d3b2da61dd10
DIST gdal-2.4.1.tar.gz 14546610 BLAKE2B 92404336339c6f46877f3e6599af6fc67a53714888ff66fc0142efa8ddf185ad34d9ec337dcbad67f059041da31e70073a9e41872a7332fd9977552d79fcbc61 SHA512 b25e49f343986af6f37e0bec6dc3084cbcf1a0080da5cfd91d1a58c1d9ffd2ac355299d66534e63e89358cbb15ecd0f2ae934d91bbd2a3749889dadaf266e483
diff --git a/sci-libs/gdal/files/gdal-2.3.1-poppler-0.69.0.patch b/sci-libs/gdal/files/gdal-2.3.1-poppler-0.69.0.patch
deleted file mode 100644
index a89970074b0..00000000000
--- a/sci-libs/gdal/files/gdal-2.3.1-poppler-0.69.0.patch
+++ /dev/null
@@ -1,301 +0,0 @@
-From 0c0b9ea5a5d6bbef938de8a77c5b00cb228b902d Mon Sep 17 00:00:00 2001
-From: Even Rouault <even.rouault@spatialys.com>
-Date: Fri, 12 Oct 2018 19:02:40 +0200
-Subject: [PATCH] Add support for Poppler 0.69 (fixes #1004)
-
----
- GDALmake.opt.in | 1 +
- configure | 61 ++++++++++++++++++++++++++---------
- configure.ac | 56 +++++++++++++++++++++++---------
- frmts/pdf/GNUmakefile | 4 +++
- frmts/pdf/makefile.vc | 6 +++-
- frmts/pdf/pdfdataset.cpp | 12 +++++++
- nmake.opt | 2 ++
- 7 files changed, 111 insertions(+), 31 deletions(-)
-
-diff --git a/GDALmake.opt.in b/GDALmake.opt.in
-index 30749ae982a..f9ab41fd124 100644
---- a/GDALmake.opt.in
-+++ b/GDALmake.opt.in
-@@ -481,6 +481,7 @@ POPPLER_BASE_STREAM_HAS_TWO_ARGS = @POPPLER_BASE_STREAM_HAS_TWO_ARGS@
- POPPLER_0_20_OR_LATER = @POPPLER_0_20_OR_LATER@
- POPPLER_0_23_OR_LATER = @POPPLER_0_23_OR_LATER@
- POPPLER_0_58_OR_LATER = @POPPLER_0_58_OR_LATER@
-+POPPLER_0_69_OR_LATER = @POPPLER_0_69_OR_LATER@
- POPPLER_INC = @POPPLER_INC@
- POPPLER_PLUGIN_LIB = @POPPLER_PLUGIN_LIB@
-
-diff --git a/configure b/configure
-index 050bc79ac97..a8472ba8c2d 100755
---- a/configure
-+++ b/configure
-@@ -669,6 +669,7 @@ PODOFO_INC
- HAVE_PODOFO
- POPPLER_PLUGIN_LIB
- POPPLER_INC
-+POPPLER_0_69_OR_LATER
- POPPLER_0_58_OR_LATER
- POPPLER_0_23_OR_LATER
- POPPLER_0_20_OR_LATER
-@@ -34798,6 +34799,7 @@ POPPLER_BASE_STREAM_HAS_TWO_ARGS=no
- POPPLER_0_20_OR_LATER=no
- POPPLER_0_23_OR_LATER=no
- POPPLER_0_58_OR_LATER=no
-+POPPLER_0_69_OR_LATER=no
-
- { $as_echo "$as_me:${as_lineno-$LINENO}: checking for poppler" >&5
- $as_echo_n "checking for poppler... " >&6; }
-@@ -34840,24 +34842,51 @@ $as_echo "yes" >&6; }
-
- CHECK_OTHER_POPPLER_VERSION=yes
-
-- # And now we check if we have Poppler >= 0.58.0
-- { $as_echo "$as_me:${as_lineno-$LINENO}: checking if Object does have new API (>= 0.58.0)" >&5
-+ if test "$CHECK_OTHER_POPPLER_VERSION" = "yes"; then
-+ { $as_echo "$as_me:${as_lineno-$LINENO}: checking if OptionalContent has API >= 0.69.0" >&5
-+$as_echo_n "checking if OptionalContent has API >= 0.69.0... " >&6; }
-+ rm -f testpoppler.*
-+ echo '#include <poppler/OptionalContent.h>' > testpoppler.cpp
-+ echo 'int main(int argc, char** argv) {' >> testpoppler.cpp
-+ echo 'OCGs ocg(nullptr, nullptr);' >> testpoppler.cpp
-+ echo 'ocg.getOCGs().size();' >> testpoppler.cpp
-+ echo 'return 0; }' >> testpoppler.cpp
-+ if test -z "`${CXX} ${CXXFLAGS} ${CPPFLAGS} testpoppler.cpp -c ${POPPLER_INC} 2>&1`" ; then
-+ POPPLER_0_69_OR_LATER=yes
-+ POPPLER_0_58_OR_LATER=yes
-+ POPPLER_0_23_OR_LATER=yes
-+ POPPLER_0_20_OR_LATER=yes
-+ POPPLER_BASE_STREAM_HAS_TWO_ARGS=yes
-+ POPPLER_HAS_OPTCONTENT=yes
-+ CHECK_OTHER_POPPLER_VERSION=no
-+ { $as_echo "$as_me:${as_lineno-$LINENO}: result: yes" >&5
-+$as_echo "yes" >&6; }
-+ else
-+ { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
-+$as_echo "no" >&6; }
-+ fi
-+ fi
-+
-+ if test "$CHECK_OTHER_POPPLER_VERSION" = "yes"; then
-+ # And now we check if we have Poppler >= 0.58.0
-+ { $as_echo "$as_me:${as_lineno-$LINENO}: checking if Object does have new API (>= 0.58.0)" >&5
- $as_echo_n "checking if Object does have new API (>= 0.58.0)... " >&6; }
-- rm -f testpoppler.*
-- echo '#include <poppler/Object.h>' > testpoppler.cpp
-- echo 'int main(int argc, char** argv) { Object o(objNull); return 0; }' >> testpoppler.cpp
-- if test -z "`${CXX} ${CXXFLAGS} ${CPPFLAGS} testpoppler.cpp -c ${POPPLER_INC} 2>&1`" ; then
-- POPPLER_0_58_OR_LATER=yes
-- POPPLER_0_23_OR_LATER=yes
-- POPPLER_0_20_OR_LATER=yes
-- POPPLER_BASE_STREAM_HAS_TWO_ARGS=yes
-- POPPLER_HAS_OPTCONTENT=yes
-- CHECK_OTHER_POPPLER_VERSION=no
-- { $as_echo "$as_me:${as_lineno-$LINENO}: result: yes" >&5
-+ rm -f testpoppler.*
-+ echo '#include <poppler/Object.h>' > testpoppler.cpp
-+ echo 'int main(int argc, char** argv) { Object o(objNull); return 0; }' >> testpoppler.cpp
-+ if test -z "`${CXX} ${CXXFLAGS} ${CPPFLAGS} testpoppler.cpp -c ${POPPLER_INC} 2>&1`" ; then
-+ POPPLER_0_58_OR_LATER=yes
-+ POPPLER_0_23_OR_LATER=yes
-+ POPPLER_0_20_OR_LATER=yes
-+ POPPLER_BASE_STREAM_HAS_TWO_ARGS=yes
-+ POPPLER_HAS_OPTCONTENT=yes
-+ CHECK_OTHER_POPPLER_VERSION=no
-+ { $as_echo "$as_me:${as_lineno-$LINENO}: result: yes" >&5
- $as_echo "yes" >&6; }
-- else
-- { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
-+ else
-+ { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
- $as_echo "no" >&6; }
-+ fi
- fi
-
- if test "$CHECK_OTHER_POPPLER_VERSION" = "yes"; then
-@@ -34962,6 +34991,8 @@ POPPLER_0_23_OR_LATER=$POPPLER_0_23_OR_LATER
-
- POPPLER_0_58_OR_LATER=$POPPLER_0_58_OR_LATER
-
-+POPPLER_0_69_OR_LATER=$POPPLER_0_69_OR_LATER
-+
- POPPLER_INC=$POPPLER_INC
-
- POPPLER_PLUGIN_LIB=$POPPLER_PLUGIN_LIB
-diff --git a/configure.ac b/configure.ac
-index 4b8ab911cec..0c588e04f03 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -4496,6 +4496,7 @@ POPPLER_BASE_STREAM_HAS_TWO_ARGS=no
- POPPLER_0_20_OR_LATER=no
- POPPLER_0_23_OR_LATER=no
- POPPLER_0_58_OR_LATER=no
-+POPPLER_0_69_OR_LATER=no
-
- AC_MSG_CHECKING([for poppler])
-
-@@ -4536,21 +4537,45 @@ if test "$with_poppler" != "no" -a "$with_poppler" != ""; then
-
- CHECK_OTHER_POPPLER_VERSION=yes
-
-- # And now we check if we have Poppler >= 0.58.0
-- AC_MSG_CHECKING([if Object does have new API (>= 0.58.0)])
-- rm -f testpoppler.*
-- echo '#include <poppler/Object.h>' > testpoppler.cpp
-- echo 'int main(int argc, char** argv) { Object o(objNull); return 0; }' >> testpoppler.cpp
-- if test -z "`${CXX} ${CXXFLAGS} ${CPPFLAGS} testpoppler.cpp -c ${POPPLER_INC} 2>&1`" ; then
-- POPPLER_0_58_OR_LATER=yes
-- POPPLER_0_23_OR_LATER=yes
-- POPPLER_0_20_OR_LATER=yes
-- POPPLER_BASE_STREAM_HAS_TWO_ARGS=yes
-- POPPLER_HAS_OPTCONTENT=yes
-- CHECK_OTHER_POPPLER_VERSION=no
-- AC_MSG_RESULT([yes])
-- else
-- AC_MSG_RESULT([no])
-+ if test "$CHECK_OTHER_POPPLER_VERSION" = "yes"; then
-+ AC_MSG_CHECKING([if OptionalContent has API >= 0.69.0])
-+ rm -f testpoppler.*
-+ echo '#include <poppler/OptionalContent.h>' > testpoppler.cpp
-+ echo 'int main(int argc, char** argv) {' >> testpoppler.cpp
-+ echo 'OCGs ocg(nullptr, nullptr);' >> testpoppler.cpp
-+ echo 'ocg.getOCGs().size();' >> testpoppler.cpp
-+ echo 'return 0; }' >> testpoppler.cpp
-+ if test -z "`${CXX} ${CXXFLAGS} ${CPPFLAGS} testpoppler.cpp -c ${POPPLER_INC} 2>&1`" ; then
-+ POPPLER_0_69_OR_LATER=yes
-+ POPPLER_0_58_OR_LATER=yes
-+ POPPLER_0_23_OR_LATER=yes
-+ POPPLER_0_20_OR_LATER=yes
-+ POPPLER_BASE_STREAM_HAS_TWO_ARGS=yes
-+ POPPLER_HAS_OPTCONTENT=yes
-+ CHECK_OTHER_POPPLER_VERSION=no
-+ AC_MSG_RESULT([yes])
-+ else
-+ AC_MSG_RESULT([no])
-+ fi
-+ fi
-+
-+ if test "$CHECK_OTHER_POPPLER_VERSION" = "yes"; then
-+ # And now we check if we have Poppler >= 0.58.0
-+ AC_MSG_CHECKING([if Object does have new API (>= 0.58.0)])
-+ rm -f testpoppler.*
-+ echo '#include <poppler/Object.h>' > testpoppler.cpp
-+ echo 'int main(int argc, char** argv) { Object o(objNull); return 0; }' >> testpoppler.cpp
-+ if test -z "`${CXX} ${CXXFLAGS} ${CPPFLAGS} testpoppler.cpp -c ${POPPLER_INC} 2>&1`" ; then
-+ POPPLER_0_58_OR_LATER=yes
-+ POPPLER_0_23_OR_LATER=yes
-+ POPPLER_0_20_OR_LATER=yes
-+ POPPLER_BASE_STREAM_HAS_TWO_ARGS=yes
-+ POPPLER_HAS_OPTCONTENT=yes
-+ CHECK_OTHER_POPPLER_VERSION=no
-+ AC_MSG_RESULT([yes])
-+ else
-+ AC_MSG_RESULT([no])
-+ fi
- fi
-
- if test "$CHECK_OTHER_POPPLER_VERSION" = "yes"; then
-@@ -4635,6 +4660,7 @@ AC_SUBST(POPPLER_BASE_STREAM_HAS_TWO_ARGS, $POPPLER_BASE_STREAM_HAS_TWO_ARGS)
- AC_SUBST(POPPLER_0_20_OR_LATER, $POPPLER_0_20_OR_LATER)
- AC_SUBST(POPPLER_0_23_OR_LATER, $POPPLER_0_23_OR_LATER)
- AC_SUBST(POPPLER_0_58_OR_LATER, $POPPLER_0_58_OR_LATER)
-+AC_SUBST(POPPLER_0_69_OR_LATER, $POPPLER_0_69_OR_LATER)
- AC_SUBST(POPPLER_INC, $POPPLER_INC)
- AC_SUBST(POPPLER_PLUGIN_LIB, $POPPLER_PLUGIN_LIB)
-
-diff --git a/frmts/pdf/GNUmakefile b/frmts/pdf/GNUmakefile
-index 2c332d2798f..6a267f529b2 100644
---- a/frmts/pdf/GNUmakefile
-+++ b/frmts/pdf/GNUmakefile
-@@ -34,6 +34,10 @@ ifeq ($(POPPLER_0_58_OR_LATER),yes)
- CPPFLAGS += -DPOPPLER_0_58_OR_LATER
- endif
-
-+ifeq ($(POPPLER_0_69_OR_LATER),yes)
-+CPPFLAGS += -DPOPPLER_0_69_OR_LATER
-+endif
-+
- ifeq ($(HAVE_PODOFO),yes)
- CPPFLAGS += -DHAVE_PODOFO
- endif
-diff --git a/frmts/pdf/makefile.vc b/frmts/pdf/makefile.vc
-index b4fa14d0a18..ad76d3de70c 100644
---- a/frmts/pdf/makefile.vc
-+++ b/frmts/pdf/makefile.vc
-@@ -14,7 +14,7 @@ OBJ = $(OBJ) ..\..\ogr\ogrsf_frmts\mem\ogrmemdatasource.obj ..\..\ogr\ogrsf_frmt
- EXTRAFLAGS = -I..\vrt -I..\mem -I..\..\ogr\ogrsf_frmts\mem $(POPPLER_EXTRAFLAGS) $(PODOFO_EXTRAFLAGS) $(PDFIUM_EXTRAFLAGS)
-
- !IFDEF POPPLER_ENABLED
--POPPLER_EXTRAFLAGS = $(POPPLER_CFLAGS) $(POPPLER_HAS_OPTCONTENT_FLAGS) $(POPPLER_BASE_STREAM_HAS_TWO_ARGS_FLAGS) $(POPPLER_0_20_OR_LATER_FLAGS) $(POPPLER_0_23_OR_LATER_FLAGS) $(POPPLER_0_58_OR_LATER_FLAGS) -DHAVE_POPPLER
-+POPPLER_EXTRAFLAGS = $(POPPLER_CFLAGS) $(POPPLER_HAS_OPTCONTENT_FLAGS) $(POPPLER_BASE_STREAM_HAS_TWO_ARGS_FLAGS) $(POPPLER_0_20_OR_LATER_FLAGS) $(POPPLER_0_23_OR_LATER_FLAGS) $(POPPLER_0_58_OR_LATER_FLAGS) $(POPPLER_0_69_OR_LATER_FLAGS) -DHAVE_POPPLER
-
- !IFDEF POPPLER_HAS_OPTCONTENT
- POPPLER_HAS_OPTCONTENT_FLAGS = -DPOPPLER_HAS_OPTCONTENT
-@@ -36,6 +36,10 @@ POPPLER_0_23_OR_LATER_FLAGS = -DPOPPLER_0_23_OR_LATER
- POPPLER_0_58_OR_LATER_FLAGS = -DPOPPLER_0_58_OR_LATER
- !ENDIF
-
-+!IFDEF POPPLER_0_69_OR_LATER
-+POPPLER_0_69_OR_LATER_FLAGS = -DPOPPLER_0_69_OR_LATER
-+!ENDIF
-+
- !ENDIF
-
- !IFDEF PODOFO_ENABLED
-diff --git a/frmts/pdf/pdfdataset.cpp b/frmts/pdf/pdfdataset.cpp
-index ee89fd07564..1a56f57ee06 100644
---- a/frmts/pdf/pdfdataset.cpp
-+++ b/frmts/pdf/pdfdataset.cpp
-@@ -3440,10 +3440,16 @@ void PDFDataset::FindLayersPoppler()
- }
- else
- {
-+#ifdef POPPLER_0_69_OR_LATER
-+ for( const auto& refOCGPair: optContentConfig->getOCGs() )
-+ {
-+ auto ocg = refOCGPair.second.get();
-+#else
- GooList* ocgList = optContentConfig->getOCGs();
- for(int i=0;i<ocgList->getLength();i++)
- {
- OptionalContentGroup* ocg = (OptionalContentGroup*) ocgList->get(i);
-+#endif
- if( ocg != nullptr && ocg->getName() != nullptr )
- {
- const char* pszLayerName = (const char*)ocg->getName()->getCString();
-@@ -3472,10 +3478,16 @@ void PDFDataset::TurnLayersOnOffPoppler()
- {
- int i;
- int bAll = EQUAL(pszLayers, "ALL");
-+#ifdef POPPLER_0_69_OR_LATER
-+ for( const auto& refOCGPair: optContentConfig->getOCGs() )
-+ {
-+ auto ocg = refOCGPair.second.get();
-+#else
- GooList* ocgList = optContentConfig->getOCGs();
- for(i=0;i<ocgList->getLength();i++)
- {
- OptionalContentGroup* ocg = (OptionalContentGroup*) ocgList->get(i);
-+#endif
- ocg->setState( (bAll) ? OptionalContentGroup::On : OptionalContentGroup::Off );
- }
-
-diff --git a/nmake.opt b/nmake.opt
-index 682d766d93e..1eb049038c8 100644
---- a/nmake.opt
-+++ b/nmake.opt
-@@ -639,6 +639,7 @@ OCI_INCLUDE = -I$(ORACLE_HOME)\oci\include
- # Uncomment POPPLER_0_20_OR_LATER = YES for Poppler >= 0.20.0
- # Uncomment POPPLER_0_23_OR_LATER = YES for Poppler >= 0.23.0
- # Uncomment POPPLER_0_58_OR_LATER = YES for Poppler >= 0.58.0
-+# Uncomment POPPLER_0_69_OR_LATER = YES for Poppler >= 0.69.0
- #POPPLER_ENABLED = YES
- #POPPLER_CFLAGS = -Ie:/kde/include -Ie:/kde/include/poppler
- #POPPLER_HAS_OPTCONTENT = YES
-@@ -646,6 +647,7 @@ OCI_INCLUDE = -I$(ORACLE_HOME)\oci\include
- #POPPLER_0_20_OR_LATER = YES
- #POPPLER_0_23_OR_LATER = YES
- #POPPLER_0_58_OR_LATER = YES
-+#POPPLER_0_69_OR_LATER = YES
- #POPPLER_LIBS = e:/kde/lib/poppler.lib e:/kde/lib/freetype.lib e:/kde/lib/liblcms-1.lib advapi32.lib gdi32.lib
-
- # Uncomment for PDF support
diff --git a/sci-libs/gdal/files/gdal-2.3.1-poppler-0.71.0.patch b/sci-libs/gdal/files/gdal-2.3.1-poppler-0.71.0.patch
deleted file mode 100644
index 90ee94d0621..00000000000
--- a/sci-libs/gdal/files/gdal-2.3.1-poppler-0.71.0.patch
+++ /dev/null
@@ -1,82 +0,0 @@
-Description: Add support for Poppler 0.71.0.
-Author: Even Rouault <even.rouault@spatialys.com>
-Origin: https://github.com/OSGeo/gdal/commit/4cc0215b8f2cef3582265cdfaf16589390697706
-Bug: https://github.com/OSGeo/gdal/issues/1121
-Bug-Debian: https://bugs.debian.org/915722
-
---- a/frmts/pdf/pdfdataset.cpp
-+++ b/frmts/pdf/pdfdataset.cpp
-@@ -2593,18 +2593,25 @@ static void PDFDatasetErrorFunctionCommo
- }
-
- #ifdef POPPLER_0_20_OR_LATER
--static void PDFDatasetErrorFunction(CPL_UNUSED void* userData, CPL_UNUSED ErrorCategory eErrCategory,
-+
-+static void PDFDatasetErrorFunction(void* /* userData*/,
-+ ErrorCategory /* eErrCategory */,
- #ifdef POPPLER_0_23_OR_LATER
- Goffset nPos,
- #else
- int nPos,
- #endif
-- char *pszMsg)
-+#ifdef POPPLER_0_71_OR_LATER
-+ const char *pszMsg
-+#else
-+ char *pszMsg
-+#endif
-+ )
- {
- CPLString osError;
-
- if (nPos >= 0)
-- osError.Printf("Pos = %d, ", (int)nPos);
-+ osError.Printf("Pos = " CPL_FRMT_GUIB ", ", static_cast<GUIntBig>(nPos));
- osError += pszMsg;
- PDFDatasetErrorFunctionCommon(osError);
- }
-@@ -4442,7 +4449,7 @@ GDALDataset *PDFDataset::Open( GDALOpenI
- #ifdef HAVE_POPPLER
- if (bUseLib.test(PDFLIB_POPPLER))
- {
-- PDFRectangle* psMediaBox = poPagePoppler->getMediaBox();
-+ const auto* psMediaBox = poPagePoppler->getMediaBox();
- dfX1 = psMediaBox->x1;
- dfY1 = psMediaBox->y1;
- dfX2 = psMediaBox->x2;
-@@ -4780,14 +4787,12 @@ GDALDataset *PDFDataset::Open( GDALOpenI
- GooString* poMetadata = poCatalogPoppler->readMetadata();
- if (poMetadata)
- {
-- char* pszContent = poMetadata->getCString();
-+ const char* pszContent = poMetadata->getCString();
- if (pszContent != nullptr &&
- STARTS_WITH(pszContent, "<?xpacket begin="))
- {
-- char *apszMDList[2];
-- apszMDList[0] = pszContent;
-- apszMDList[1] = nullptr;
-- poDS->SetMetadata(apszMDList, "xml:XMP");
-+ const char * const apszMDList[2] = { pszContent, nullptr };
-+ poDS->SetMetadata(const_cast<char**>(apszMDList), "xml:XMP");
- }
- delete poMetadata;
- }
---- a/frmts/pdf/pdfio.h
-+++ b/frmts/pdf/pdfio.h
-@@ -58,6 +58,15 @@
- #define makeSubStream_object_type Object*
- #endif
-
-+// Detect Poppler 0.71 that no longer defines GBool
-+#ifdef POPPLER_0_69_OR_LATER
-+#ifndef initObj
-+#define POPPLER_0_71_OR_LATER
-+#define GBool bool
-+#define gFalse false
-+#endif
-+#endif
-+
- class VSIPDFFileStream: public BaseStream
- {
- public:
diff --git a/sci-libs/gdal/gdal-2.3.1.ebuild b/sci-libs/gdal/gdal-2.3.1.ebuild
deleted file mode 100644
index da763e365dc..00000000000
--- a/sci-libs/gdal/gdal-2.3.1.ebuild
+++ /dev/null
@@ -1,326 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-GENTOO_DEPEND_ON_PERL="no"
-PYTHON_COMPAT=( python2_7 python3_{5,6} )
-DISTUTILS_OPTIONAL=1
-
-inherit autotools perl-module distutils-r1 toolchain-funcs flag-o-matic java-pkg-opt-2
-
-DESCRIPTION="Translator library for raster geospatial data formats (includes OGR support)"
-HOMEPAGE="https://www.gdal.org/"
-SRC_URI="https://download.osgeo.org/${PN}/${PV}/${P}.tar.gz"
-
-SLOT="0/2.3"
-LICENSE="BSD Info-ZIP MIT"
-KEYWORDS="amd64 ~arm ~arm64 ~ia64 ppc ppc64 ~sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
-IUSE="armadillo +aux_xml curl debug doc fits geos gif gml hdf5 java jpeg jpeg2k lzma mdb mysql netcdf odbc ogdi opencl oracle pdf perl png postgres python spatialite sqlite threads webp xls zstd"
-
-COMMON_DEPEND="
- dev-libs/expat
- dev-libs/json-c:=
- dev-libs/libpcre
- dev-libs/libxml2:=
- media-libs/tiff:0=
- sci-libs/libgeotiff
- sys-libs/zlib:=[minizip(+)]
- armadillo? ( sci-libs/armadillo:=[lapack] )
- curl? ( net-misc/curl )
- fits? ( sci-libs/cfitsio:= )
- geos? ( >=sci-libs/geos-2.2.1 )
- gif? ( media-libs/giflib:= )
- gml? ( >=dev-libs/xerces-c-3.1 )
- hdf5? ( >=sci-libs/hdf5-1.6.4:=[szip] )
- jpeg? ( virtual/jpeg:0= )
- jpeg2k? ( media-libs/openjpeg:2= )
- lzma? ( || (
- app-arch/xz-utils
- app-arch/lzma
- ) )
- mdb? ( dev-java/jackcess:1 )
- mysql? ( virtual/mysql )
- netcdf? ( sci-libs/netcdf:= )
- odbc? ( dev-db/unixODBC )
- ogdi? ( sci-libs/ogdi )
- opencl? ( virtual/opencl )
- oracle? ( dev-db/oracle-instantclient:= )
- pdf? ( app-text/poppler:= )
- perl? ( dev-lang/perl:= )
- png? ( media-libs/libpng:0= )
- postgres? ( >=dev-db/postgresql-8.4:= )
- python? (
- ${PYTHON_DEPS}
- dev-python/numpy[${PYTHON_USEDEP}]
- )
- spatialite? ( dev-db/spatialite )
- sqlite? ( dev-db/sqlite:3 )
- webp? ( media-libs/libwebp:= )
- xls? ( dev-libs/freexl )
- zstd? ( app-arch/zstd:= )"
-
-RDEPEND="${COMMON_DEPEND}
- java? ( >=virtual/jre-1.7:* )"
-
-DEPEND="${COMMON_DEPEND}
- doc? ( app-doc/doxygen )
- java? ( >=virtual/jdk-1.7:* )
- perl? ( dev-lang/swig:0 )
- python? (
- dev-lang/swig:0
- dev-python/setuptools[${PYTHON_USEDEP}]
- )"
-
-REQUIRED_USE="
- mdb? ( java )
- python? ( ${PYTHON_REQUIRED_USE} )
- spatialite? ( sqlite )
-"
-
-PATCHES=(
- "${FILESDIR}/${PN}-2.2.3-soname.patch"
- "${FILESDIR}/${PN}-2.2.3-bashcomp-path.patch" # bug 641866
- "${FILESDIR}/${PN}-2.3.0-curl.patch" # bug 659840
- # fixed in 2.4.0:
- "${FILESDIR}/${P}-poppler-0.69.0.patch"
- "${FILESDIR}/${P}-poppler-0.71.0.patch" # bug 674556
-)
-
-src_prepare() {
- # fix datadir and docdir placement
- sed -e "s:@datadir@:@datadir@/gdal:" \
- -e "s:@exec_prefix@/doc:@exec_prefix@/share/doc/${PF}/html:g" \
- -i "${S}"/GDALmake.opt.in || die
-
- # the second sed expression should fix bug 371075
- sed -e "s:setup.py install:setup.py install --root=\$(DESTDIR):" \
- -e "s:--prefix=\$(DESTDIR):--prefix=:" \
- -i "${S}"/swig/python/GNUmakefile || die
-
- # Fix spatialite/sqlite include issue
- sed -e 's:spatialite/sqlite3.h:sqlite3.h:g' \
- -i ogr/ogrsf_frmts/sqlite/ogr_sqlite.h || die
-
- # Fix freexl configure check
- sed -e 's:FREEXL_LIBS=missing):FREEXL_LIBS=missing,-lm):g' \
- -i configure.ac || die
-
- sed -e "s: /usr/: \"${EPREFIX}\"/usr/:g" \
- -i configure.ac || die
-
- sed -e 's:^ar:$(AR):g' \
- -i ogr/ogrsf_frmts/sdts/install-libs.sh || die
-
- # updated for newer swig (must specify the path to input files)
- sed -e "s: gdal_array.i: ../include/gdal_array.i:" \
- -e "s:\$(DESTDIR)\$(prefix):\$(DESTDIR)\$(INST_PREFIX):g" \
- -i swig/python/GNUmakefile || die "sed python makefile failed"
- sed -e "s:library_dirs = :library_dirs = /usr/$(get_libdir):g" \
- -i swig/python/setup.cfg || die "sed python setup.cfg failed"
-
- default
-
- # fixed in git master or what will become 2.4.1:
- has_version ">=app-text/poppler-0.72.0" && eapply "${FILESDIR}/${P}-poppler-0.72.0.patch"
- has_version ">=app-text/poppler-0.73.0" && eapply "${FILESDIR}/${P}-poppler-0.73.0.patch"
-
- eautoreconf
-}
-
-src_configure() {
- # bug 619148
- append-cxxflags -std=c++14
-
- local myconf=(
- # charls - not packaged in Gentoo ebuild repository
- # kakadu, mrsid jp2mrsid - another jpeg2k stuff, ignore
- # bsb - legal issues
- # ingres - same story as oracle oci
- # jasper - disabled because unmaintained and vulnerable; openjpeg will be used as JPEG-2000 provider instead
- # podofo - we use poppler instead they are exclusive for each other
- # tiff is a hard dep
- --includedir="${EPREFIX}/usr/include/${PN}"
- --disable-pdf-plugin
- --disable-static
- --enable-shared
- --with-expat
- --with-cryptopp=no
- --with-geotiff
- --with-grib
- --with-hide-internal-symbols
- --with-libjson-c="${EPREFIX}/usr/"
- --with-libtiff
- --with-libtool
- --with-libz="${EPREFIX}/usr/"
- --with-gnm
- --without-bsb
- --without-charls
- --without-dods-root
- --without-ecw
- --without-epsilon
- --without-fgdb
- --without-fme
- --without-gta
- --without-grass
- --without-hdf4
- --without-idb
- --without-ingres
- --without-jasper
- --without-jp2lura
- --without-jp2mrsid
- --without-kakadu
- --without-kea
- --without-libkml
- --without-mongocxx
- --without-mrsid
- --without-mrsid_lidar
- --without-msg
- --without-mrf
- --without-rasdaman
- --without-rasterlite2
- --without-pcraster
- --without-pdfium
- --without-php
- --without-podofo
- --without-qhull
- --without-sde
- --without-sfcgal
- --without-sosi
- --without-teigha
- --disable-lto
- $(use_enable debug)
- $(use_with armadillo)
- $(use_with aux_xml pam)
- $(use_with curl)
- $(use_with fits cfitsio)
- $(use_with geos)
- $(use_with gif)
- $(use_with gml xerces)
- $(use_with hdf5)
- $(use_with jpeg pcidsk) # pcidsk is internal, because there is no such library yreleased developer by gdal
- $(use_with jpeg)
- $(use_with jpeg2k openjpeg)
- $(use_with lzma liblzma)
- $(use_with mysql mysql "${EPREFIX}"/usr/bin/mysql_config)
- $(use_with netcdf)
- $(use_with oracle oci)
- $(use_with odbc)
- $(use_with ogdi ogdi "${EPREFIX}"/usr)
- $(use_with opencl)
- $(use_with pdf poppler)
- $(use_with perl)
- $(use_with png)
- $(use_with postgres pg)
- $(use_with python)
- $(use_with spatialite)
- $(use_with sqlite sqlite3 "${EPREFIX}"/usr)
- $(use_with threads)
- $(use_with webp)
- $(use_with xls freexl)
- $(use_with zstd)
- )
-
- tc-export AR RANLIB
-
- if use java; then
- myconf+=(
- --with-java=$(java-config --jdk-home 2>/dev/null)
- --with-jvm-lib=dlopen
- $(use_with mdb)
- )
- else
- myconf+=( --without-java --without-mdb )
- fi
-
- if use sqlite; then
- append-libs -lsqlite3
- fi
-
- # bug #632660
- if use ogdi; then
- tc-export PKG_CONFIG
- append-cflags $(${PKG_CONFIG} --cflags libtirpc)
- append-cxxflags $(${PKG_CONFIG} --cflags libtirpc)
- fi
-
- ECONF_SOURCE="${S}" econf "${myconf[@]}"
-
- # mysql-config puts this in (and boy is it a PITA to get it out)
- if use mysql; then
- sed -e "s: -rdynamic : :" \
- -i GDALmake.opt || die "sed LIBS failed"
- fi
-}
-
-src_compile() {
- if use perl; then
- rm "${S}"/swig/perl/*_wrap.cpp || die
- emake -C "${S}"/swig/perl generate
- fi
-
- # gdal-config needed before generating Python bindings
- default
-
- if use perl ; then
- pushd "${S}"/swig/perl > /dev/null || die
- perl-module_src_configure
- perl-module_src_compile
- popd > /dev/null || die
- fi
-
- if use python; then
- rm -f "${S}"/swig/python/*_wrap.cpp || die
- emake -C "${S}"/swig/python generate
- pushd "${S}"/swig/python > /dev/null || die
- distutils-r1_src_compile
- popd > /dev/null || die
- fi
-
- use doc && emake docs
-}
-
-src_install() {
- if use perl ; then
- pushd "${S}"/swig/perl > /dev/null || die
- myinst=( DESTDIR="${D}" )
- perl-module_src_install
- popd > /dev/null || die
- sed -e 's:BINDINGS = \(.*\) perl:BINDINGS = \1:g' \
- -i GDALmake.opt || die
- fi
-
- use perl && perl_delete_localpod
-
- local DOCS=( Doxyfile HOWTO-RELEASE NEWS )
- use doc && HTML_DOCS=( html/. )
-
- default
-
- python_install() {
- distutils-r1_python_install
- python_doscript scripts/*.py
- }
-
- if use python; then
- # Don't clash with gdal's docs
- unset DOCS HTML_DOCS
-
- pushd "${S}"/swig/python > /dev/null || die
- distutils-r1_src_install
- popd > /dev/null || die
-
- newdoc swig/python/README.txt README-python.txt
-
- insinto /usr/share/${PN}/samples
- doins -r swig/python/samples/
- fi
-
- doman "${S}"/man/man*/*
- find "${ED}" -name '*.la' -delete || die
-}
-
-pkg_postinst() {
- elog "Check available image and data formats after building with"
- elog "gdalinfo and ogrinfo (using the --formats switch)."
-}