summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-06-01 20:43:42 +0000
committerSam James <sam@gentoo.org>2021-06-01 20:43:56 +0000
commit2d19b45cd14c5e47bc37fa826fdd7c13f0b5d27b (patch)
tree81fd9a9e1822f72a9b55b2f900c19d45231ad512 /sci-libs/gsl
parentdev-python/selenium: Remove ALLARCHES (diff)
downloadgentoo-2d19b45cd14c5e47bc37fa826fdd7c13f0b5d27b.tar.gz
gentoo-2d19b45cd14c5e47bc37fa826fdd7c13f0b5d27b.tar.bz2
gentoo-2d19b45cd14c5e47bc37fa826fdd7c13f0b5d27b.zip
sci-libs/gsl: add 2.7
Closes: https://bugs.gentoo.org/725368 Bug: https://bugs.gentoo.org/687126 Bug: https://bugs.gentoo.org/687342 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-libs/gsl')
-rw-r--r--sci-libs/gsl/Manifest2
-rw-r--r--sci-libs/gsl/gsl-2.7.ebuild63
2 files changed, 65 insertions, 0 deletions
diff --git a/sci-libs/gsl/Manifest b/sci-libs/gsl/Manifest
index 916572058e4f..099284fea1dd 100644
--- a/sci-libs/gsl/Manifest
+++ b/sci-libs/gsl/Manifest
@@ -2,3 +2,5 @@ DIST gsl-1.16-cblas.patch.bz2 2810 BLAKE2B 364c9f93a386e5d95c86789a3c00231cdfbe5
DIST gsl-1.16.tar.gz 3534080 BLAKE2B 1c55a41e5ed57b57f671074240d23416aa8f23e3cc2bb832e455d4f44d307e6be6adfa3671dbbf2aa14604ea49f96ff636de7909f3532cdc811f6bd99b0aa59d SHA512 94e998953f30d701e1cd0a5e05d572c5cca7b6f40f0533aa85394ba4218946826408093ffe3049a0ab13d6ba87034fcec1a7d52a67d0b8860dc02b5fd4feb8eb
DIST gsl-2.3-cblas.patch.bz2 12036 BLAKE2B ddad801cc42f925581e2e4995292f3eab0d2faf70c43c3b205fcf521b98e426df1d0824ed7d98b2c4cc89bbc4068fd45f2595dc02d23bded5c702b5a01bbfdb2 SHA512 37b867a21e60cd96c453ae24139bcf16c00c85bb6d5a3dcece81185fd9af5870c5167d2fa3c74cffce55bfb84f72be34d28ea94e0889904f8dda8687f66b4d23
DIST gsl-2.5.tar.gz 7303881 BLAKE2B 7c6d10c21071a1af1f03123f83244476d2e90fcd27d05a115b03a74fe631eb7d8081f5260e534ae58ab0997c1111f980a5e4cb50d110ca626fe810c44be70180 SHA512 5b4c5c023f9029ce220f4e09aa4d0234fed94d42ac224d58fda095fe0532d54237a7c33278f8b5d0ba051f6004486edb38d0adb4fcb49337a8c1d8a18cf4a24a
+DIST gsl-2.7-cblas.patch.bz2 12073 BLAKE2B 71f2bdafdb1f42ca5c3515f8e39266242185218495705018d88e523be9bc776b39749156500cdc5746a16e481e9cfe2b79660e250eb1a70f3b18819d16fe11c5 SHA512 5b9b2a798079610d7d4981b83672cc978ed44b66aaf6e671794685f10bd4069764bb358870019dc0eec1e251639cde12aaa3598cae0e2fc050ea39c79435fe2f
+DIST gsl-2.7.tar.gz 7508761 BLAKE2B a9da4df40ea57374880026a0586f2f218dbb0c9154cc661b3e7f5cd414311b95300e60faa2d7f4d3c6cdae5cfdf77cb8052075b56f51564aec2649cc4ad5f7f9 SHA512 a14ac5400acaf4884620430dbeb6f0b28eafe946923b792ab0eccc2a2abc9113d8ce342f4b1e5396f05247649f7d6f953944a8e6bdbf9ee1adb9e67b7c3df2b5
diff --git a/sci-libs/gsl/gsl-2.7.ebuild b/sci-libs/gsl/gsl-2.7.ebuild
new file mode 100644
index 000000000000..35e85c74340b
--- /dev/null
+++ b/sci-libs/gsl/gsl-2.7.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools flag-o-matic toolchain-funcs
+
+DESCRIPTION="The GNU Scientific Library"
+HOMEPAGE="https://www.gnu.org/software/gsl/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz
+ https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${PN}-2.7-cblas.patch.bz2"
+
+LICENSE="GPL-3"
+SLOT="0/25"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~sparc-solaris ~x86-solaris"
+IUSE="cblas-external +deprecated static-libs"
+
+RDEPEND="cblas-external? ( virtual/cblas:= )"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${WORKDIR}"/${PN}-2.7-cblas.patch
+)
+
+src_prepare() {
+ # bug #349005
+ [[ $(tc-getCC)$ == *gcc* ]] && \
+ [[ $(tc-getCC)$ != *apple* ]] && \
+ [[ $(gcc-major-version)$(gcc-minor-version) -eq 44 ]] \
+ && filter-mfpmath sse
+ filter-flags -ffast-math
+
+ default
+
+ if use deprecated; then
+ sed -i -e "/GSL_DISABLE_DEPRECATED/,+2d" configure.ac || die
+ fi
+ eautoreconf
+}
+
+src_configure() {
+ if use cblas-external; then
+ export CBLAS_LIBS="$($(tc-getPKG_CONFIG) --libs cblas)"
+ export CBLAS_CFLAGS="$($(tc-getPKG_CONFIG) --cflags cblas)"
+ fi
+
+ econf \
+ --enable-shared \
+ $(use_with cblas-external) \
+ $(use_enable static-libs static)
+}
+
+src_test() {
+ local MAKEOPTS="${MAKEOPTS} -j1"
+ default
+}
+
+src_install() {
+ default
+
+ find "${ED}" -name '*.la' -delete || die
+}