summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2023-05-15 11:59:56 +0200
committerAlfredo Tupone <tupone@gentoo.org>2023-05-15 12:00:53 +0200
commit55ac0694328b652528f58f3721f482c8006489fe (patch)
treeae9df459625becffcfdd3eec63e3b8523b4d3ae7 /sci-libs/jiwer/jiwer-3.0.1-r1.ebuild
parentacct-user/iroffer: remove myself from maintainers (diff)
downloadgentoo-55ac0694328b652528f58f3721f482c8006489fe.tar.gz
gentoo-55ac0694328b652528f58f3721f482c8006489fe.tar.bz2
gentoo-55ac0694328b652528f58f3721f482c8006489fe.zip
sci-libs/jiwer: fix RDEPEND
Closes: https://bugs.gentoo.org/906375 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'sci-libs/jiwer/jiwer-3.0.1-r1.ebuild')
-rw-r--r--sci-libs/jiwer/jiwer-3.0.1-r1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/sci-libs/jiwer/jiwer-3.0.1-r1.ebuild b/sci-libs/jiwer/jiwer-3.0.1-r1.ebuild
new file mode 100644
index 000000000000..c3b6585071d4
--- /dev/null
+++ b/sci-libs/jiwer/jiwer-3.0.1-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{9..11} )
+inherit distutils-r1
+
+DESCRIPTION="Evaluate an automatic speech recognition system"
+HOMEPAGE="
+ https://github.com/jitsi/jiwer
+ https://pypi.org/project/jiwer/
+"
+SRC_URI="https://github.com/jitsi/${PN}/archive/refs/tags/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+RDEPEND="
+ dev-python/rapidfuzz[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+PATCHES=( "${FILESDIR}"/${P}-tests.patch )