summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2024-01-02 20:42:53 +0100
committerAlfredo Tupone <tupone@gentoo.org>2024-01-02 20:43:19 +0100
commit00cd3b2f7f02add71703d3c676865f24322d6c25 (patch)
treead096999efb05d3f80704c72cbd6d7c06cbed9bd /sci-libs/jiwer/jiwer-3.0.3.ebuild
parentdev-python/bcrypt: Workaround pytest-asyncio cause test failures (diff)
downloadgentoo-00cd3b2f7f02add71703d3c676865f24322d6c25.tar.gz
gentoo-00cd3b2f7f02add71703d3c676865f24322d6c25.tar.bz2
gentoo-00cd3b2f7f02add71703d3c676865f24322d6c25.zip
sci-libs/jiwer: add 3.0.3, drop 3.0.1-r1
Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'sci-libs/jiwer/jiwer-3.0.3.ebuild')
-rw-r--r--sci-libs/jiwer/jiwer-3.0.3.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/sci-libs/jiwer/jiwer-3.0.3.ebuild b/sci-libs/jiwer/jiwer-3.0.3.ebuild
new file mode 100644
index 000000000000..dd694082ecbe
--- /dev/null
+++ b/sci-libs/jiwer/jiwer-3.0.3.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{9..12} )
+inherit distutils-r1
+
+DESCRIPTION="Evaluate an automatic speech recognition system"
+HOMEPAGE="
+ https://github.com/jitsi/jiwer
+ https://pypi.org/project/jiwer/
+"
+SRC_URI="https://github.com/jitsi/${PN}/archive/refs/tags/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+RDEPEND="
+ dev-python/rapidfuzz[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+PATCHES=( "${FILESDIR}"/${PN}-3.0.1-tests.patch )