summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Zaman <perfinion@gentoo.org>2018-09-28 11:58:40 +0800
committerJason Zaman <perfinion@gentoo.org>2018-09-28 18:23:49 +0800
commit0b8a769c8128c3b8b501ed85dbbee195da2b1636 (patch)
tree83cac40b31ab81bd297b3fb7247549178bb6bb74 /sci-libs/keras-applications/keras-applications-1.0.5.ebuild
parentsci-libs/keras-preprocessing: bump 1.0.3 (diff)
downloadgentoo-0b8a769c8128c3b8b501ed85dbbee195da2b1636.tar.gz
gentoo-0b8a769c8128c3b8b501ed85dbbee195da2b1636.tar.bz2
gentoo-0b8a769c8128c3b8b501ed85dbbee195da2b1636.zip
sci-libs/keras-applications: bump 1.0.5
Package-Manager: Portage-2.3.49, Repoman-2.3.10
Diffstat (limited to 'sci-libs/keras-applications/keras-applications-1.0.5.ebuild')
-rw-r--r--sci-libs/keras-applications/keras-applications-1.0.5.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/sci-libs/keras-applications/keras-applications-1.0.5.ebuild b/sci-libs/keras-applications/keras-applications-1.0.5.ebuild
new file mode 100644
index 000000000000..065753c60c54
--- /dev/null
+++ b/sci-libs/keras-applications/keras-applications-1.0.5.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python{3_5,3_6} )
+inherit distutils-r1
+
+DESCRIPTION="Keras deep learning library reference implementations of deep learning models"
+HOMEPAGE="https://keras.io/applications/"
+SRC_URI="https://files.pythonhosted.org/packages/60/27/a25dfc6e49a6ab3de2d5f23fdb851f18d45ea9867a0955906a5c488ebbe2/Keras_Applications-${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+S="${WORKDIR}/Keras_Applications-${PV}/"
+
+RDEPEND="dev-python/numpy[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"