summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenda Xu <heroxbd@gentoo.org>2020-09-25 19:45:35 +0800
committerBenda Xu <heroxbd@gentoo.org>2020-09-25 19:45:35 +0800
commit0e8aa833a02a5d55cb3294702aaf566eebb8383c (patch)
tree4200d2018c840d12558804eb23438c8b9f943d12 /sci-libs/keras-applications
parentdev-python/google-auth-oauthlib: tested on Python 3.8. (diff)
downloadgentoo-0e8aa833a02a5d55cb3294702aaf566eebb8383c.tar.gz
gentoo-0e8aa833a02a5d55cb3294702aaf566eebb8383c.tar.bz2
gentoo-0e8aa833a02a5d55cb3294702aaf566eebb8383c.zip
sci-libs/keras-applications: tested on Python 3.8.
Package-Manager: Portage-3.0.5, Repoman-3.0.1 Signed-off-by: Benda Xu <heroxbd@gentoo.org>
Diffstat (limited to 'sci-libs/keras-applications')
-rw-r--r--sci-libs/keras-applications/keras-applications-1.0.8-r1.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/sci-libs/keras-applications/keras-applications-1.0.8-r1.ebuild b/sci-libs/keras-applications/keras-applications-1.0.8-r1.ebuild
new file mode 100644
index 000000000000..78bc7b1dc8d1
--- /dev/null
+++ b/sci-libs/keras-applications/keras-applications-1.0.8-r1.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+inherit distutils-r1
+
+DESCRIPTION="Keras deep learning library reference implementations of deep learning models"
+HOMEPAGE="https://keras.io/applications/"
+SRC_URI="https://github.com/keras-team/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-python/numpy[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"