summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2024-01-21 13:56:01 +0100
committerAlfredo Tupone <tupone@gentoo.org>2024-01-21 13:56:01 +0100
commit7bc5ee69fda2277259e0834e9e20ff9669fb861f (patch)
treee62cc75829b145def187184b5670677b65da1d3c /sci-libs/kineto/kineto-0.4.0_p20231127.ebuild
parentsci-geosciences/xyzservices: add RESTRICT test (diff)
downloadgentoo-7bc5ee69fda2277259e0834e9e20ff9669fb861f.tar.gz
gentoo-7bc5ee69fda2277259e0834e9e20ff9669fb861f.tar.bz2
gentoo-7bc5ee69fda2277259e0834e9e20ff9669fb861f.zip
sci-libs/kineto: add 0.4.0_p20231127, drop 0.4.0_p20231031-r1
Closes: https://bugs.gentoo.org/908397 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'sci-libs/kineto/kineto-0.4.0_p20231127.ebuild')
-rw-r--r--sci-libs/kineto/kineto-0.4.0_p20231127.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/sci-libs/kineto/kineto-0.4.0_p20231127.ebuild b/sci-libs/kineto/kineto-0.4.0_p20231127.ebuild
new file mode 100644
index 000000000000..3a0dcc58057b
--- /dev/null
+++ b/sci-libs/kineto/kineto-0.4.0_p20231127.ebuild
@@ -0,0 +1,51 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..12} )
+inherit python-any-r1 cmake prefix
+
+CommitId=c7aeac02222978e7673ee5381bfcaa6b60d5d69c
+
+DESCRIPTION="part of the PyTorch Profiler"
+HOMEPAGE="https://github.com/pytorch/kineto"
+SRC_URI="https://github.com/pytorch/${PN}/archive/${CommitId}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+RDEPEND="
+ dev-libs/libfmt
+ dev-libs/dynolog
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ test? ( dev-cpp/gtest )
+ ${PYTHON_DEPS}
+"
+RESTRICT="!test? ( test )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.4.0-gcc13.patch
+)
+
+S="${WORKDIR}"/${PN}-${CommitId}
+
+src_prepare() {
+ cd libkineto
+ cmake_src_prepare
+}
+
+src_configure() {
+ cd libkineto
+ local mycmakeargs=(
+ -DLIBKINETO_THIRDPARTY_DIR="${EPREFIX}"/usr/include/
+ )
+ eapply $(prefixify_ro "${FILESDIR}"/${PN}-0.4.0_p20231031-gentoo.patch)
+
+ cmake_src_configure
+}