summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2020-08-12 16:29:11 -0400
committerMichael Orlitzky <mjo@gentoo.org>2020-08-12 16:29:11 -0400
commitcf8616b021a79c5317ecedc2e28f4c8592b21f09 (patch)
tree53e12efc0b80ddfe92d7a067a7aab03c341fb8a9 /sci-libs/libhomfly/libhomfly-1.02.6.ebuild
parentapp-admin/apg: Maintainer retired (diff)
downloadgentoo-cf8616b021a79c5317ecedc2e28f4c8592b21f09.tar.gz
gentoo-cf8616b021a79c5317ecedc2e28f4c8592b21f09.tar.bz2
gentoo-cf8616b021a79c5317ecedc2e28f4c8592b21f09.zip
sci-libs/libhomfly: new library for homfly polynomial computation.
This package is used by SageMath, and sage will soon be able to use a system copy of libhomfly when it exists. Having libhomfly available in Gentoo therefore avoids pointless rebuilds of it for Gentoo users of SageMath. Thanks are due to François Bissey, whose ebuild was imported more or less verbatim from the sage-on-gentoo overlay. Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'sci-libs/libhomfly/libhomfly-1.02.6.ebuild')
-rw-r--r--sci-libs/libhomfly/libhomfly-1.02.6.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/sci-libs/libhomfly/libhomfly-1.02.6.ebuild b/sci-libs/libhomfly/libhomfly-1.02.6.ebuild
new file mode 100644
index 000000000000..717bc354d1d4
--- /dev/null
+++ b/sci-libs/libhomfly/libhomfly-1.02.6.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PV=$(ver_rs 2 r)
+MY_P="${PN}-${MY_PV}"
+DESCRIPTION="Library to compute the homfly polynomial of a link"
+HOMEPAGE="https://github.com/miguelmarco/libhomfly"
+SRC_URI="https://github.com/miguelmarco/${PN}/releases/download/${MY_PV}/${MY_P}.tar.gz"
+
+LICENSE="Unlicense"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="static-libs"
+
+DEPEND="dev-libs/boehm-gc"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure(){
+ econf $(use_enable static-libs static)
+}
+
+src_install(){
+ default
+ find "${ED}" -name '*.la' -delete || die
+}