summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2022-05-16 10:12:20 +0200
committerDavid Seifert <soap@gentoo.org>2022-05-16 10:12:20 +0200
commit843d3ab2d6bdda43eda143d0b10d5edc2e0a5e8c (patch)
tree1ea53ad36795cb26e2c3cc46474898d2eb652a09 /sci-libs/linbox/linbox-1.6.3-r1.ebuild
parentsci-libs/kissfft: [QA] use tc-check-openmp correctly (diff)
downloadgentoo-843d3ab2d6bdda43eda143d0b10d5edc2e0a5e8c.tar.gz
gentoo-843d3ab2d6bdda43eda143d0b10d5edc2e0a5e8c.tar.bz2
gentoo-843d3ab2d6bdda43eda143d0b10d5edc2e0a5e8c.zip
sci-libs/linbox: deprecate tc-has-openmp
Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sci-libs/linbox/linbox-1.6.3-r1.ebuild')
-rw-r--r--sci-libs/linbox/linbox-1.6.3-r1.ebuild8
1 files changed, 6 insertions, 2 deletions
diff --git a/sci-libs/linbox/linbox-1.6.3-r1.ebuild b/sci-libs/linbox/linbox-1.6.3-r1.ebuild
index 1771643dd4d6..cabe5a6d2cf9 100644
--- a/sci-libs/linbox/linbox-1.6.3-r1.ebuild
+++ b/sci-libs/linbox/linbox-1.6.3-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -34,7 +34,11 @@ RDEPEND="${DEPEND}"
PATCHES=( "${FILESDIR}/${PN}-1.6.3-pc.patch" )
pkg_pretend() {
- [[ "${MERGE_TYPE}" != "binary" ]] && use openmp && tc-check-openmp
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
+pkg_setup() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
}
src_configure() {