summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-01-13 03:53:49 +0000
committerSam James <sam@gentoo.org>2022-01-13 03:56:01 +0000
commitc10ce89a8b65d0927d26c77dacd7d54e297ed7d7 (patch)
tree1a6f903ed5a290ecb9272c237beb6b6c80b7ed15 /sci-libs/netcdf-fortran/netcdf-fortran-4.5.4.ebuild
parentsys-apps/keyutils: Stabilize 1.6.3 ppc64, #789837 (diff)
downloadgentoo-c10ce89a8b65d0927d26c77dacd7d54e297ed7d7.tar.gz
gentoo-c10ce89a8b65d0927d26c77dacd7d54e297ed7d7.tar.bz2
gentoo-c10ce89a8b65d0927d26c77dacd7d54e297ed7d7.zip
sci-libs/netcdf-fortran: add 4.5.4
Drops Fortran flag workaround: https://github.com/Unidata/netcdf-fortran/commit/846ec7ac1d1eb552d319ce51fd70b832f6fcb347 Bug: https://github.com/Unidata/netcdf-fortran/pull/316 Bug: https://bugs.gentoo.org/723274 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-libs/netcdf-fortran/netcdf-fortran-4.5.4.ebuild')
-rw-r--r--sci-libs/netcdf-fortran/netcdf-fortran-4.5.4.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/sci-libs/netcdf-fortran/netcdf-fortran-4.5.4.ebuild b/sci-libs/netcdf-fortran/netcdf-fortran-4.5.4.ebuild
new file mode 100644
index 000000000000..49803dfd5170
--- /dev/null
+++ b/sci-libs/netcdf-fortran/netcdf-fortran-4.5.4.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+FORTRAN_STANDARD="77 90"
+
+inherit autotools fortran-2 flag-o-matic
+
+DESCRIPTION="Scientific library and interface for array oriented data access"
+HOMEPAGE="https://www.unidata.ucar.edu/software/netcdf/"
+SRC_URI="https://github.com/Unidata/netcdf-fortran/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="UCAR-Unidata"
+SLOT="0/7"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc examples static-libs"
+
+RDEPEND="sci-libs/netcdf"
+DEPEND="${RDEPEND}
+ dev-lang/cfortran"
+BDEPEND="doc? ( app-doc/doxygen )"
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-valgrind \
+ --with-temp-large="${T}" \
+ --disable-dot \
+ $(use_enable doc doxygen) \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ use examples && dodoc -r examples
+ find "${ED}" -name '*.la' -delete || die
+}