summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2020-06-09 16:53:45 -0400
committerMichael Orlitzky <mjo@gentoo.org>2020-06-09 17:02:11 -0400
commitce743c3eb6cdaf8780d9380c10a3c476c695ee1f (patch)
treea4eb37d5fe6aa2933393bbc4290e6bbf263b2804 /sci-libs/openblas
parentapp-office/homebank: bump to 5.4.2 (diff)
downloadgentoo-ce743c3eb6cdaf8780d9380c10a3c476c695ee1f.tar.gz
gentoo-ce743c3eb6cdaf8780d9380c10a3c476c695ee1f.tar.bz2
gentoo-ce743c3eb6cdaf8780d9380c10a3c476c695ee1f.zip
sci-libs/openblas: fix AR usage in the latest version.
Upstream sets $AR unconditionally in a non-autotools Makefile, so we have to try extra hard to override it. Closes: https://bugs.gentoo.org/725608 Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'sci-libs/openblas')
-rw-r--r--sci-libs/openblas/openblas-0.3.9.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/sci-libs/openblas/openblas-0.3.9.ebuild b/sci-libs/openblas/openblas-0.3.9.ebuild
index 9aa17003313d..c200d21b519e 100644
--- a/sci-libs/openblas/openblas-0.3.9.ebuild
+++ b/sci-libs/openblas/openblas-0.3.9.ebuild
@@ -54,8 +54,10 @@ src_unpack() {
}
src_compile() {
- emake
- emake -Cinterface shared-blas-lapack
+ # We have to try extra hard to override AR for now.
+ # https://github.com/xianyi/OpenBLAS/issues/2654
+ emake AR="$(tc-getAR)"
+ emake AR="$(tc-getAR)" -Cinterface shared-blas-lapack
if use index-64bit; then
emake -C"${S}-index-64bit" INTERFACE64=1 LIBPREFIX=libopenblas64
fi