summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-libs/rosetta-fragments
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-libs/rosetta-fragments')
-rw-r--r--sci-libs/rosetta-fragments/Manifest1
-rw-r--r--sci-libs/rosetta-fragments/files/3.1-chemshift.patch33
-rw-r--r--sci-libs/rosetta-fragments/files/3.1-nnmake.patch107
-rw-r--r--sci-libs/rosetta-fragments/files/rosetta-fragments-3.1-chemshift.patch62
-rw-r--r--sci-libs/rosetta-fragments/files/rosetta-fragments-3.1-nnmake.patch153
-rw-r--r--sci-libs/rosetta-fragments/metadata.xml8
-rw-r--r--sci-libs/rosetta-fragments/rosetta-fragments-3.1-r1.ebuild57
7 files changed, 421 insertions, 0 deletions
diff --git a/sci-libs/rosetta-fragments/Manifest b/sci-libs/rosetta-fragments/Manifest
new file mode 100644
index 000000000000..efbeb3f09970
--- /dev/null
+++ b/sci-libs/rosetta-fragments/Manifest
@@ -0,0 +1 @@
+DIST rosetta3.1_fragments.tgz 221931894 SHA256 2211cab76e4848d80d6fd311e97535de220a865d8afc72d8ca12f90b7d4641bf SHA512 a2b2646c916ea1b98e2c7267c1eadb1fd6cb76d015c24bd4e8318ce127cb5d96ca56bfdd76821e1dd884e03d59631f544e221b9f541ad4063a99e96dbb029da1 WHIRLPOOL 32d0758e6782da8088178e11af5bfe23b457e98a3ab9a8cbb583d4e4aa48e5d1ef9005825ff62944c5c755a0ac99b3ff88fb7c1d1b249940110287969ff0118a
diff --git a/sci-libs/rosetta-fragments/files/3.1-chemshift.patch b/sci-libs/rosetta-fragments/files/3.1-chemshift.patch
new file mode 100644
index 000000000000..6ea69b210e82
--- /dev/null
+++ b/sci-libs/rosetta-fragments/files/3.1-chemshift.patch
@@ -0,0 +1,33 @@
+--- chemshift/makefile 2009-01-09 16:08:00.000000000 +0100
++++ chemshift/makefile.new 2009-04-09 11:30:34.179824057 +0200
+@@ -64,7 +64,7 @@
+ # rule to compile executable
+ compile: $(BASE_NAME).$(COMPILER)
+ $(BASE_NAME).$(COMPILER) : print ${OBJS}
+- $(F77) $(FFLAGS) -o $@ $(OBJS) $(LINKFLAGS)
++ $(F77) $(FFLAGS) $(LDFLAGS) -o $@ $(OBJS) $(LINKFLAGS)
+
+ # rule to compile object files:
+ .$(COMPILER).%.o: %.f
+--- chemshift/make.system 2009-01-09 16:08:00.000000000 +0100
++++ chemshift/make.system.new 2009-04-09 11:35:16.126466293 +0200
+@@ -61,16 +61,14 @@
+
+ # defaults
+ F77=f77
+-FFLAGS=
+ FOPTIMFLAGS=-O
+ FDEBUGFLAGS=-g
+ FPROFILEFLAGS=-P
+
+ ifeq ($(COMPILER),gnu)
+- F77 = g77
+- FFLAGS = -finline-functions -funroll-loops -W -ffixed-line-length-132 -Wimplicit
+- FOPTIMFLAGS = -O -ffast-math -malign-double
+- FDEBUGFLAGS = -g -Wall -Wimplicit -Wsurprising -Wformat -W
++ F77 = $(FORTRANC)
++ FOPTIMFLAGS =
++ FDEBUGFLAGS =
+ FPROFILEFLAGS = -pg
+ endif
+
diff --git a/sci-libs/rosetta-fragments/files/3.1-nnmake.patch b/sci-libs/rosetta-fragments/files/3.1-nnmake.patch
new file mode 100644
index 000000000000..35568bb9f805
--- /dev/null
+++ b/sci-libs/rosetta-fragments/files/3.1-nnmake.patch
@@ -0,0 +1,107 @@
+--- nnmake/make.system 2009-01-09 16:07:59.000000000 +0100
++++ nnmake/make.system.new 2009-04-09 10:54:50.000000000 +0200
+@@ -62,10 +62,9 @@
+ FPROFILEFLAGS=-P
+
+ ifeq ($(COMPILER),gnu)
+- F77 = g77
+- FFLAGS = -finline-functions -funroll-loops -W -ffixed-line-length-132 -Wimplicit
+- FOPTIMFLAGS = -O -ffast-math -malign-double
+- FDEBUGFLAGS = -g -Wall -Wimplicit -Wsurprising -Wformat -W
++ F77 = $(FORTRANC)
++ FOPTIMFLAGS =
++ FDEBUGFLAGS =
+ FPROFILEFLAGS = -pg
+ endif
+
+--- nnmake/dipolar_nn.f 2009-01-09 16:08:00.000000000 +0100
++++ nnmake/dipolar_nn.f.new 2009-04-09 11:06:24.923302302 +0200
+@@ -1396,7 +1396,7 @@
+ write(0,*)'rejected'
+ write(0,*)x(1,iset),x(2,iset),x(3,iset),x(4,iset),x(5,iset)
+ do i=1,maplength(iset)
+- write(0,'(i,6f6.3)')i,A(i,1),A(i,2),A(i,3),A(i,4),A(i,5),
++ write(0,'(i6,6f6.3)')i,A(i,1),A(i,2),A(i,3),A(i,4),A(i,5),
+ # b(i)
+ enddo
+ goto 300
+--- nnmake/make.system 2009-04-09 11:10:34.399945087 +0200
++++ nnmake/make.system.new 2009-04-09 11:19:41.287390259 +0200
+@@ -55,7 +55,6 @@
+
+ # defaults
+ F77=f77
+-FFLAGS=
+ FOPTIMFLAGS=-O
+ FDEBUGFLAGS=-g
+ FPROFILEFLAGS=-P
+--- nnmake/makefile 2009-01-09 16:08:00.000000000 +0100
++++ nnmake/makefile.new 2009-04-09 11:22:43.454037887 +0200
+@@ -102,7 +102,7 @@
+ # rule to compile executable
+ compile: print $(BASE_NAME).$(COMPILER)
+ $(BASE_NAME).$(COMPILER) : ${OBJS}
+- $(F77) $(FFLAGS) -o $@ $(OBJS) $(LINKFLAGS)
++ $(F77) $(FFLAGS) $(LDFLAGS) -o $@ $(OBJS) $(LINKFLAGS)
+
+ coord_compile: print $(COORD_BASE_NAME).$(COMPILER)
+ $(COORD_BASE_NAME).$(COMPILER) : ${COORD_OBJS}
+--- nnmake/make_fragments.pl 2009-01-09 15:53:33.000000000 +0100
++++ nnmake/make_fragments.pl.new 2009-04-09 13:01:52.987174602 +0200
+@@ -19,38 +19,38 @@
+
+ my $TAIL = "_v1_3";
+
+-$src_dir = '/work/chu/rosetta/rosetta_C++/rosetta-2.2.0/rosetta_fragments';
+-$shareware_dir = '/work/chu/src/shareware';
+-$scratch = "/scratch/shared";
++$src_dir = '/';
++$shareware_dir = '$src_dir/usr/share';
++$scratch = "$src_dir/scratch/shared";
+
+ # psi-blast
+ #my $BLAST_BIN_DIR = "$shareware_dir/new_blast/blast-2.2.12/bin";
+-my $PSIBLAST = "$shareware_dir/blast/bin/blastpgp"; # PSI-BLAST (duh.)
+-my $NR = "/$scratch/genomes/nr"; # nr blast database filename
+-my $VALL_BLAST_DB = "/$scratch/nnmake_database/vall.blast.2006-05-05"; # vall blast database filename (cvs respository 'nnmake_database')
+-my $BLOSUM = "$scratch/nnmake_database/"; # BLOSUM score matrices directory (cvs repository 'nnmake_database')
++my $PSIBLAST = "$src_dir/usr/bin/blastpgp"; # PSI-BLAST (duh.)
++my $NR = "$shareware_dir/blast-db/nr"; # nr blast database filename
++my $VALL_BLAST_DB = "$shareware_dir/rosetta-fragments/nnmake_database/vall.blast.2006-05-05"; # vall blast database filename (cvs respository 'nnmake_database')
++my $BLOSUM = "$shareware_dir/rosetta-fragments/nnmake_database/"; # BLOSUM score matrices directory (cvs repository 'nnmake_database')
+
+ # psipred
+-my $FILTNR = "$scratch/genomes/filtnr"; # filtnr blast database filename
+-my $MAKEMAT = "$shareware_dir/blast/bin/makemat"; # makemat utility (part of NCBI tools)
+-my $PSIPRED = "$shareware_dir/psipred/bin/psipred"; # psipred
+-my $PSIPASS2 = "$shareware_dir/psipred/bin/psipass2"; # psipass2 (part of psipred pkg)
++my $FILTNR = "$src_dir/tmp/filtnr"; # filtnr blast database filename
++my $MAKEMAT = "$src_dir/usr/bin/makemat"; # makemat utility (part of NCBI tools)
++my $PSIPRED = "$src_dir/usr/bin/psipred"; # psipred
++my $PSIPASS2 = "$src_dir/usr/bin/psipass2"; # psipass2 (part of psipred pkg)
+ my $PSIPRED_DATA = "$shareware_dir/psipred/data"; # dir containing psipred data files.
+
+ # prof
+ #my $PROF = "$shareware_dir/prof/run_prof.py";
+-my $PROF = "$src_dir/nnmake/run_prof.py"; # remember to change prof executable location in run_prof.py
++my $PROF = "$src_dir/usr/bin/run_prof.py"; # remember to change prof executable location in run_prof.py
+
+ # nnmake
+-my $VALL = "$scratch/nnmake_database"; # dir containing vall database (cvs repository 'nnmake_database')
+-my $VALL2 = "$scratch/nnmake_database"; # alt dir containing vall database (cvs repository 'nnmake_database')
++my $VALL = "$shareware_dir/rosetta-fragments/nnmake_database"; # dir containing vall database (cvs repository 'nnmake_database')
++my $VALL2 = "$shareware_dir/rosetta-fragments/nnmake_database"; # alt dir containing vall database (cvs repository 'nnmake_database')
+ my $VALL_NAME = "vall.dat.2006-05-05"; # filename of vall (vall.dat.<id> and vall_cst_coord.dat.<id> must exist)
+-my $NNMAKE = "$src_dir/nnmake/pNNMAKE.gnu"; # nnmake binary (cvs respository 'nnmake')
+-my $TRIMLOOPS = "$src_dir/nnmake/trimLoopLibrary.pl"; # trimLoopLibrary.pl (cvs respository 'nnmake')
++my $NNMAKE = "$src_dir/usr/bin/pNNMAKE"; # nnmake binary (cvs respository 'nnmake')
++my $TRIMLOOPS = "$src_dir/usr/bin/trimLoopLibrary.pl"; # trimLoopLibrary.pl (cvs respository 'nnmake')
+
+ # chemshift
+-my $CHEMSHIFT = "$src_dir/chemshift/pCHEMSHIFT.gnu"; # chemshift binary (cvs repository 'chemshift')
+-my $TALOS_DB = "$scratch/chemshift_database"; # TALOS databases directory (cvs respository 'chemshift_database')
++my $CHEMSHIFT = "$src_dir/usr/bin/pCHEMSHIFT"; # chemshift binary (cvs repository 'chemshift')
++my $TALOS_DB = "$shareware_dir/rosetta-fragments/chemshift_database"; # TALOS databases directory (cvs respository 'chemshift_database')
+
+ # jufo (secondary structure prediction software)
+ my $JUFO = "$shareware_dir/jufo/molecule.exe"; # jufo executable
diff --git a/sci-libs/rosetta-fragments/files/rosetta-fragments-3.1-chemshift.patch b/sci-libs/rosetta-fragments/files/rosetta-fragments-3.1-chemshift.patch
new file mode 100644
index 000000000000..cb8fd9197d1b
--- /dev/null
+++ b/sci-libs/rosetta-fragments/files/rosetta-fragments-3.1-chemshift.patch
@@ -0,0 +1,62 @@
+ chemshift/make.system | 24 ++++++++++++------------
+ chemshift/makefile | 2 +-
+ 2 files changed, 13 insertions(+), 13 deletions(-)
+
+diff --git a/chemshift/make.system b/chemshift/make.system
+index 53bbd38..d105802 100644
+--- a/chemshift/make.system
++++ b/chemshift/make.system
+@@ -60,18 +60,18 @@ endif
+ ########## once COMPILER is set, here are the options
+
+ # defaults
+-F77=f77
+-FFLAGS=
+-FOPTIMFLAGS=-O
+-FDEBUGFLAGS=-g
++F77?=f77
++FFLAGS?=
++FOPTIMFLAGS?=
++FDEBUGFLAGS?=
+ FPROFILEFLAGS=-P
+
+ ifeq ($(COMPILER),gnu)
+- F77 = g77
+- FFLAGS = -finline-functions -funroll-loops -W -ffixed-line-length-132 -Wimplicit
+- FOPTIMFLAGS = -O -ffast-math -malign-double
+- FDEBUGFLAGS = -g -Wall -Wimplicit -Wsurprising -Wformat -W
+- FPROFILEFLAGS = -pg
++ F77 ?= g77
++ FFLAGS += -W -ffixed-line-length-132 -Wimplicit
++ FOPTIMFLAGS += -malign-double
++ FDEBUGFLAGS += -Wall -Wimplicit -Wsurprising -Wformat -W
++ FPROFILEFLAGS =
+ endif
+
+ ifeq ($(COMPILER),pgi) # on mary, good bounds checking
+@@ -108,9 +108,9 @@ endif
+
+ # Suse ppc gnu
+ ifeq ($(COMPILER),ppc)
+- F77 = g77
+- FFLAGS = -Wall -finline-functions -funroll-loops -W -ffixed-line-length-132
+- FDEBUGFLAGS = -g -C -Mbounds
++ F77 ?= g77
++ FFLAGS += -Wall -W -ffixed-line-length-132
++ FDEBUGFLAGS += -C -Mbounds
+ FOPTIMFLAGS =
+ endif
+
+diff --git a/chemshift/makefile b/chemshift/makefile
+index 712e98f..05d3b64 100644
+--- a/chemshift/makefile
++++ b/chemshift/makefile
+@@ -64,7 +64,7 @@ regular: compile
+ # rule to compile executable
+ compile: $(BASE_NAME).$(COMPILER)
+ $(BASE_NAME).$(COMPILER) : print ${OBJS}
+- $(F77) $(FFLAGS) -o $@ $(OBJS) $(LINKFLAGS)
++ $(F77) $(FFLAGS) $(LDFLAGS) -o $@ $(OBJS) $(LINKFLAGS)
+
+ # rule to compile object files:
+ .$(COMPILER).%.o: %.f
diff --git a/sci-libs/rosetta-fragments/files/rosetta-fragments-3.1-nnmake.patch b/sci-libs/rosetta-fragments/files/rosetta-fragments-3.1-nnmake.patch
new file mode 100644
index 000000000000..91da48017eff
--- /dev/null
+++ b/sci-libs/rosetta-fragments/files/rosetta-fragments-3.1-nnmake.patch
@@ -0,0 +1,153 @@
+ nnmake/dipolar_nn.f | 2 +-
+ nnmake/make.system | 33 ++++++++++++++++-----------------
+ nnmake/make_fragments.pl | 36 ++++++++++++++++++------------------
+ nnmake/makefile | 2 +-
+ 4 files changed, 36 insertions(+), 37 deletions(-)
+
+diff --git a/nnmake/dipolar_nn.f b/nnmake/dipolar_nn.f
+index c159888..4412a20 100644
+--- a/nnmake/dipolar_nn.f
++++ b/nnmake/dipolar_nn.f
+@@ -1396,7 +1396,7 @@ car pairDipolar(1,i) .le. pairDipolar(1,i+1)
+ write(0,*)'rejected'
+ write(0,*)x(1,iset),x(2,iset),x(3,iset),x(4,iset),x(5,iset)
+ do i=1,maplength(iset)
+- write(0,'(i,6f6.3)')i,A(i,1),A(i,2),A(i,3),A(i,4),A(i,5),
++ write(0,'(i6,6f6.3)')i,A(i,1),A(i,2),A(i,3),A(i,4),A(i,5),
+ # b(i)
+ enddo
+ goto 300
+diff --git a/nnmake/make.system b/nnmake/make.system
+index 34bea8f..2fbfabf 100644
+--- a/nnmake/make.system
++++ b/nnmake/make.system
+@@ -55,18 +55,17 @@ endif
+ ########## once COMPILER is set, here are the options
+
+ # defaults
+-F77=f77
+-FFLAGS=
+-FOPTIMFLAGS=-O
+-FDEBUGFLAGS=-g
+-FPROFILEFLAGS=-P
++F77?=f77
++FOPTIMFLAGS=
++FDEBUGFLAGS=
++FPROFILEFLAGS=
+
+ ifeq ($(COMPILER),gnu)
+- F77 = g77
+- FFLAGS = -finline-functions -funroll-loops -W -ffixed-line-length-132 -Wimplicit
+- FOPTIMFLAGS = -O -ffast-math -malign-double
+- FDEBUGFLAGS = -g -Wall -Wimplicit -Wsurprising -Wformat -W
+- FPROFILEFLAGS = -pg
++ F77 ?= g77
++ FFLAGS += -W -ffixed-line-length-132 -Wimplicit
++ FOPTIMFLAGS += -malign-double
++ FDEBUGFLAGS += -Wall -Wimplicit -Wsurprising -Wformat -W
++ FPROFILEFLAGS =
+ endif
+
+ ifeq ($(COMPILER),pgi) # on mary, good bounds checking
+@@ -82,9 +81,9 @@ ifeq ($(COMPILER),pgi) # on mary, good bounds checking
+ endif
+
+ ifeq ($(COMPILER),absoft) # on mary, fast
+- F77 = f77
+- FFLAGS = -N109 -s -W
+- LINKFLAGS = -lU77
++ F77 ?= f77
++ FFLAGS ?= -N109 -s -W
++ LINKFLAGS += -lU77
+ FDEBUGFLAGS = -C -g
+ FOPTIMFLAGS = -O -N18
+ FPROFILEFLAGS = -P -O
+@@ -103,10 +102,10 @@ endif
+
+ # Suse ppc gnu
+ ifeq ($(COMPILER),ppc)
+- F77 = g77
+- FFLAGS = -Wall -finline-functions -funroll-loops -W -ffixed-line-length-132
+- FDEBUGFLAGS = -g -C -Mbounds
+- FOPTIMFLAGS =
++ F77 ?= g77
++ FFLAGS += -Wall -W -ffixed-line-length-132
++ FDEBUGFLAGS += -C -Mbounds
++ FOPTIMFLAGS +=
+ endif
+
+ # alpha flags
+diff --git a/nnmake/make_fragments.pl b/nnmake/make_fragments.pl
+index 5273685..29619a2 100755
+--- a/nnmake/make_fragments.pl
++++ b/nnmake/make_fragments.pl
+@@ -19,38 +19,38 @@
+
+ my $TAIL = "_v1_3";
+
+-$src_dir = '/work/chu/rosetta/rosetta_C++/rosetta-2.2.0/rosetta_fragments';
+-$shareware_dir = '/work/chu/src/shareware';
+-$scratch = "/scratch/shared";
++$src_dir = '@GENTOO_PORTAGE_EPREFIX@/';
++$shareware_dir = '$src_dir/usr/share';
++$scratch = "$src_dir/scratch/shared";
+
+ # psi-blast
+ #my $BLAST_BIN_DIR = "$shareware_dir/new_blast/blast-2.2.12/bin";
+-my $PSIBLAST = "$shareware_dir/blast/bin/blastpgp"; # PSI-BLAST (duh.)
+-my $NR = "/$scratch/genomes/nr"; # nr blast database filename
+-my $VALL_BLAST_DB = "/$scratch/nnmake_database/vall.blast.2006-05-05"; # vall blast database filename (cvs respository 'nnmake_database')
+-my $BLOSUM = "$scratch/nnmake_database/"; # BLOSUM score matrices directory (cvs repository 'nnmake_database')
++my $PSIBLAST = "$src_dir/usr/bin/blastpgp"; # PSI-BLAST (duh.)
++my $NR = "$shareware_dir/nr"; # nr blast database filename
++my $VALL_BLAST_DB = "$shareware_dir/rosetta-fragments/nnmake_database/vall.blast.2006-05-05"; # vall blast database filename (cvs respository 'nnmake_database')
++my $BLOSUM = "$shareware_dir/rosetta-fragments/nnmake_database/"; # BLOSUM score matrices directory (cvs repository 'nnmake_database')
+
+ # psipred
+-my $FILTNR = "$scratch/genomes/filtnr"; # filtnr blast database filename
+-my $MAKEMAT = "$shareware_dir/blast/bin/makemat"; # makemat utility (part of NCBI tools)
+-my $PSIPRED = "$shareware_dir/psipred/bin/psipred"; # psipred
+-my $PSIPASS2 = "$shareware_dir/psipred/bin/psipass2"; # psipass2 (part of psipred pkg)
++my $FILTNR = "$src_dir/tmp/filtnr"; # filtnr blast database filename
++my $MAKEMAT = "$src_dir/usr/bin/makemat"; # makemat utility (part of NCBI tools)
++my $PSIPRED = "$src_dir/usr/bin/psipred"; # psipred
++my $PSIPASS2 = "$src_dir/usr/bin/psipass2"; # psipass2 (part of psipred pkg)
+ my $PSIPRED_DATA = "$shareware_dir/psipred/data"; # dir containing psipred data files.
+
+ # prof
+ #my $PROF = "$shareware_dir/prof/run_prof.py";
+-my $PROF = "$src_dir/nnmake/run_prof.py"; # remember to change prof executable location in run_prof.py
++my $PROF = "$src_dir/usr/bin/run_prof.py"; # remember to change prof executable location in run_prof.py
+
+ # nnmake
+-my $VALL = "$scratch/nnmake_database"; # dir containing vall database (cvs repository 'nnmake_database')
+-my $VALL2 = "$scratch/nnmake_database"; # alt dir containing vall database (cvs repository 'nnmake_database')
++my $VALL = "$shareware_dir/rosetta-fragments/nnmake_database"; # dir containing vall database (cvs repository 'nnmake_database')
++my $VALL2 = "$shareware_dir/rosetta-fragments/nnmake_database"; # alt dir containing vall database (cvs repository 'nnmake_database')
+ my $VALL_NAME = "vall.dat.2006-05-05"; # filename of vall (vall.dat.<id> and vall_cst_coord.dat.<id> must exist)
+-my $NNMAKE = "$src_dir/nnmake/pNNMAKE.gnu"; # nnmake binary (cvs respository 'nnmake')
+-my $TRIMLOOPS = "$src_dir/nnmake/trimLoopLibrary.pl"; # trimLoopLibrary.pl (cvs respository 'nnmake')
++my $NNMAKE = "$src_dir/usr/bin/pNNMAKE"; # nnmake binary (cvs respository 'nnmake')
++my $TRIMLOOPS = "$src_dir/usr/bin/trimLoopLibrary.pl"; # trimLoopLibrary.pl (cvs respository 'nnmake')
+
+ # chemshift
+-my $CHEMSHIFT = "$src_dir/chemshift/pCHEMSHIFT.gnu"; # chemshift binary (cvs repository 'chemshift')
+-my $TALOS_DB = "$scratch/chemshift_database"; # TALOS databases directory (cvs respository 'chemshift_database')
++my $CHEMSHIFT = "$src_dir/usr/bin/pCHEMSHIFT"; # chemshift binary (cvs repository 'chemshift')
++my $TALOS_DB = "$shareware_dir/rosetta-fragments/chemshift_database"; # TALOS databases directory (cvs respository 'chemshift_database')
+
+ # jufo (secondary structure prediction software)
+ my $JUFO = "$shareware_dir/jufo/molecule.exe"; # jufo executable
+diff --git a/nnmake/makefile b/nnmake/makefile
+index c09ac1c..ebfde68 100644
+--- a/nnmake/makefile
++++ b/nnmake/makefile
+@@ -102,7 +102,7 @@ VallCoord: coord_compile
+ # rule to compile executable
+ compile: print $(BASE_NAME).$(COMPILER)
+ $(BASE_NAME).$(COMPILER) : ${OBJS}
+- $(F77) $(FFLAGS) -o $@ $(OBJS) $(LINKFLAGS)
++ $(F77) $(FFLAGS) $(LDFLAGS) -o $@ $(OBJS) $(LINKFLAGS)
+
+ coord_compile: print $(COORD_BASE_NAME).$(COMPILER)
+ $(COORD_BASE_NAME).$(COMPILER) : ${COORD_OBJS}
diff --git a/sci-libs/rosetta-fragments/metadata.xml b/sci-libs/rosetta-fragments/metadata.xml
new file mode 100644
index 000000000000..ae9ec7c5f6a4
--- /dev/null
+++ b/sci-libs/rosetta-fragments/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-chemistry</herd>
+ <maintainer>
+ <email>jlec@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>
diff --git a/sci-libs/rosetta-fragments/rosetta-fragments-3.1-r1.ebuild b/sci-libs/rosetta-fragments/rosetta-fragments-3.1-r1.ebuild
new file mode 100644
index 000000000000..c659931015d9
--- /dev/null
+++ b/sci-libs/rosetta-fragments/rosetta-fragments-3.1-r1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils flag-o-matic prefix toolchain-funcs
+
+DESCRIPTION="Fragment library for rosetta"
+HOMEPAGE="http://www.rosettacommons.org"
+SRC_URI="rosetta3.1_fragments.tgz"
+
+LICENSE="rosetta"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND=""
+RDEPEND="
+ sci-biology/ncbi-tools
+ || ( sci-biology/update-blastdb sci-biology/ncbi-tools++ )
+ sci-biology/psipred"
+
+RESTRICT="fetch"
+
+S="${WORKDIR}"/${PN/-/_}
+
+pkg_nofetch() {
+ einfo "Go to ${HOMEPAGE} and get ${PN}.tgz and rename it to ${A}"
+ einfo "which must be placed in ${DISTDIR}"
+}
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-nnmake.patch \
+ "${FILESDIR}"/${P}-chemshift.patch
+ tc-export F77
+ eprefixify nnmake/*.pl
+}
+
+src_compile() {
+ emake -C nnmake
+ emake -C chemshift
+}
+
+src_install() {
+ esvn_clean .
+
+ newbin nnmake/pNNMAKE.gnu pNNMAKE
+ newbin chemshift/pCHEMSHIFT.gnu pCHEMSHIFT
+
+ dobin nnmake/*.pl
+
+ insinto /usr/share/${PN}
+ doins -r *_database
+ dodoc fragments.README nnmake/{nnmake.README,vall/*.pl} chemshift/chemshift.README
+}