summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-libs/scikits_timeseries
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-libs/scikits_timeseries')
-rw-r--r--sci-libs/scikits_timeseries/Manifest2
-rw-r--r--sci-libs/scikits_timeseries/metadata.xml16
-rw-r--r--sci-libs/scikits_timeseries/scikits_timeseries-0.91.3-r1.ebuild48
3 files changed, 66 insertions, 0 deletions
diff --git a/sci-libs/scikits_timeseries/Manifest b/sci-libs/scikits_timeseries/Manifest
new file mode 100644
index 000000000000..3b4ae8899012
--- /dev/null
+++ b/sci-libs/scikits_timeseries/Manifest
@@ -0,0 +1,2 @@
+DIST scikits.timeseries-0.91.3-html_docs.zip 907495 SHA256 181db1fa0d4b8eac5235eff79fad393c54ef82163cfcee0d78c550869ad8e11a SHA512 9fb474e2a13dee865801fa5aa5f05bb74ea2387b7e14d716210898d9b338b63b7f1935f7a5514d72ffcd6f4a8552054094244fab199e18c819815d4b19cd3f23 WHIRLPOOL d0dacdd7aa31785b68155f3507e34738d83316e72f5439875c0d641b72a7d600cc8e169fd9c84647fa29f7f4051c83f92884a5d5dd197aec2269093de13a0344
+DIST scikits.timeseries-0.91.3.tar.gz 323771 SHA256 2c4f74f1151763c231df713e9f990d0f7961cae0be59e31d3bb41781eadca6c0 SHA512 ea7292bf4d9bcce416b6f0e2c99fc40afe97a3a0210c535bd68f43a4a553d8a30cb77ce00f96ffc26340d5ff837faf5d480ea775385769495eccb5a196a88617 WHIRLPOOL eb93ae2a3a1cb1a767acff9b07ada738dabaef56f5312a16903f4d49134f630700d794ae81a5dd44501f87cd5c93e46b461b0566fb386fca640e7c4ee61e691a
diff --git a/sci-libs/scikits_timeseries/metadata.xml b/sci-libs/scikits_timeseries/metadata.xml
new file mode 100644
index 000000000000..775e9e167d18
--- /dev/null
+++ b/sci-libs/scikits_timeseries/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci</herd>
+ <herd>proxy-maintainers</herd>
+ <longdescription lang="en">
+ The scikits.timeseries module provides classes and functions for
+ manipulating, reporting, and plotting time series of various
+ frequencies. The focus is on convenient data access and manipulation
+ while leveraging the existing mathematical functionality in numpy
+ and scipy.
+</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">pytseries</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/sci-libs/scikits_timeseries/scikits_timeseries-0.91.3-r1.ebuild b/sci-libs/scikits_timeseries/scikits_timeseries-0.91.3-r1.ebuild
new file mode 100644
index 000000000000..332bae5afb4f
--- /dev/null
+++ b/sci-libs/scikits_timeseries/scikits_timeseries-0.91.3-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+MY_P="${P/scikits_/scikits.}"
+
+DESCRIPTION="SciPy module for manipulating, reporting, and plotting time series"
+HOMEPAGE="http://pytseries.sourceforge.net/index.html"
+SRC_URI="
+ mirror://sourceforge/pytseries/${MY_P}.tar.gz
+ doc? ( mirror://sourceforge/pytseries/${MY_P}-html_docs.zip )"
+
+LICENSE="BSD eGenixPublic-1.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+RDEPEND="
+ sci-libs/scipy[${PYTHON_USEDEP}]
+ sci-libs/scikits[${PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/pytables[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}/${MY_P}"
+
+python_test() {
+ esetup.py test
+}
+
+python_install() {
+ distutils-r1_python_install
+ rm "${D}"$(python_get_sitedir)/scikits/__init__.py || die
+}
+
+python_install_all() {
+ use doc && HTMLDOCS=( "${WORKDIR}/html" )
+ distutils-r1_python_install_all
+}