summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlessandro Barbieri <lssndrbarbieri@gmail.com>2019-09-28 12:03:16 +0200
committerDavid Seifert <soap@gentoo.org>2019-10-20 14:47:58 +0200
commite155288972e5439827ac9d0c30f7904a1d753caa (patch)
tree0f25f4faf229d834f2ea89083b2166bcb556259c /sci-libs/tamu_anova
parentprofiles/package.mask: mask ruby24-only packages for removal (diff)
downloadgentoo-e155288972e5439827ac9d0c30f7904a1d753caa.tar.gz
gentoo-e155288972e5439827ac9d0c30f7904a1d753caa.tar.bz2
gentoo-e155288972e5439827ac9d0c30f7904a1d753caa.zip
sci-libs/tamu_anova: various fixes
* EAPI 7 bump * disable static library * added missing build dep * Debian as new upstream Closes: https://bugs.gentoo.org/617806 Closes: https://github.com/gentoo/gentoo/pull/13071 Package-Manager: Portage-2.3.76, Repoman-2.3.17 Signed-off-by: Alessandro Barbieri <lssndrbarbieri@gmail.com> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sci-libs/tamu_anova')
-rw-r--r--sci-libs/tamu_anova/Manifest2
-rw-r--r--sci-libs/tamu_anova/files/0.2-gentoo.patch (renamed from sci-libs/tamu_anova/files/0.2.1-gentoo.patch)0
-rw-r--r--sci-libs/tamu_anova/files/tamu_anova-0.2-texinfo5.1.patch (renamed from sci-libs/tamu_anova/files/tamu_anova-0.2.1-texinfo5.1.patch)0
-rw-r--r--sci-libs/tamu_anova/tamu_anova-0.2-r1.ebuild39
-rw-r--r--sci-libs/tamu_anova/tamu_anova-0.2.1.ebuild27
5 files changed, 40 insertions, 28 deletions
diff --git a/sci-libs/tamu_anova/Manifest b/sci-libs/tamu_anova/Manifest
index 94f6bd123f5b..756d2dae551b 100644
--- a/sci-libs/tamu_anova/Manifest
+++ b/sci-libs/tamu_anova/Manifest
@@ -1 +1 @@
-DIST tamu_anova-0.2.1.tar.gz 220803 BLAKE2B dab9762a34c0abdeae900bc26864874dc33b60c19dafd06ddb6d41670c142d33c034e61b45d10d1c609d8b38af40514578f40b53b413256a38a1956036728bb1 SHA512 e4e65997d8ca57b5ad1c0001abbe41652fa86f8b8e9e00aa53d8079062e028baee67436408997d96d87c85801c48e1c87f40dfe291d387cd94dcefd61a52c477
+DIST tamuanova_0.2.orig.tar.gz 220803 BLAKE2B dab9762a34c0abdeae900bc26864874dc33b60c19dafd06ddb6d41670c142d33c034e61b45d10d1c609d8b38af40514578f40b53b413256a38a1956036728bb1 SHA512 e4e65997d8ca57b5ad1c0001abbe41652fa86f8b8e9e00aa53d8079062e028baee67436408997d96d87c85801c48e1c87f40dfe291d387cd94dcefd61a52c477
diff --git a/sci-libs/tamu_anova/files/0.2.1-gentoo.patch b/sci-libs/tamu_anova/files/0.2-gentoo.patch
index 4d4c1f4a0af1..4d4c1f4a0af1 100644
--- a/sci-libs/tamu_anova/files/0.2.1-gentoo.patch
+++ b/sci-libs/tamu_anova/files/0.2-gentoo.patch
diff --git a/sci-libs/tamu_anova/files/tamu_anova-0.2.1-texinfo5.1.patch b/sci-libs/tamu_anova/files/tamu_anova-0.2-texinfo5.1.patch
index f0c0570fc46d..f0c0570fc46d 100644
--- a/sci-libs/tamu_anova/files/tamu_anova-0.2.1-texinfo5.1.patch
+++ b/sci-libs/tamu_anova/files/tamu_anova-0.2-texinfo5.1.patch
diff --git a/sci-libs/tamu_anova/tamu_anova-0.2-r1.ebuild b/sci-libs/tamu_anova/tamu_anova-0.2-r1.ebuild
new file mode 100644
index 000000000000..36f86cfa54bf
--- /dev/null
+++ b/sci-libs/tamu_anova/tamu_anova-0.2-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="ANOVA Extensions to the GNU Scientific Library"
+HOMEPAGE="https://tracker.debian.org/pkg/tamuanova"
+SRC_URI="http://cdn-fastly.deb.debian.org/debian/pool/main/t/tamuanova/tamuanova_${PV}.orig.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-linux"
+
+RDEPEND="sci-libs/gsl:0="
+DEPEND="${RDEPEND}"
+BDEPEND="sys-apps/texinfo"
+
+S="${WORKDIR}"/${PN}-0.2
+
+PATCHES=(
+ "${FILESDIR}"/${PV}-gentoo.patch
+ "${FILESDIR}"/${P}-texinfo5.1.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf --disable-static
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
diff --git a/sci-libs/tamu_anova/tamu_anova-0.2.1.ebuild b/sci-libs/tamu_anova/tamu_anova-0.2.1.ebuild
deleted file mode 100644
index 5ae7872d14fe..000000000000
--- a/sci-libs/tamu_anova/tamu_anova-0.2.1.ebuild
+++ /dev/null
@@ -1,27 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=4
-
-AUTOTOOLS_AUTORECONF=yes
-
-inherit autotools-utils
-
-DESCRIPTION="ANOVA Extensions to the GNU Scientific Library"
-HOMEPAGE="http://www.stat.tamu.edu/~aredd/tamuanova/"
-SRC_URI="http://www.stat.tamu.edu/~aredd/tamuanova/${PN}-0.2.tar.gz -> ${P}.tar.gz"
-
-SLOT="0"
-KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
-LICENSE="GPL-2"
-IUSE="static-libs"
-
-RDEPEND="sci-libs/gsl"
-DEPEND="${RDEPEND}"
-
-S="${WORKDIR}"/${PN}-0.2
-
-PATCHES=(
- "${FILESDIR}"/${PV}-gentoo.patch
- "${FILESDIR}"/${P}-texinfo5.1.patch
- )