summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Zaman <perfinion@gentoo.org>2019-12-02 17:34:18 +0800
committerJason Zaman <perfinion@gentoo.org>2019-12-02 22:50:02 +0800
commit20b80def0c29932e1435e9fdfa05e0de259dbbd2 (patch)
tree838bf7c72cedd5810e48d7ce95d7bbd24b3660dd /sci-libs/tensorflow-estimator
parentsci-libs/tensorflow-estimator: drop python2_7 support (diff)
downloadgentoo-20b80def0c29932e1435e9fdfa05e0de259dbbd2.tar.gz
gentoo-20b80def0c29932e1435e9fdfa05e0de259dbbd2.tar.bz2
gentoo-20b80def0c29932e1435e9fdfa05e0de259dbbd2.zip
sci-libs/tensorflow-estimator: drop old
Package-Manager: Portage-2.3.79, Repoman-2.3.16 Signed-off-by: Jason Zaman <perfinion@gentoo.org>
Diffstat (limited to 'sci-libs/tensorflow-estimator')
-rw-r--r--sci-libs/tensorflow-estimator/Manifest1
-rw-r--r--sci-libs/tensorflow-estimator/tensorflow-estimator-1.13.0.ebuild61
2 files changed, 0 insertions, 62 deletions
diff --git a/sci-libs/tensorflow-estimator/Manifest b/sci-libs/tensorflow-estimator/Manifest
index 58814ea86873..9a00ca7d70e9 100644
--- a/sci-libs/tensorflow-estimator/Manifest
+++ b/sci-libs/tensorflow-estimator/Manifest
@@ -1,4 +1,3 @@
-DIST tensorflow-estimator-1.13.0.tar.gz 530871 BLAKE2B 4f208ed20e10fa68e06d21c9865cd07623e14362bdcff456bc9b412431c8f12f289c8a8f8ad89cb1f0ec98b1432844632d7e1097ea29d40bf6f67b90b4968f93 SHA512 e4be92b805776d2be5f391f737f1043b994f42721173c4d4a7dbf3fac9b00121cb072091a474bf71c7dcd952fc8b330cf9254c7a5ad9d096ba1cdc12ba12078b
DIST tensorflow-estimator-1.14.0.tar.gz 670750 BLAKE2B d24bba87131605f965be05cd76103e77c45c606af685f08d478cf4acaf2975aba6134bfe9ea51d1837297cf4ce5339bad761af6c00077193ccbae3f1bbcaa667 SHA512 65d21f4d275edc57feb0b36775f275d7b7adc1f5c2958b8269dcf61bed0189570adcb2eaf981e2ae4ba7e6ccec6d4d467384a267a6a29c325dc8126b1bdced5a
DIST tensorflow-estimator-1.15.0.tar.gz 696331 BLAKE2B 67aac4adb05149de13d68595e3520f4b843dedd48b58b0b0bea920767f04f64291842b9931f2540b6c6e997bbd01f8e23f64da9ea02ee295f57c777186e5ab19 SHA512 ea0f0c9f74db3d7bed5ee2b38a8eafbeae8fddd824c410461a88ecebc3e11ad6f885cc7404b3af8c7751562bbc2b71fb7e0e5627cb5dea05617ec1a383279bee
DIST tensorflow-estimator-2.0.0.tar.gz 618578 BLAKE2B e7e13b6a38f9d23350510aaef689761bc8459556db487572da0ee07d5ae0f1b0ec62517037ecd2f6b109f9657d42127a149405b7780dba4c1086f87319d77ad6 SHA512 99bbdb4be9cd9f46128657b262fc6daa61a1dbfad6c430c43bb62ef99cefec10b10bf03090adcb21bdac0404e00084b4e5c4961761a52462afdeb105ef1e0c73
diff --git a/sci-libs/tensorflow-estimator/tensorflow-estimator-1.13.0.ebuild b/sci-libs/tensorflow-estimator/tensorflow-estimator-1.13.0.ebuild
deleted file mode 100644
index f9250b24498f..000000000000
--- a/sci-libs/tensorflow-estimator/tensorflow-estimator-1.13.0.ebuild
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python{3_5,3_6,3_7} )
-MY_PN="estimator"
-MY_PV=${PV/_rc/-rc}
-MY_P=${MY_PN}-${MY_PV}
-
-inherit bazel distutils-r1 flag-o-matic toolchain-funcs
-
-DESCRIPTION="A high-level TensorFlow API that greatly simplifies machine learning programming"
-HOMEPAGE="https://www.tensorflow.org/"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE=""
-
-SRC_URI="https://github.com/tensorflow/${MY_PN}/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
-
-RDEPEND="sci-libs/tensorflow[python,${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}"
-BDEPEND="
- dev-java/java-config"
-
-S="${WORKDIR}/${MY_P}"
-
-PATCHES=(
- "${FILESDIR}/0001-pip_package-modularize-build-script-to-allow-distros.patch"
-)
-DOCS=( CONTRIBUTING.md README.md )
-
-src_prepare() {
- bazel_setup_bazelrc
- default
-}
-
-src_compile() {
- export JAVA_HOME=$(java-config --jre-home)
-
- ebazel build //tensorflow_estimator/tools/pip_package:build_pip_package
- ebazel shutdown
-
- local srcdir="${T}/src"
- mkdir -p "${srcdir}" || die
- bazel-bin/tensorflow_estimator/tools/pip_package/build_pip_package --src "${srcdir}" || die
-}
-
-src_install() {
- do_install() {
- cd "${T}/src" || die
- esetup.py install
- python_optimize
- }
- python_foreach_impl do_install
-
- cd "${S}" || die
- einstalldocs
-}