summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2020-03-01 19:50:45 -0500
committerMichael Orlitzky <mjo@gentoo.org>2020-03-02 12:20:46 -0500
commitd3ff37a807618fd1463a8e667d088a2ba818b3de (patch)
tree028ee471bbc49ec274f15d462c7727ae14182fcb /sci-libs/umfpack
parentsci-libs/spqr: new version 2.0.9. (diff)
downloadgentoo-d3ff37a807618fd1463a8e667d088a2ba818b3de.tar.gz
gentoo-d3ff37a807618fd1463a8e667d088a2ba818b3de.tar.bz2
gentoo-d3ff37a807618fd1463a8e667d088a2ba818b3de.zip
sci-libs/umfpack: new version 5.7.9.
Update to EAPI=7 and fix the HOMEPAGE, SRC_URI, and LICENSE. This is part of a larger SuiteSparse v5.4.0 upgrade thanks to François Bissey whose sage-on-gentoo ebuilds I'm using. There's a newer release (v5.7.1) of SuiteSparse, but v5.4.0 has seen more testing. The dependency on cholmod probably needs some USE flags, because the previous version dependend on !minimal. I can't figure out which of the modules implied by !minimal are necessary, though, now that the flags have been separated out. Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'sci-libs/umfpack')
-rw-r--r--sci-libs/umfpack/Manifest1
-rw-r--r--sci-libs/umfpack/umfpack-5.7.9.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/sci-libs/umfpack/Manifest b/sci-libs/umfpack/Manifest
index cb66bb194776..8c04f60db6f7 100644
--- a/sci-libs/umfpack/Manifest
+++ b/sci-libs/umfpack/Manifest
@@ -1 +1,2 @@
DIST umfpack-5.6.2.tar.bz2 780204 BLAKE2B 9e0f4abe92139e3cd6604be63d7fea0ffe50e0669081cafe07eef5d16a4c99493ace16a36a13470d617944cef2c505a3feadb5324e0add4a7f7fe6cbaa732fd3 SHA512 7b206235e837e84885c871322c1f0d4378a048008d9c110bd96204e9bc1bd9c72c6909da513fd78b6225fddc7b91e1ceebf1a5147e99943b3f0fff48682403dc
+DIST umfpack-5.7.9.tar.bz2 772026 BLAKE2B 6d6dc1ba47b8f473884c1cb17d3eaa363d88281512e33586a0af0c2bcb7a523272bef4d8da0a29e2a5a84c8f0cd0ee6830ec10247971db63b4c319e6fa9a3c42 SHA512 5ad57467b5b7e4579f3cc9e2e7c92a0262ac2ef991a606d079b749b66e10da60aceaa4b0e741c116f8866da23c0f7c06368fe2b08d66d51383683f0dcbeddba3
diff --git a/sci-libs/umfpack/umfpack-5.7.9.ebuild b/sci-libs/umfpack/umfpack-5.7.9.ebuild
new file mode 100644
index 000000000000..d4c065afcadf
--- /dev/null
+++ b/sci-libs/umfpack/umfpack-5.7.9.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Unsymmetric multifrontal sparse LU factorization library"
+HOMEPAGE="http://faculty.cse.tamu.edu/davis/suitesparse.html"
+SRC_URI="http://202.36.178.9/sage/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-macos"
+IUSE="doc +cholmod static-libs"
+
+BDEPEND="virtual/pkgconfig
+ doc? ( virtual/latex-base )"
+DEPEND="sci-libs/amd
+ >=sci-libs/suitesparseconfig-5.4.0
+ virtual/blas
+ cholmod? ( sci-libs/cholmod )"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ econf \
+ --with-blas="$($(tc-getPKG_CONFIG) --libs blas)" \
+ $(use_with doc) \
+ $(use_enable static-libs static) \
+ $(use_with cholmod)
+}