summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDennis Lamm <expeditioneer@gentoo.org>2021-03-12 05:45:25 +0100
committerDennis Lamm <expeditioneer@gentoo.org>2021-03-12 08:05:48 +0100
commit335d6530649be9e5e4d94d279c812fca505f97a7 (patch)
treec4228931b52cde68f25f05c19505bc8261ddcfe1 /sci-libs
parentmedia-gfx/meshlab: drop old (diff)
downloadgentoo-335d6530649be9e5e4d94d279c812fca505f97a7.tar.gz
gentoo-335d6530649be9e5e4d94d279c812fca505f97a7.tar.bz2
gentoo-335d6530649be9e5e4d94d279c812fca505f97a7.zip
sci-libs/levmar: EAPI-7 bump
Closes: https://bugs.gentoo.org/770598 Signed-off-by: Dennis Lamm <expeditioneer@gentoo.org> Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: Dennis Lamm <expeditioneer@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/levmar/levmar-2.6-r1.ebuild49
-rw-r--r--sci-libs/levmar/metadata.xml2
2 files changed, 50 insertions, 1 deletions
diff --git a/sci-libs/levmar/levmar-2.6-r1.ebuild b/sci-libs/levmar/levmar-2.6-r1.ebuild
new file mode 100644
index 000000000000..0141944adb95
--- /dev/null
+++ b/sci-libs/levmar/levmar-2.6-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake toolchain-funcs
+
+DESCRIPTION="Levenberg-Marquardt nonlinear least squares C library"
+HOMEPAGE="https://www.ics.forth.gr/~lourakis/levmar/"
+SRC_URI="https://www.ics.forth.gr/~lourakis/levmar/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ virtual/blas
+ virtual/lapack"
+BDEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-shared.patch
+ "${FILESDIR}"/${P}-demo-underlinking.patch
+)
+
+DOCS=(README.txt)
+
+src_configure() {
+ local mycmakeargs+=(
+ -DNEED_F2C=OFF
+ -DHAVE_LAPACK=ON
+ -DLAPACKBLAS_LIB_NAMES="$($(tc-getPKG_CONFIG) --libs blas lapack)"
+ -DBUILD_DEMO=$(usex test)
+ )
+ cmake_src_configure
+}
+
+src_test() {
+ "${BUILD_DIR}"/lmdemo || die "Tests failed"
+}
+
+src_install() {
+ dolib.so "${BUILD_DIR}"/liblevmar.so
+ insinto /usr/include
+ doins "${S}"/levmar.h
+}
diff --git a/sci-libs/levmar/metadata.xml b/sci-libs/levmar/metadata.xml
index 114a1bee0b24..6007842dab25 100644
--- a/sci-libs/levmar/metadata.xml
+++ b/sci-libs/levmar/metadata.xml
@@ -8,7 +8,7 @@
<email>3dprint@gentoo.org</email>
<name>Gentoo 3D print</name>
</maintainer>
- <longdescription lang="en">
+ <longdescription>
levmar is a native ANSI C implementation of the Levenberg-Marquardt
optimization algorithm. Both unconstrained and constrained (under
linear equations, inequality and box constraints)