summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-10-14 13:44:04 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-10-14 15:35:05 +0200
commit80cceb37cdd7966792abb91376759b287fd95b94 (patch)
tree3cb9019e6c348c7c1470d5e98f8c1e69ad725509 /sci-libs
parentsci-libs/lemon: Sort DEPENDs, one line per dep, https download (diff)
downloadgentoo-80cceb37cdd7966792abb91376759b287fd95b94.tar.gz
gentoo-80cceb37cdd7966792abb91376759b287fd95b94.tar.bz2
gentoo-80cceb37cdd7966792abb91376759b287fd95b94.zip
sci-libs/exodusii: EAPI-6 bump, fix LIB_SUFFIX, unused cmake args
Fix dead HOMEPAGE, SRC_URI. Closes: https://bugs.gentoo.org/644588 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/exodusii/exodusii-6.09.ebuild29
-rw-r--r--sci-libs/exodusii/files/exodusii-6.09-multilib.patch18
2 files changed, 24 insertions, 23 deletions
diff --git a/sci-libs/exodusii/exodusii-6.09.ebuild b/sci-libs/exodusii/exodusii-6.09.ebuild
index a91a3e96e992..7f44f3f24c74 100644
--- a/sci-libs/exodusii/exodusii-6.09.ebuild
+++ b/sci-libs/exodusii/exodusii-6.09.ebuild
@@ -1,18 +1,17 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=6
FORTRAN_NEEDED="test"
-
-inherit cmake-utils fortran-2 multilib
+inherit cmake-utils fortran-2
MY_PN="${PN%ii}"
MY_P="${MY_PN}-${PV}"
DESCRIPTION="Model developed to store and retrieve transient data for finite element analyses"
-HOMEPAGE="https://sourceforge.net/projects/exodusii/"
-SRC_URI="mirror://sourceforge/project/${PN}/${MY_P}.tar.gz"
+HOMEPAGE="https://github.com/certik/exodus"
+SRC_URI="https://dev.gentoo.org/~asturm/distfiles/${MY_P}.tar.gz"
LICENSE="BSD"
SLOT="0"
@@ -29,21 +28,23 @@ S="${WORKDIR}"/${MY_P}/${MY_PN}
PATCHES=( "${FILESDIR}"/${P}-multilib.patch )
src_prepare() {
- use test || \
- sed \
- -e 's:Fortran::g' \
- -i CMakeLists.txt || die
cmake-utils_src_prepare
+
+ if ! use test; then
+ sed -e 's:Fortran::g' -i CMakeLists.txt || die
+ fi
}
src_configure() {
+ local libdir="$(get_libdir)"
+
local mycmakeargs=(
- -DLIB_INSTALL_DIR=$(get_libdir)
- -DNETCDF_DIR="${EPREFIX}/usr/"
+ -DLIB_SUFFIX=${libdir#lib}
-DPYTHON_INSTALL="${EPREFIX}/usr/share/${PN}"
- $(cmake-utils_use_build !static-libs SHARED)
- $(cmake-utils_use_build test TESTING)
+ -DBUILD_SHARED=$(usex !static-libs)
+ -DBUILD_TESTING=$(usex test)
)
+ export NETCDF_DIR="${EPREFIX}/usr/"
cmake-utils_src_configure
}
diff --git a/sci-libs/exodusii/files/exodusii-6.09-multilib.patch b/sci-libs/exodusii/files/exodusii-6.09-multilib.patch
index 3b1b5e2ace7f..5463fba50019 100644
--- a/sci-libs/exodusii/files/exodusii-6.09-multilib.patch
+++ b/sci-libs/exodusii/files/exodusii-6.09-multilib.patch
@@ -1,6 +1,6 @@
-diff -Naur exodus-6.09.orig/exodus/cbind/CMakeLists.txt exodus-6.09/exodus/cbind/CMakeLists.txt
---- exodus-6.09.orig/exodus/cbind/CMakeLists.txt 2016-05-10 13:20:06.408385120 -0600
-+++ exodus-6.09/exodus/cbind/CMakeLists.txt 2016-05-10 13:22:35.378385120 -0600
+diff -Naur a/cbind/CMakeLists.txt b/cbind/CMakeLists.txt
+--- a/cbind/CMakeLists.txt 2016-05-10 13:20:06.408385120 -0600
++++ b/cbind/CMakeLists.txt 2016-05-10 13:22:35.378385120 -0600
@@ -293,9 +293,9 @@
IF(NOT EXODUS_INSTALL_NO_LIBRARIES)
@@ -14,9 +14,9 @@ diff -Naur exodus-6.09.orig/exodus/cbind/CMakeLists.txt exodus-6.09/exodus/cbind
INSTALL(FILES ${cbind_HEADERS} DESTINATION include COMPONENT Development)
ENDIF(NOT EXODUS_INSTALL_NO_LIBRARIES)
-diff -Naur exodus-6.09.orig/exodus/CMakeLists.txt exodus-6.09/exodus/CMakeLists.txt
---- exodus-6.09.orig/exodus/CMakeLists.txt 2016-05-10 13:20:06.418385120 -0600
-+++ exodus-6.09/exodus/CMakeLists.txt 2016-05-10 13:21:25.928385120 -0600
+diff -Naur a/CMakeLists.txt b/CMakeLists.txt
+--- a/CMakeLists.txt 2016-05-10 13:20:06.418385120 -0600
++++ b/CMakeLists.txt 2016-05-10 13:21:25.928385120 -0600
@@ -27,7 +27,7 @@
find_library( NETCDF_LIBRARY
NAMES netcdf
@@ -43,9 +43,9 @@ diff -Naur exodus-6.09.orig/exodus/CMakeLists.txt exodus-6.09/exodus/CMakeLists.
$ENV{NETCDF_DIR}/libsrc/.libs
/usr/local/hdf5/lib
)
-diff -Naur exodus-6.09.orig/exodus/forbind/CMakeLists.txt exodus-6.09/exodus/forbind/CMakeLists.txt
---- exodus-6.09.orig/exodus/forbind/CMakeLists.txt 2016-05-10 13:20:06.418385120 -0600
-+++ exodus-6.09/exodus/forbind/CMakeLists.txt 2016-05-10 13:21:25.928385120 -0600
+diff -Naur a/forbind/CMakeLists.txt b/forbind/CMakeLists.txt
+--- a/forbind/CMakeLists.txt 2016-05-10 13:20:06.418385120 -0600
++++ b/forbind/CMakeLists.txt 2016-05-10 13:21:25.928385120 -0600
@@ -14,7 +14,7 @@
find_library( NETCDF_LIBRARY
NAMES netcdf