summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenda Xu <heroxbd@gentoo.org>2017-12-04 12:03:10 +0900
committerBenda Xu <heroxbd@gentoo.org>2017-12-04 12:03:40 +0900
commitc4f54efe1a826c1d06e9009bf182050e1a3753b3 (patch)
tree74bfbb4db2449d63c4a0927e7cda8f7278dc9010 /sci-libs
parentdev-python/setuptools-git-1.2: added ~mips, bug 631608 (diff)
downloadgentoo-c4f54efe1a826c1d06e9009bf182050e1a3753b3.tar.gz
gentoo-c4f54efe1a826c1d06e9009bf182050e1a3753b3.tar.bz2
gentoo-c4f54efe1a826c1d06e9009bf182050e1a3753b3.zip
sci-libs/hdf5: version bump.
Drop fortran2003 use flag, replace rpath hacks with hprefixify. Reported-by: Erik Quaeghebeur <gentoobugzilla@equaeghe.nospammail.net> Closes: https://bugs.gentoo.org/600656 Package-Manager: Portage-2.3.16, Repoman-2.3.6
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/hdf5/Manifest3
-rw-r--r--sci-libs/hdf5/hdf5-1.10.1.ebuild99
2 files changed, 101 insertions, 1 deletions
diff --git a/sci-libs/hdf5/Manifest b/sci-libs/hdf5/Manifest
index a988c49c5af4..7ec5335c9d8a 100644
--- a/sci-libs/hdf5/Manifest
+++ b/sci-libs/hdf5/Manifest
@@ -1 +1,2 @@
-DIST hdf5-1.8.18.tar.bz2 10081294 SHA256 01c6deadf4211f86922400da82c7a8b5b50dc8fc1ce0b5912de3066af316a48c SHA512 01f6d14bdd3be2ced9c63cc9e1820cd7ea11db649ff9f3a3055c18c4b0fffe777fd23baad536e3bce31c4d76fe17db64a3972762e1bb4d232927c1ca140e72b2 WHIRLPOOL c1ea97aa30ded9f3129edf47cfda3b7e371aa21fcb2fc409005818f69ed0f0ac41a19e28ec38a5da2c417ef98033f197292169c88f7db81dd94244b016ab2595
+DIST hdf5-1.10.1.tar.bz2 11769617 BLAKE2B 66ad762aed90cea9e58a9735bf0e189d78befc40cac0e566586e967f2b3ba6f5bf8a6bfd12a2f4062f8b20900c16d467c34134c17dedfd8f345cb96bd853a2fe SHA512 266b0e2f28c5fd540099a4955244ddb8c03aca3ad40d626358643f033a6ae5e9266a1d6c1d60925c7d42d24d28a1549d3305fe8ddb42cec2379af7231b93e554
+DIST hdf5-1.8.18.tar.bz2 10081294 BLAKE2B cf0d0c8a41576bcf816460eaabcfab29cfffba240721a64fe584c42fbb322470f29fb93c8513f7bbdedeeb392c2fe64cd3261b47b47de5b01828dae0b1929cd3 SHA512 01f6d14bdd3be2ced9c63cc9e1820cd7ea11db649ff9f3a3055c18c4b0fffe777fd23baad536e3bce31c4d76fe17db64a3972762e1bb4d232927c1ca140e72b2
diff --git a/sci-libs/hdf5/hdf5-1.10.1.ebuild b/sci-libs/hdf5/hdf5-1.10.1.ebuild
new file mode 100644
index 000000000000..5980c67ccda2
--- /dev/null
+++ b/sci-libs/hdf5/hdf5-1.10.1.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+FORTRAN_NEEDED=fortran
+AUTOTOOLS_AUTORECONF=1
+
+inherit autotools-utils eutils fortran-2 flag-o-matic toolchain-funcs multilib versionator prefix
+
+MY_P=${PN}-${PV/_p/-patch}
+MAJOR_P=${PN}-$(get_version_component_range 1-2 ${PV})
+
+DESCRIPTION="General purpose library and file format for storing scientific data"
+HOMEPAGE="http://www.hdfgroup.org/HDF5/"
+SRC_URI="http://www.hdfgroup.org/ftp/HDF5/releases/${MAJOR_P}/${MY_P}/src/${MY_P}.tar.bz2"
+
+LICENSE="NCSA-HDF"
+SLOT="0/${PV%%_p*}"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE="cxx debug examples fortran fortran2003 mpi static-libs szip threads zlib"
+
+REQUIRED_USE="
+ cxx? ( !mpi ) mpi? ( !cxx )
+ threads? ( !cxx !mpi !fortran )
+ fortran2003? ( fortran )"
+
+RDEPEND="
+ mpi? ( virtual/mpi[romio] )
+ szip? ( virtual/szip )
+ zlib? ( sys-libs/zlib:0= )"
+
+DEPEND="${RDEPEND}
+ sys-devel/libtool:2
+ >=sys-devel/autoconf-2.69"
+
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.8.9-static_libgfortran.patch
+ "${FILESDIR}"/${PN}-1.8.9-mpicxx.patch
+ "${FILESDIR}"/${PN}-1.8.13-no-messing-ldpath.patch
+ "${FILESDIR}"/${PN}-1.8.15-implicits.patch
+)
+
+pkg_setup() {
+ tc-export CXX CC AR # workaround for bug 285148
+ if use fortran; then
+ use fortran2003 && FORTRAN_STANDARD=2003
+ fortran-2_pkg_setup
+ fi
+ if use mpi; then
+ if has_version 'sci-libs/hdf5[-mpi]'; then
+ ewarn "Installing hdf5 with mpi enabled with a previous hdf5 with mpi disabled may fail."
+ ewarn "Try to uninstall the current hdf5 prior to enabling mpi support."
+ fi
+ export CC=mpicc
+ use fortran && export FC=mpif90
+ elif has_version 'sci-libs/hdf5[mpi]'; then
+ ewarn "Installing hdf5 with mpi disabled while having hdf5 installed with mpi enabled may fail."
+ ewarn "Try to uninstall the current hdf5 prior to disabling mpi support."
+ fi
+}
+
+src_prepare() {
+ # respect gentoo examples directory
+ sed \
+ -e "s:hdf5_examples:doc/${PF}/examples:g" \
+ -i $(find . -name Makefile.am) $(find . -name "run*.sh.in") || die
+ sed \
+ -e '/docdir/d' \
+ -i config/commence.am || die
+ if ! use examples; then
+ sed -e '/^install:/ s/install-examples//' \
+ -i Makefile.am || die #409091
+ fi
+ # enable shared libs by default for h5cc config utility
+ sed -i -e "s/SHLIB:-no/SHLIB:-yes/g" tools/src/misc/h5cc.in || die
+ hprefixify m4/libtool.m4
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ local myeconfargs=(
+ --docdir="${EPREFIX}"/usr/share/doc/${PF}
+ --enable-deprecated-symbols
+ $(use debug && echo --enable-build-mode=debug || echo --enable-build-mode=production)
+ $(use_enable debug codestack)
+ $(use_enable cxx)
+ $(use_enable fortran)
+ $(use_enable fortran2003)
+ $(use_enable mpi parallel)
+ $(use_enable threads threadsafe)
+ $(use_with szip szlib)
+ $(use_with threads pthread)
+ $(use_with zlib)
+ )
+ autotools-utils_src_configure
+}