summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2022-05-18 20:13:31 -0400
committerMichael Orlitzky <mjo@gentoo.org>2022-05-18 20:13:46 -0400
commitd319d641b8f4b90b02375e6d968f139b5d58443e (patch)
treed0ed007d53e764a3f57466c981730b04c73cb677 /sci-mathematics/dunshire/dunshire-0.1.1-r2.ebuild
parentapp-misc/gramps: enable py3.10 (diff)
downloadgentoo-d319d641b8f4b90b02375e6d968f139b5d58443e.tar.gz
gentoo-d319d641b8f4b90b02375e6d968f139b5d58443e.tar.bz2
gentoo-d319d641b8f4b90b02375e6d968f139b5d58443e.zip
sci-mathematics/dunshire: new revision with python-3.10 support.
Closes: https://bugs.gentoo.org/846275 Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'sci-mathematics/dunshire/dunshire-0.1.1-r2.ebuild')
-rw-r--r--sci-mathematics/dunshire/dunshire-0.1.1-r2.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/sci-mathematics/dunshire/dunshire-0.1.1-r2.ebuild b/sci-mathematics/dunshire/dunshire-0.1.1-r2.ebuild
new file mode 100644
index 000000000000..a365b4c4e53c
--- /dev/null
+++ b/sci-mathematics/dunshire/dunshire-0.1.1-r2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python library to solve linear games over symmetric cones"
+HOMEPAGE="http://michael.orlitzky.com/code/dunshire/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="AGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="dev-python/cvxopt[${PYTHON_USEDEP}]"
+
+# Tests run on the build host? Bug #693916. There's one doctest that
+# uses a numpy matrix, sorry. That will be fixed in the next release.
+# Otherwise numpy is not needed; the required interfaces are provided
+# through cvxopt.
+BDEPEND="test? (
+ ${RDEPEND}
+ dev-python/numpy[${PYTHON_USEDEP}]
+)"
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/build/html/. )
+ local DOCS=( doc/README.rst )
+ distutils-r1_python_install_all
+}
+
+python_test() {
+ esetup.py test
+}