summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-10-06 21:18:26 +0200
committerMaciej Barć <xgqt@gentoo.org>2024-10-06 21:51:36 +0200
commit1dbb8ef709f77bc430ef5384ea32842541469fb3 (patch)
treed63205eb213d6de58916a44947192d93c05f385c /sci-mathematics/easycrypt/easycrypt-2024.09.ebuild
parentsys-apps/openrazer: bump to 3.9.0 (diff)
downloadgentoo-1dbb8ef709f77bc430ef5384ea32842541469fb3.tar.gz
gentoo-1dbb8ef709f77bc430ef5384ea32842541469fb3.tar.bz2
gentoo-1dbb8ef709f77bc430ef5384ea32842541469fb3.zip
sci-mathematics/easycrypt: bump to 2024.09
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'sci-mathematics/easycrypt/easycrypt-2024.09.ebuild')
-rw-r--r--sci-mathematics/easycrypt/easycrypt-2024.09.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/sci-mathematics/easycrypt/easycrypt-2024.09.ebuild b/sci-mathematics/easycrypt/easycrypt-2024.09.ebuild
new file mode 100644
index 000000000000..80d57075fb07
--- /dev/null
+++ b/sci-mathematics/easycrypt/easycrypt-2024.09.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="Computer-Aided Cryptographic Proofs"
+HOMEPAGE="https://github.com/EasyCrypt/easycrypt/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/EasyCrypt/${PN}.git"
+else
+ SRC_URI="https://github.com/EasyCrypt/${PN}/archive/r${PV}.tar.gz
+ -> ${P}.tar.gz"
+ S="${WORKDIR}/${PN}-r${PV}"
+
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+IUSE="+ocamlopt"
+
+RDEPEND="
+ <dev-ml/num-1.5:=
+ >=dev-lang/ocaml-4.08.0:=[ocamlopt?]
+ dev-ml/batteries:=
+ dev-ml/camlp-streams:=
+ dev-ml/camlzip:=
+ dev-ml/dune-build-info:=
+ dev-ml/dune-site:=
+ dev-ml/ocaml-inifiles:=
+ dev-ml/pcre-ocaml:=
+ dev-ml/yojson:=
+ dev-ml/zarith:=
+ sci-mathematics/why3:=
+"
+DEPEND="
+ ${RDEPEND}
+"
+
+src_prepare() {
+ local theories="[\"$(ocamlc -where)/easycrypt/theories\"]"
+ sed -i "s|EcRelocate\.Sites\.theories|${theories}|g" src/ec.ml || die
+
+ default
+}