summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2016-02-24 23:18:30 +0600
committerAndrey Grozin <grozin@gentoo.org>2016-02-24 23:18:30 +0600
commit8a17bc22b91f1969b73e696e59945d077a059191 (patch)
tree382b4e649be5f4257e0c3f82530a577fc29cc6ba /sci-mathematics/fricas
parentsci-mathematics/fricas: no longer need to restrict sbcl version (diff)
downloadgentoo-8a17bc22b91f1969b73e696e59945d077a059191.tar.gz
gentoo-8a17bc22b91f1969b73e696e59945d077a059191.tar.bz2
gentoo-8a17bc22b91f1969b73e696e59945d077a059191.zip
sci-mathematics/fricas: cleaning 1.2.7-r1
Package-Manager: portage-2.2.27
Diffstat (limited to 'sci-mathematics/fricas')
-rw-r--r--sci-mathematics/fricas/fricas-1.2.7-r1.ebuild102
1 files changed, 0 insertions, 102 deletions
diff --git a/sci-mathematics/fricas/fricas-1.2.7-r1.ebuild b/sci-mathematics/fricas/fricas-1.2.7-r1.ebuild
deleted file mode 100644
index 3601edc82109..000000000000
--- a/sci-mathematics/fricas/fricas-1.2.7-r1.ebuild
+++ /dev/null
@@ -1,102 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-EAPI=5
-inherit multilib elisp-common
-
-DESCRIPTION="FriCAS is a fork of Axiom computer algebra system"
-HOMEPAGE="http://${PN}.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}-full.tar.bz2"
-LICENSE="BSD-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-# Supported lisps, number 0 is the default
-LISPS=( sbcl cmucl gcl ecls clisp clozurecl )
-# Version restrictions, . means no restrictions
-REST=( "<=dev-lisp/sbcl-1.3.0" . . . . . )
-# command name: . means just ${LISP}
-COMS=( . lisp . ecl . ccl )
-
-IUSE="${LISPS[*]} X emacs gmp"
-RDEPEND="X? ( x11-libs/libXpm x11-libs/libICE )
- emacs? ( virtual/emacs )
- gmp? ( dev-libs/gmp )"
-
-# Generating lisp deps
-n=${#LISPS[*]}
-for ((n--; n > 0; n--)); do
- LISP=${LISPS[$n]}
- if [ "${REST[$n]}" = "." ]; then
- DEP="dev-lisp/${LISP}"
- else
- DEP="${REST[$n]}"
- fi
- RDEPEND="${RDEPEND} ${LISP}? ( ${DEP}:= ) !${LISP}? ("
-done
-if [ "${REST[0]}" = "." ]; then
- DEP="dev-lisp/${LISPS[0]}"
-else
- DEP="${REST[0]}"
-fi
-RDEPEND="${RDEPEND} ${DEP}:="
-n=${#LISPS[*]}
-for ((n--; n > 0; n--)); do
- RDEPEND="${RDEPEND} )"
-done
-
-DEPEND="${RDEPEND}"
-
-# necessary for clisp and gcl
-RESTRICT="strip"
-
-src_configure() {
- local LISP n
- LISP=sbcl
- n=${#LISPS[*]}
- for ((n--; n > 0; n--)); do
- if use ${LISPS[$n]}; then
- LISP=${COMS[$n]}
- if [ "${LISP}" = "." ]; then
- LISP=${LISPS[$n]}
- fi
- fi
- done
- einfo "Using lisp: ${LISP}"
-
- # aldor is not yet in portage
- econf --disable-aldor --with-lisp=${LISP} $(use_with X x) $(use_with gmp)
-}
-
-src_compile() {
- # bug #300132
- emake -j1
-}
-
-src_test() {
- emake -j1 all-input
-}
-
-src_install() {
- emake -j1 DESTDIR="${D}" install
- dodoc README FAQ
-
- if use emacs; then
- sed -e "s|(setq load-path (cons (quote \"/usr/$(get_libdir)/fricas/emacs\") load-path)) ||" \
- -i "${D}"/usr/bin/efricas \
- || die "sed efricas failed"
- elisp-install ${PN} "${D}"/usr/$(get_libdir)/${PN}/emacs/*.el
- elisp-site-file-install "${FILESDIR}"/64${PN}-gentoo.el
- else
- rm "${D}"/usr/bin/efricas || die "rm efricas failed"
- fi
- rm -r "${D}"/usr/$(get_libdir)/${PN}/emacs || die "rm -r emacs failed"
-}
-
-pkg_postinst() {
- use emacs && elisp-site-regen
-}
-
-pkg_postrm() {
- use emacs && elisp-site-regen
-}