summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2016-02-26 20:38:01 +0600
committerAndrey Grozin <grozin@gentoo.org>2016-02-26 20:38:01 +0600
commitaf6383eb3c405f92f626e9e59f786217f1e0f832 (patch)
treee715d18192b531bf636a98acb12eb63e809a9893 /sci-mathematics/fricas
parentsci-mathematics/fricas: sbcl version must be <=1.3.0 (diff)
downloadgentoo-af6383eb3c405f92f626e9e59f786217f1e0f832.tar.gz
gentoo-af6383eb3c405f92f626e9e59f786217f1e0f832.tar.bz2
gentoo-af6383eb3c405f92f626e9e59f786217f1e0f832.zip
sci-mathematics/fricas: cleaning 1.2.7-r2
Package-Manager: portage-2.2.27
Diffstat (limited to 'sci-mathematics/fricas')
-rw-r--r--sci-mathematics/fricas/fricas-1.2.7-r2.ebuild92
1 files changed, 0 insertions, 92 deletions
diff --git a/sci-mathematics/fricas/fricas-1.2.7-r2.ebuild b/sci-mathematics/fricas/fricas-1.2.7-r2.ebuild
deleted file mode 100644
index 3e1eadb4a4a0..000000000000
--- a/sci-mathematics/fricas/fricas-1.2.7-r2.ebuild
+++ /dev/null
@@ -1,92 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-EAPI=5
-inherit multilib elisp-common
-
-DESCRIPTION="FriCAS is a fork of Axiom computer algebra system"
-HOMEPAGE="http://${PN}.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}-full.tar.bz2"
-LICENSE="BSD-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-# Supported lisps, number 0 is the default
-LISPS=( sbcl cmucl gcl ecls clisp clozurecl )
-# command name: . means just ${LISP}
-COMS=( . lisp . ecl . ccl )
-
-IUSE="${LISPS[*]} X emacs gmp"
-RDEPEND="X? ( x11-libs/libXpm x11-libs/libICE )
- emacs? ( virtual/emacs )
- gmp? ( dev-libs/gmp:= )"
-
-# Generating lisp deps
-n=${#LISPS[*]}
-for ((n--; n > 0; n--)); do
- LISP=${LISPS[$n]}
- DEP="dev-lisp/${LISP}"
- RDEPEND="${RDEPEND} ${LISP}? ( ${DEP}:= ) !${LISP}? ("
-done
-DEP="dev-lisp/${LISPS[0]}"
-RDEPEND="${RDEPEND} ${DEP}:="
-n=${#LISPS[*]}
-for ((n--; n > 0; n--)); do
- RDEPEND="${RDEPEND} )"
-done
-
-DEPEND="${RDEPEND}"
-
-# necessary for clisp and gcl
-RESTRICT="strip"
-
-src_configure() {
- local LISP n
- LISP=sbcl
- n=${#LISPS[*]}
- for ((n--; n > 0; n--)); do
- if use ${LISPS[$n]}; then
- LISP=${COMS[$n]}
- if [ "${LISP}" = "." ]; then
- LISP=${LISPS[$n]}
- fi
- fi
- done
- einfo "Using lisp: ${LISP}"
-
- # aldor is not yet in portage
- econf --disable-aldor --with-lisp=${LISP} $(use_with X x) $(use_with gmp)
-}
-
-src_compile() {
- # bug #300132
- emake -j1
-}
-
-src_test() {
- emake -j1 all-input
-}
-
-src_install() {
- emake -j1 DESTDIR="${D}" install
- dodoc README FAQ
-
- if use emacs; then
- sed -e "s|(setq load-path (cons (quote \"/usr/$(get_libdir)/fricas/emacs\") load-path)) ||" \
- -i "${D}"/usr/bin/efricas \
- || die "sed efricas failed"
- elisp-install ${PN} "${D}"/usr/$(get_libdir)/${PN}/emacs/*.el
- elisp-site-file-install "${FILESDIR}"/64${PN}-gentoo.el
- else
- rm "${D}"/usr/bin/efricas || die "rm efricas failed"
- fi
- rm -r "${D}"/usr/$(get_libdir)/${PN}/emacs || die "rm -r emacs failed"
-}
-
-pkg_postinst() {
- use emacs && elisp-site-regen
-}
-
-pkg_postrm() {
- use emacs && elisp-site-regen
-}