summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2019-06-22 23:06:54 +0200
committerDavid Seifert <soap@gentoo.org>2019-06-22 23:06:54 +0200
commit6236187e8b9672b0006a0ba02520281821368036 (patch)
tree89c43b009392ae5356f65989a5d87a9c6d77a603 /sci-mathematics/gfan/gfan-0.5-r1.ebuild
parentdev-python/cffi: version bump to 1.12.3 (diff)
downloadgentoo-6236187e8b9672b0006a0ba02520281821368036.tar.gz
gentoo-6236187e8b9672b0006a0ba02520281821368036.tar.bz2
gentoo-6236187e8b9672b0006a0ba02520281821368036.zip
sci-mathematics/gfan: Port to EAPI 7
Package-Manager: Portage-2.3.67, Repoman-2.3.15 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sci-mathematics/gfan/gfan-0.5-r1.ebuild')
-rw-r--r--sci-mathematics/gfan/gfan-0.5-r1.ebuild32
1 files changed, 15 insertions, 17 deletions
diff --git a/sci-mathematics/gfan/gfan-0.5-r1.ebuild b/sci-mathematics/gfan/gfan-0.5-r1.ebuild
index ec591ee19578..5d1d84e462a4 100644
--- a/sci-mathematics/gfan/gfan-0.5-r1.ebuild
+++ b/sci-mathematics/gfan/gfan-0.5-r1.ebuild
@@ -1,38 +1,36 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-inherit eutils toolchain-funcs
+inherit toolchain-funcs
-DESCRIPTION="computes Groebner fans and tropical varities"
+DESCRIPTION="Compute Groebner fans and tropical varities"
HOMEPAGE="http://www.math.tu-berlin.de/~jensen/software/gfan/gfan.html"
SRC_URI="http://www.math.tu-berlin.de/~jensen/software/gfan/${PN}${PV}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ~arm x86 ~amd64-linux ~x86-linux"
-IUSE=""
-DEPEND="dev-libs/gmp[cxx]
- sci-libs/cddlib"
+DEPEND="
+ dev-libs/gmp:0=[cxx]
+ sci-libs/cddlib:0="
RDEPEND="${DEPEND}"
S="${WORKDIR}/${PN}${PV}/"
PATCHES=(
- "${FILESDIR}/${P}-double-declare-fix.patch"
- "${FILESDIR}/${P}-gcc6.1-compat.patch"
- )
-
-src_prepare () {
- default
- sed -i -e "s/-O2/${CXXFLAGS}/" \
- -e "/GPROFFLAG =/d" \
- -e "s/g++/$(tc-getCXX)/" \
- -e "s/\$(CCLINKER)/& \$(LDFLAGS)/" Makefile || die
+ "${FILESDIR}"/${P}-double-declare-fix.patch
+ "${FILESDIR}"/${P}-gcc6.1-compat.patch
+ "${FILESDIR}"/${P}-fix-build-system.patch
+)
+
+src_configure() {
+ tc-export CXX
}
src_install() {
emake PREFIX="${ED}/usr" install
+ einstalldocs
}