summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2021-04-29 21:15:59 +0700
committerAndrey Grozin <grozin@gentoo.org>2021-04-29 21:15:59 +0700
commitad56d1fa2528b5842754ca207a28dd7105f321a3 (patch)
treefa8d8dbd35252d43ca712cf3abae23c2e46fb7ab /sci-mathematics/ginac
parentnet-misc/electrum: Enable py3.9 (diff)
downloadgentoo-ad56d1fa2528b5842754ca207a28dd7105f321a3.tar.gz
gentoo-ad56d1fa2528b5842754ca207a28dd7105f321a3.tar.bz2
gentoo-ad56d1fa2528b5842754ca207a28dd7105f321a3.zip
sci-mathematics/ginac: bump to 1.8.0
Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Andrey Grozin <grozin@gentoo.org>
Diffstat (limited to 'sci-mathematics/ginac')
-rw-r--r--sci-mathematics/ginac/Manifest1
-rw-r--r--sci-mathematics/ginac/ginac-1.8.0.ebuild75
2 files changed, 76 insertions, 0 deletions
diff --git a/sci-mathematics/ginac/Manifest b/sci-mathematics/ginac/Manifest
index a825a00b9fd1..978bbaec0563 100644
--- a/sci-mathematics/ginac/Manifest
+++ b/sci-mathematics/ginac/Manifest
@@ -1 +1,2 @@
DIST ginac-1.7.11.tar.bz2 1077491 BLAKE2B 741e9c8adfec15c225c3656b935707f86292b98310b50533269b238d1a9746bf54d186074c879fdbdd23f915dde225d9ee34fdbd87977835e8f9e78af364d77d SHA512 35a029915c946fcc10ba7b78df6fe1ece9a9f2f6bc172816a923c35f5b495154ab356526b904ac2a16a1bd6b0a81c480c5abb39ef40238ca7b32d1acbf97276c
+DIST ginac-1.8.0.tar.bz2 1124136 BLAKE2B 087c286f621ca5502c54c1765d948f0549a60668fd610bd16ea627af2f4056b13331097768771a0ac14807212de59b132608dc615bf2618dd487a9478dbf5a83 SHA512 6cacd0d87ffae24118f2fbaed4d201ee2d3812a751becef1982308e91cf489543db14443439da9333f3620dc5c8b1c32587e1aff0bed69e6e334310dc64edf49
diff --git a/sci-mathematics/ginac/ginac-1.8.0.ebuild b/sci-mathematics/ginac/ginac-1.8.0.ebuild
new file mode 100644
index 000000000000..8c06689bf026
--- /dev/null
+++ b/sci-mathematics/ginac/ginac-1.8.0.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit python-any-r1
+
+DESCRIPTION="C++ library and tools for symbolic calculations"
+SRC_URI="http://www.ginac.de/${P}.tar.bz2"
+HOMEPAGE="https://www.ginac.de/"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc examples"
+
+RDEPEND=">=sci-libs/cln-1.2.2"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ ${PYTHON_DEPS}
+ virtual/pkgconfig
+ doc? (
+ app-doc/doxygen
+ dev-texlive/texlive-fontsrecommended
+ media-gfx/transfig
+ virtual/texi2dvi
+ )"
+
+PATCHES=( "${FILESDIR}"/${PN}-1.5.1-pkgconfig.patch )
+
+src_configure() {
+ econf \
+ --disable-rpath \
+ --disable-static
+}
+
+src_compile() {
+ emake
+
+ if use doc; then
+ local -x VARTEXFONTS="${T}"/fonts
+ emake -C doc/reference html pdf
+ emake -C doc/tutorial ginac.pdf ginac.html
+ fi
+}
+
+src_install() {
+ default
+
+ if use doc; then
+ pushd doc >/dev/null || die
+ newdoc tutorial/ginac.pdf tutorial.pdf
+ newdoc reference/reference.pdf reference.pdf
+
+ docinto html/reference
+ dodoc -r reference/html_files/.
+
+ docinto html
+ newdoc tutorial/ginac.html tutorial.html
+ popd >/dev/null || die
+ fi
+
+ if use examples; then
+ pushd doc >/dev/null || die
+ docinto examples
+ dodoc examples/*.cpp examples/ginac-examples.*
+ docompress -x /usr/share/doc/${PF}/examples
+ popd >/dev/null || die
+ fi
+
+ # no static archives
+ find "${ED}" -name '*.la' -delete || die
+}