summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2021-06-14 20:22:50 -0400
committerMichael Orlitzky <mjo@gentoo.org>2021-06-14 20:40:54 -0400
commit8c7da7cc0a7a42cc82475a54a18b80c574ee8cc8 (patch)
treed7c71b47cc54db3748e198156be8d75d845467ce /sci-mathematics/gmp-ecm
parentsci-mathematics/gmp-ecm: fix executable stack for good (diff)
downloadgentoo-8c7da7cc0a7a42cc82475a54a18b80c574ee8cc8.tar.gz
gentoo-8c7da7cc0a7a42cc82475a54a18b80c574ee8cc8.tar.bz2
gentoo-8c7da7cc0a7a42cc82475a54a18b80c574ee8cc8.zip
sci-mathematics/gmp-ecm: remove old "unused" gmp-ecm-7.0.4-r3.ebuild.
Closes: https://bugs.gentoo.org/795819 Closes: https://github.com/gentoo/gentoo/pull/21244 Package-Manager: Portage-3.0.18, Repoman-3.0.2 Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'sci-mathematics/gmp-ecm')
-rw-r--r--sci-mathematics/gmp-ecm/gmp-ecm-7.0.4-r3.ebuild57
1 files changed, 0 insertions, 57 deletions
diff --git a/sci-mathematics/gmp-ecm/gmp-ecm-7.0.4-r3.ebuild b/sci-mathematics/gmp-ecm/gmp-ecm-7.0.4-r3.ebuild
deleted file mode 100644
index f36a15f13d2c..000000000000
--- a/sci-mathematics/gmp-ecm/gmp-ecm-7.0.4-r3.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit flag-o-matic toolchain-funcs
-
-MY_PN="ecm"
-MY_P="${MY_PN}-${PV}"
-DESCRIPTION="Elliptic Curve Method for Integer Factorization"
-HOMEPAGE="https://gitlab.inria.fr/zimmerma/ecm"
-SRC_URI="https://gitlab.inria.fr/zimmerma/ecm/uploads/9cd422ec80268f8a885e499e17f98056/${MY_P}.tar.gz"
-
-LICENSE="GPL-3 LGPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~ppc-macos ~x64-macos"
-IUSE="+custom-tune openmp static-libs cpu_flags_x86_sse2"
-
-DEPEND="dev-libs/gmp:="
-RDEPEND="${DEPEND}"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-7.0.4-openmp.patch
-)
-
-S="${WORKDIR}/${MY_P}"
-
-pkg_pretend() {
- use openmp && tc-check-openmp
-}
-
-src_compile() {
- default
- if use custom-tune; then
- # One "emake" was needed to build the library. Now we can find
- # the best set of parameters, and then run "emake" one more time
- # to rebuild the library with the custom parameters. See the
- # project's README or INSTALL-ecm. The build targets don't depend
- # on ecm-params.h, so we need to "make clean" to force a rebuild.
- emake ecm-params && emake clean && emake
- fi
-}
-src_configure() {
- econf \
- --enable-shared \
- $(use_enable static-libs static) \
- $(use_enable openmp) \
- $(use_enable cpu_flags_x86_sse2 sse2) \
- $(use_enable custom-tune asm-redc)
-}
-
-src_install() {
- default
-
- # remove .la file
- find "${ED}" -name '*.la' -delete || die
-}