summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-mathematics/gsl-shell/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-mathematics/gsl-shell/files')
-rw-r--r--sci-mathematics/gsl-shell/files/gsl-shell-2.2.0-pkg-config.patch33
-rw-r--r--sci-mathematics/gsl-shell/files/gsl-shell-font.patch10
-rw-r--r--sci-mathematics/gsl-shell/files/gsl-shell-nogui.patch25
-rw-r--r--sci-mathematics/gsl-shell/files/gsl-shell-strip.patch8
-rw-r--r--sci-mathematics/gsl-shell/files/gsl-shell-usr.patch8
5 files changed, 84 insertions, 0 deletions
diff --git a/sci-mathematics/gsl-shell/files/gsl-shell-2.2.0-pkg-config.patch b/sci-mathematics/gsl-shell/files/gsl-shell-2.2.0-pkg-config.patch
new file mode 100644
index 000000000000..8bb28635df2b
--- /dev/null
+++ b/sci-mathematics/gsl-shell/files/gsl-shell-2.2.0-pkg-config.patch
@@ -0,0 +1,33 @@
+ makepackages | 16 ++++++++--------
+ 1 file changed, 8 insertions(+), 8 deletions(-)
+
+diff --git a/makepackages b/makepackages
+index afeef79..a724e82 100644
+--- a/makepackages
++++ b/makepackages
+@@ -52,17 +52,17 @@ else
+ PTHREADS_LIBS = -lpthread
+
+ else
+- AGG_INCLUDES = -I/usr/include/agg2
+- AGG_LIBS = -lagg -lX11
++ AGG_INCLUDES = $(shell $(PKG_CONFIG) --cflags libagg)
++ AGG_LIBS = $(shell $(PKG_CONFIG) --libs libagg) -lX11
+
+- GSL_INCLUDES =
+- GSL_LIBS = -lgsl -lblas
++ GSL_INCLUDES = $(shell $(PKG_CONFIG) --cflags gsl)
++ GSL_LIBS = $(shell $(PKG_CONFIG) --libs gsl)
+
+- FOX_INCLUDES := $(shell pkg-config fox --cflags)
+- FOX_LIBS = $(shell pkg-config fox --libs)
++ FOX_INCLUDES := $(shell $(PKG_CONFIG) fox --cflags)
++ FOX_LIBS = $(shell $(PKG_CONFIG) fox --libs)
+
+- FREETYPE_INCLUDES = -I/usr/include/freetype2
+- FREETYPE_LIBS = -lfreetype
++ FREETYPE_INCLUDES = $(shell $(PKG_CONFIG) --cflags freetype2)
++ FREETYPE_LIBS = $(shell $(PKG_CONFIG) --libs freetype2)
+
+ PTHREADS_LIBS = -lpthread
+ endif
diff --git a/sci-mathematics/gsl-shell/files/gsl-shell-font.patch b/sci-mathematics/gsl-shell/files/gsl-shell-font.patch
new file mode 100644
index 000000000000..d8879497c4cd
--- /dev/null
+++ b/sci-mathematics/gsl-shell/files/gsl-shell-font.patch
@@ -0,0 +1,10 @@
+diff -r -U1 gsl-shell.orig/agg-plot/support_x11.cpp gsl-shell/agg-plot/support_x11.cpp
+--- gsl-shell.orig/agg-plot/support_x11.cpp 2012-11-27 04:55:38.000000000 +0700
++++ gsl-shell/agg-plot/support_x11.cpp 2012-11-30 23:02:31.000000000 +0700
+@@ -9,4 +9,4 @@
+ #else
+-const char *ttf_names[] = {"ubuntu-font-family/Ubuntu-R.ttf", "freefont/FreeSans.ttf", "ttf-dejavu/DejaVuSans.ttf", 0};
+-#define TTF_SYSTEM_DIR "/usr/share/fonts/truetype/"
++const char *ttf_names[] = {"ubuntu-font-family/Ubuntu-R.ttf", "freefont-ttf/FreeSans.ttf", "dejavu/DejaVuSans.ttf", 0};
++#define TTF_SYSTEM_DIR "/usr/share/fonts/"
+ #define CONSOLE_FONT_NAME "monospace"
diff --git a/sci-mathematics/gsl-shell/files/gsl-shell-nogui.patch b/sci-mathematics/gsl-shell/files/gsl-shell-nogui.patch
new file mode 100644
index 000000000000..16d3eb0f04d2
--- /dev/null
+++ b/sci-mathematics/gsl-shell/files/gsl-shell-nogui.patch
@@ -0,0 +1,25 @@
+diff -r -U1 gsl-shell.orig/Makefile gsl-shell/Makefile
+--- gsl-shell.orig/Makefile 2012-09-21 19:54:05.000000000 +0700
++++ gsl-shell/Makefile 2012-09-21 19:53:37.000000000 +0700
+@@ -29,3 +29,2 @@
+ GSL_SHELL = gsl-shell$(EXE_EXT)
+-GSL_SHELL_GUI = gsl-shell-gui$(EXE_EXT)
+ LUA_CFLAGS = -I$(LUADIR)/src
+@@ -73,4 +72,3 @@
+ INCLUDES += $(PTHREADS_CFLAGS) -Iagg-plot
+-GUI_SUBDIR = fox-gui
+-SUBDIRS += agg-plot $(GUI_SUBDIR)
++SUBDIRS += agg-plot
+ LUAGSL_LIBS += agg-plot/libaggplot.a
+@@ -105,6 +103,5 @@
+
+-install: $(GSL_SHELL) $(GUI_SUBDIR)
++install: $(GSL_SHELL)
+ mkdir -p $(INSTALL_BIN_DIR)
+ cp $(GSL_SHELL) $(INSTALL_BIN_DIR)
+- cp fox-gui/$(GSL_SHELL_GUI) $(INSTALL_BIN_DIR)
+ mkdir -p $(INSTALL_LIB_DIR)
+@@ -122,3 +119,2 @@
+ $(MAKE) -C $(LUADIR) clean
+- $(MAKE) -C fox-gui clean
+ $(HOST_RM) *.o $(TARGETS)
diff --git a/sci-mathematics/gsl-shell/files/gsl-shell-strip.patch b/sci-mathematics/gsl-shell/files/gsl-shell-strip.patch
new file mode 100644
index 000000000000..1d50a7e831af
--- /dev/null
+++ b/sci-mathematics/gsl-shell/files/gsl-shell-strip.patch
@@ -0,0 +1,8 @@
+diff -r -U1 gsl-shell.orig/Makefile gsl-shell/Makefile
+--- gsl-shell.orig/Makefile 2012-09-12 01:13:31.000000000 +0700
++++ gsl-shell/Makefile 2012-09-26 16:13:56.000000000 +0700
+@@ -109,4 +109,2 @@
+ cp fox-gui/$(GSL_SHELL_GUI) $(INSTALL_BIN_DIR)
+- strip $(INSTALL_BIN_DIR)/$(GSL_SHELL)
+- strip $(INSTALL_BIN_DIR)/$(GSL_SHELL_GUI)
+ mkdir -p $(INSTALL_LIB_DIR)
diff --git a/sci-mathematics/gsl-shell/files/gsl-shell-usr.patch b/sci-mathematics/gsl-shell/files/gsl-shell-usr.patch
new file mode 100644
index 000000000000..20ca6d317c7a
--- /dev/null
+++ b/sci-mathematics/gsl-shell/files/gsl-shell-usr.patch
@@ -0,0 +1,8 @@
+diff -r -U1 gsl-shell.orig/makeconfig gsl-shell/makeconfig
+--- gsl-shell.orig/makeconfig 2012-09-12 01:13:31.000000000 +0700
++++ gsl-shell/makeconfig 2012-09-26 16:16:43.000000000 +0700
+@@ -21,3 +21,3 @@
+
+-PREFIX= /usr/local
++PREFIX= /usr
+ DESTDIR=