summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2016-09-10 13:36:28 +0200
committerDavid Seifert <soap@gentoo.org>2016-09-11 10:48:00 +0200
commitd6473d63d7750c68812a1f5f8da79e4548b752bb (patch)
tree972e189a0d8f4d7711433b0fb7844a52c8026fd7 /sci-mathematics/octave
parentdev-python/Numdifftools: Version bump to 0.9.17, switch back to PyPI (diff)
downloadgentoo-d6473d63d7750c68812a1f5f8da79e4548b752bb.tar.gz
gentoo-d6473d63d7750c68812a1f5f8da79e4548b752bb.tar.bz2
gentoo-d6473d63d7750c68812a1f5f8da79e4548b752bb.zip
sci-mathematics/octave: Remove USE=jit
Gentoo-Bug: 588098 * USE=jit has become a liability instead of a feature for Gentoo. The JIT support within octave requires old versions of LLVM, which are broken and unsupported. Package-Manager: portage-2.3.0 Closes: https://github.com/gentoo/gentoo/pull/2288 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sci-mathematics/octave')
-rw-r--r--sci-mathematics/octave/files/octave-4.0.0-llvm-3.5-gnulib-hg.patch19
-rw-r--r--sci-mathematics/octave/files/octave-4.0.0-llvm-3.5.patch130
-rw-r--r--sci-mathematics/octave/metadata.xml1
-rw-r--r--sci-mathematics/octave/octave-4.0.0-r1.ebuild13
-rw-r--r--sci-mathematics/octave/octave-4.0.0.ebuild13
-rw-r--r--sci-mathematics/octave/octave-4.0.1-r1.ebuild13
-rw-r--r--sci-mathematics/octave/octave-4.0.1.ebuild13
-rw-r--r--sci-mathematics/octave/octave-4.0.2-r2.ebuild13
-rw-r--r--sci-mathematics/octave/octave-4.0.3.ebuild13
9 files changed, 12 insertions, 216 deletions
diff --git a/sci-mathematics/octave/files/octave-4.0.0-llvm-3.5-gnulib-hg.patch b/sci-mathematics/octave/files/octave-4.0.0-llvm-3.5-gnulib-hg.patch
deleted file mode 100644
index e74d123b641..00000000000
--- a/sci-mathematics/octave/files/octave-4.0.0-llvm-3.5-gnulib-hg.patch
+++ /dev/null
@@ -1,19 +0,0 @@
-diff -r 7f19e7f2afa2 lib/stddef.in.h
---- a/libgnu/stddef.in.h Sat Feb 21 06:19:32 2015 -0800
-+++ b/libgnu/stddef.in.h Fri May 01 06:01:06 2015 +0200
-@@ -82,6 +82,7 @@
- #endif
-
- /* Some platforms lack max_align_t. */
-+#ifndef _GCC_MAX_ALIGN_T
- #if !@HAVE_MAX_ALIGN_T@
- typedef union
- {
-@@ -91,6 +92,7 @@
- long int __i;
- } max_align_t;
- #endif
-+#endif
-
- # endif /* _@GUARD_PREFIX@_STDDEF_H */
- # endif /* _@GUARD_PREFIX@_STDDEF_H */
diff --git a/sci-mathematics/octave/files/octave-4.0.0-llvm-3.5.patch b/sci-mathematics/octave/files/octave-4.0.0-llvm-3.5.patch
deleted file mode 100644
index 31b1bed74e2..00000000000
--- a/sci-mathematics/octave/files/octave-4.0.0-llvm-3.5.patch
+++ /dev/null
@@ -1,130 +0,0 @@
-diff -r 3797df921988 configure.ac
---- a/configure.ac Wed Apr 29 17:09:24 2015 -0700
-+++ b/configure.ac Sun May 03 22:48:56 2015 +0200
-@@ -815,8 +815,13 @@
- AC_MSG_NOTICE([using -isystem for LLVM headers])])
-
- dnl Use -isystem so we don't get warnings from llvm headers
-- LLVM_CPPFLAGS="$LLVM_INCLUDE_FLAG `$LLVM_CONFIG --includedir`"
-- LLVM_CXXFLAGS=
-+ AX_CHECK_COMPILE_FLAG([-std=c++11],[
-+ LLVM_CPPFLAGS="-std=c++11 $LLVM_INCLUDE_FLAG `$LLVM_CONFIG --includedir`"
-+ LLVM_CXXFLAGS="-std=c++11"
-+ ],[
-+ LLVM_CPPFLAGS="$LLVM_INCLUDE_FLAG `$LLVM_CONFIG --includedir`"
-+ LLVM_CXXFLAGS=
-+ ])
- LLVM_LDFLAGS="-L`$LLVM_CONFIG --libdir`"
-
-
-@@ -860,6 +865,8 @@
- OCTAVE_LLVM_CALLINST_ADDATTRIBUTE_API
- OCTAVE_LLVM_RAW_FD_OSTREAM_API
- OCTAVE_LLVM_LEGACY_PASSMANAGER_API
-+ OCTAVE_LLVM_DATALAYOUTPASS_API
-+
- AC_LANG_POP(C++)
- CPPFLAGS="$save_CPPFLAGS"
- CXXFLAGS="$save_CXXFLAGS"
-diff -r 3797df921988 libinterp/corefcn/jit-typeinfo.cc
---- a/libinterp/corefcn/jit-typeinfo.cc Wed Apr 29 17:09:24 2015 -0700
-+++ b/libinterp/corefcn/jit-typeinfo.cc Sun May 03 22:48:56 2015 +0200
-@@ -1208,7 +1208,7 @@
- for (int op = 0; op < octave_value::num_binary_ops; ++op)
- {
- llvm::Twine fn_name ("octave_jit_binary_any_any_");
-- fn_name = fn_name + llvm::Twine (op);
-+ fn_name.concat( llvm::Twine (op) );
-
- fn = create_internal (fn_name, any, any, any);
- fn.mark_can_error ();
-diff -r 3797df921988 libinterp/corefcn/pt-jit.cc
---- a/libinterp/corefcn/pt-jit.cc Wed Apr 29 17:09:24 2015 -0700
-+++ b/libinterp/corefcn/pt-jit.cc Sun May 03 22:48:56 2015 +0200
-@@ -59,6 +59,7 @@
-
- #include <llvm/Bitcode/ReaderWriter.h>
- #include <llvm/ExecutionEngine/ExecutionEngine.h>
-+#include <llvm/ExecutionEngine/MCJIT.h>
- #include <llvm/ExecutionEngine/JIT.h>
-
- #ifdef LEGACY_PASSMANAGER
-@@ -83,6 +84,7 @@
- #include <llvm/IRBuilder.h>
- #endif
-
-+#include <llvm/Support/FileSystem.h>
- #include <llvm/Support/raw_os_ostream.h>
- #include <llvm/Support/TargetSelect.h>
-
-@@ -2077,7 +2079,11 @@
- module_pass_manager->add (llvm::createAlwaysInlinerPass ());
-
- #ifdef HAVE_LLVM_DATALAYOUT
-+#ifdef HAVE_LLVM_DATALAYOUTPASS
-+ pass_manager->add (new llvm::DataLayoutPass (*engine->getDataLayout ()));
-+#else
- pass_manager->add (new llvm::DataLayout (*engine->getDataLayout ()));
-+#endif
- #else
- pass_manager->add (new llvm::TargetData (*engine->getTargetData ()));
- #endif
-@@ -2192,7 +2198,7 @@
- std::string error;
- #ifdef RAW_FD_OSTREAM_ARG_IS_LLVM_SYS_FS
- llvm::raw_fd_ostream fout ("test.bc", error,
-- llvm::sys::fs::F_Binary);
-+ llvm::sys::fs::F_Text);
- #else
- llvm::raw_fd_ostream fout ("test.bc", error,
- llvm::raw_fd_ostream::F_Binary);
-diff -r 3797df921988 m4/acinclude.m4
---- a/m4/acinclude.m4 Wed Apr 29 17:09:24 2015 -0700
-+++ b/m4/acinclude.m4 Sun May 03 22:48:56 2015 +0200
-@@ -1784,10 +1784,11 @@
- [AC_LANG_PUSH(C++)
- AC_COMPILE_IFELSE(
- [AC_LANG_PROGRAM([[
-+ #include <llvm/Support/FileSystem.h>
- #include <llvm/Support/raw_os_ostream.h>
- ]], [[
- std::string str;
-- llvm::raw_fd_ostream fout ("", str, llvm::sys::fs::F_Binary);
-+ llvm::raw_fd_ostream fout ("", str, llvm::sys::fs::F_Text);
- ]])],
- octave_cv_raw_fd_ostream_arg_is_llvm_sys_fs=yes,
- octave_cv_raw_fd_ostream_arg_is_llvm_sys_fs=no)
-@@ -1828,6 +1829,33 @@
- fi
- ])
- dnl
-+dnl Check for llvm::DataLayoutPass API
-+dnl
-+AC_DEFUN([OCTAVE_LLVM_DATALAYOUTPASS_API], [
-+ AC_CACHE_CHECK([check for LLVM::DataLayoutPass],
-+ [octave_cv_datalayoutpass],
-+ [AC_LANG_PUSH(C++)
-+ save_LIBS="$LIBS"
-+ LIBS="$LLVM_LIBS $LIBS"
-+ AC_LINK_IFELSE(
-+ [AC_LANG_PROGRAM([[
-+ #include <llvm/IR/DataLayout.h>
-+ ]], [[
-+ llvm::Module *module;
-+ llvm::DataLayoutPass *datalayoutpass;
-+ datalayoutpass = new llvm::DataLayoutPass (module)
-+ ]])],
-+ octave_cv_datalayoutpass=yes,
-+ octave_cv_datalayoutpass=no)
-+ LIBS="$save_LIBS"
-+ AC_LANG_POP(C++)
-+ ])
-+ if test $octave_cv_datalayoutpass = yes; then
-+ AC_DEFINE(HAVE_LLVM_DATALAYOUTPASS, 1,
-+ [Define to 1 if LLVM::DataLayoutPass exists.])
-+ fi
-+])
-+dnl
- dnl Check for ar.
- dnl
- AC_DEFUN([OCTAVE_PROG_AR], [
diff --git a/sci-mathematics/octave/metadata.xml b/sci-mathematics/octave/metadata.xml
index a3ecac6b94b..885c63396ee 100644
--- a/sci-mathematics/octave/metadata.xml
+++ b/sci-mathematics/octave/metadata.xml
@@ -16,7 +16,6 @@
<flag name="glpk">Add support for <pkg>sci-mathematics/glpk</pkg> for linear programming</flag>
<flag name="graphicsmagick">Add support for <pkg>media-gfx/graphicsmagick</pkg></flag>
<flag name="gui">Enable the graphical user interface</flag>
- <flag name="jit">(EXPERIMENTAL) enable JIT compiler</flag>
<flag name="qhull">Add support for <pkg>media-libs/qhull</pkg>, to allow `delaunay', `convhull', and related functions</flag>
<flag name="qrupdate">Add support for <pkg>sci-libs/qrupdate</pkg>for QR and Cholesky update functions</flag>
<flag name="sparse">Add enhanced support for sparse matrix algebra with SuiteSparse</flag>
diff --git a/sci-mathematics/octave/octave-4.0.0-r1.ebuild b/sci-mathematics/octave/octave-4.0.0-r1.ebuild
index 4aa4db278af..52f52e87249 100644
--- a/sci-mathematics/octave/octave-4.0.0-r1.ebuild
+++ b/sci-mathematics/octave/octave-4.0.0-r1.ebuild
@@ -15,7 +15,7 @@ HOMEPAGE="http://www.octave.org/"
SRC_URI="mirror://gnu/${PN}/${P}.tar.xz"
SLOT="0/${PV}"
-IUSE="curl doc fftw +glpk gnuplot graphicsmagick gui hdf5 +imagemagick java jit opengl
+IUSE="curl doc fftw +glpk gnuplot graphicsmagick gui hdf5 +imagemagick java opengl
postscript +qhull +qrupdate readline +sparse static-libs X zlib"
REQUIRED_USE="?? ( graphicsmagick imagemagick )"
KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
@@ -35,9 +35,6 @@ RDEPEND="
graphicsmagick? ( media-gfx/graphicsmagick:=[cxx] )
imagemagick? ( media-gfx/imagemagick:=[cxx] )
java? ( >=virtual/jre-1.6.0:* )
- jit? (
- >=sys-devel/autoconf-archive-2015.02.04
- >=sys-devel/llvm-3.3:0= <sys-devel/llvm-3.6:0= )
opengl? (
media-libs/freetype:2=
media-libs/fontconfig:1.0=
@@ -89,12 +86,6 @@ src_prepare() {
use gui && append-ldflags -Wl,-rpath,"${EPREFIX}/usr/$(get_libdir)/qt4"
fi
- # Octave fails to build with LLVM 3.5 https://savannah.gnu.org/bugs/?41061
- use jit && \
- has_version ">=sys-devel/llvm-3.5" && \
- epatch "${FILESDIR}"/${PN}-4.0.0-llvm-3.5.patch && \
- epatch "${FILESDIR}"/${PN}-4.0.0-llvm-3.5-gnulib-hg.patch
-
# Fix bug 501756
sed -i \
-e 's@A-Za-z0-9@[:alnum:]@g' \
@@ -121,10 +112,10 @@ src_configure() {
--with-blas="$($(tc-getPKG_CONFIG) --libs blas)"
--with-lapack="$($(tc-getPKG_CONFIG) --libs lapack)"
--disable-64
+ --disable-jit
$(use_enable doc docs)
$(use_enable java)
$(use_enable gui)
- $(use_enable jit)
$(use_enable readline)
$(use_with curl)
$(use_with fftw fftw3)
diff --git a/sci-mathematics/octave/octave-4.0.0.ebuild b/sci-mathematics/octave/octave-4.0.0.ebuild
index a90d8000ce2..d84666836f3 100644
--- a/sci-mathematics/octave/octave-4.0.0.ebuild
+++ b/sci-mathematics/octave/octave-4.0.0.ebuild
@@ -15,7 +15,7 @@ HOMEPAGE="http://www.octave.org/"
SRC_URI="mirror://gnu/${PN}/${P}.tar.xz"
SLOT="0/${PV}"
-IUSE="curl doc fftw +glpk gnuplot graphicsmagick gui hdf5 +imagemagick java jit opengl
+IUSE="curl doc fftw +glpk gnuplot graphicsmagick gui hdf5 +imagemagick java opengl
postscript +qhull +qrupdate readline +sparse static-libs X zlib"
REQUIRED_USE="?? ( graphicsmagick imagemagick )"
KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
@@ -35,9 +35,6 @@ RDEPEND="
graphicsmagick? ( media-gfx/graphicsmagick:=[cxx] )
imagemagick? ( media-gfx/imagemagick:=[cxx] )
java? ( >=virtual/jre-1.6.0:* )
- jit? (
- >=sys-devel/autoconf-archive-2015.02.04
- >=sys-devel/llvm-3.3:0= <sys-devel/llvm-3.6:0= )
opengl? (
media-libs/freetype:2=
media-libs/fontconfig:1.0=
@@ -89,12 +86,6 @@ src_prepare() {
use gui && append-ldflags -Wl,-rpath,"${EPREFIX}/usr/$(get_libdir)/qt4"
fi
- # Octave fails to build with LLVM 3.5 https://savannah.gnu.org/bugs/?41061
- use jit && \
- has_version ">=sys-devel/llvm-3.5" && \
- epatch "${FILESDIR}"/${PN}-4.0.0-llvm-3.5.patch && \
- epatch "${FILESDIR}"/${PN}-4.0.0-llvm-3.5-gnulib-hg.patch
-
# Fix bug 501756
sed -i \
-e 's@A-Za-z0-9@[:alnum:]@g' \
@@ -116,10 +107,10 @@ src_configure() {
--with-blas="$($(tc-getPKG_CONFIG) --libs blas)"
--with-lapack="$($(tc-getPKG_CONFIG) --libs lapack)"
--disable-64
+ --disable-jit
$(use_enable doc docs)
$(use_enable java)
$(use_enable gui)
- $(use_enable jit)
$(use_enable readline)
$(use_with curl)
$(use_with fftw fftw3)
diff --git a/sci-mathematics/octave/octave-4.0.1-r1.ebuild b/sci-mathematics/octave/octave-4.0.1-r1.ebuild
index 279abf2fb37..666ac67e20b 100644
--- a/sci-mathematics/octave/octave-4.0.1-r1.ebuild
+++ b/sci-mathematics/octave/octave-4.0.1-r1.ebuild
@@ -15,7 +15,7 @@ HOMEPAGE="http://www.octave.org/"
SRC_URI="mirror://gnu/${PN}/${P}.tar.xz"
SLOT="0/${PV}"
-IUSE="curl doc fftw +glpk gnuplot graphicsmagick gui hdf5 +imagemagick java jit opengl
+IUSE="curl doc fftw +glpk gnuplot graphicsmagick gui hdf5 +imagemagick java opengl
postscript +qhull +qrupdate readline +sparse static-libs X zlib"
REQUIRED_USE="?? ( graphicsmagick imagemagick )"
KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
@@ -35,9 +35,6 @@ RDEPEND="
graphicsmagick? ( media-gfx/graphicsmagick:=[cxx] )
imagemagick? ( media-gfx/imagemagick:=[cxx] )
java? ( >=virtual/jre-1.6.0:* )
- jit? (
- >=sys-devel/autoconf-archive-2015.02.04
- >=sys-devel/llvm-3.3:0= <sys-devel/llvm-3.6:0= )
opengl? (
media-libs/freetype:2=
media-libs/fontconfig:1.0=
@@ -89,12 +86,6 @@ src_prepare() {
use gui && append-ldflags -Wl,-rpath,"${EPREFIX}/usr/$(get_libdir)/qt4"
fi
- # Octave fails to build with LLVM 3.5 https://savannah.gnu.org/bugs/?41061
- use jit && \
- has_version ">=sys-devel/llvm-3.5" && \
- epatch "${FILESDIR}"/${PN}-4.0.0-llvm-3.5.patch && \
- epatch "${FILESDIR}"/${PN}-4.0.0-llvm-3.5-gnulib-hg.patch
-
# Fix bug 501756
sed -i \
-e 's@A-Za-z0-9@[:alnum:]@g' \
@@ -116,10 +107,10 @@ src_configure() {
--with-blas="$($(tc-getPKG_CONFIG) --libs blas)"
--with-lapack="$($(tc-getPKG_CONFIG) --libs lapack)"
--disable-64
+ --disable-jit
$(use_enable doc docs)
$(use_enable java)
$(use_enable gui)
- $(use_enable jit)
$(use_enable readline)
$(use_with curl)
$(use_with fftw fftw3)
diff --git a/sci-mathematics/octave/octave-4.0.1.ebuild b/sci-mathematics/octave/octave-4.0.1.ebuild
index a90d8000ce2..d84666836f3 100644
--- a/sci-mathematics/octave/octave-4.0.1.ebuild
+++ b/sci-mathematics/octave/octave-4.0.1.ebuild
@@ -15,7 +15,7 @@ HOMEPAGE="http://www.octave.org/"
SRC_URI="mirror://gnu/${PN}/${P}.tar.xz"
SLOT="0/${PV}"
-IUSE="curl doc fftw +glpk gnuplot graphicsmagick gui hdf5 +imagemagick java jit opengl
+IUSE="curl doc fftw +glpk gnuplot graphicsmagick gui hdf5 +imagemagick java opengl
postscript +qhull +qrupdate readline +sparse static-libs X zlib"
REQUIRED_USE="?? ( graphicsmagick imagemagick )"
KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
@@ -35,9 +35,6 @@ RDEPEND="
graphicsmagick? ( media-gfx/graphicsmagick:=[cxx] )
imagemagick? ( media-gfx/imagemagick:=[cxx] )
java? ( >=virtual/jre-1.6.0:* )
- jit? (
- >=sys-devel/autoconf-archive-2015.02.04
- >=sys-devel/llvm-3.3:0= <sys-devel/llvm-3.6:0= )
opengl? (
media-libs/freetype:2=
media-libs/fontconfig:1.0=
@@ -89,12 +86,6 @@ src_prepare() {
use gui && append-ldflags -Wl,-rpath,"${EPREFIX}/usr/$(get_libdir)/qt4"
fi
- # Octave fails to build with LLVM 3.5 https://savannah.gnu.org/bugs/?41061
- use jit && \
- has_version ">=sys-devel/llvm-3.5" && \
- epatch "${FILESDIR}"/${PN}-4.0.0-llvm-3.5.patch && \
- epatch "${FILESDIR}"/${PN}-4.0.0-llvm-3.5-gnulib-hg.patch
-
# Fix bug 501756
sed -i \
-e 's@A-Za-z0-9@[:alnum:]@g' \
@@ -116,10 +107,10 @@ src_configure() {
--with-blas="$($(tc-getPKG_CONFIG) --libs blas)"
--with-lapack="$($(tc-getPKG_CONFIG) --libs lapack)"
--disable-64
+ --disable-jit
$(use_enable doc docs)
$(use_enable java)
$(use_enable gui)
- $(use_enable jit)
$(use_enable readline)
$(use_with curl)
$(use_with fftw fftw3)
diff --git a/sci-mathematics/octave/octave-4.0.2-r2.ebuild b/sci-mathematics/octave/octave-4.0.2-r2.ebuild
index 279abf2fb37..666ac67e20b 100644
--- a/sci-mathematics/octave/octave-4.0.2-r2.ebuild
+++ b/sci-mathematics/octave/octave-4.0.2-r2.ebuild
@@ -15,7 +15,7 @@ HOMEPAGE="http://www.octave.org/"
SRC_URI="mirror://gnu/${PN}/${P}.tar.xz"
SLOT="0/${PV}"
-IUSE="curl doc fftw +glpk gnuplot graphicsmagick gui hdf5 +imagemagick java jit opengl
+IUSE="curl doc fftw +glpk gnuplot graphicsmagick gui hdf5 +imagemagick java opengl
postscript +qhull +qrupdate readline +sparse static-libs X zlib"
REQUIRED_USE="?? ( graphicsmagick imagemagick )"
KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
@@ -35,9 +35,6 @@ RDEPEND="
graphicsmagick? ( media-gfx/graphicsmagick:=[cxx] )
imagemagick? ( media-gfx/imagemagick:=[cxx] )
java? ( >=virtual/jre-1.6.0:* )
- jit? (
- >=sys-devel/autoconf-archive-2015.02.04
- >=sys-devel/llvm-3.3:0= <sys-devel/llvm-3.6:0= )
opengl? (
media-libs/freetype:2=
media-libs/fontconfig:1.0=
@@ -89,12 +86,6 @@ src_prepare() {
use gui && append-ldflags -Wl,-rpath,"${EPREFIX}/usr/$(get_libdir)/qt4"
fi
- # Octave fails to build with LLVM 3.5 https://savannah.gnu.org/bugs/?41061
- use jit && \
- has_version ">=sys-devel/llvm-3.5" && \
- epatch "${FILESDIR}"/${PN}-4.0.0-llvm-3.5.patch && \
- epatch "${FILESDIR}"/${PN}-4.0.0-llvm-3.5-gnulib-hg.patch
-
# Fix bug 501756
sed -i \
-e 's@A-Za-z0-9@[:alnum:]@g' \
@@ -116,10 +107,10 @@ src_configure() {
--with-blas="$($(tc-getPKG_CONFIG) --libs blas)"
--with-lapack="$($(tc-getPKG_CONFIG) --libs lapack)"
--disable-64
+ --disable-jit
$(use_enable doc docs)
$(use_enable java)
$(use_enable gui)
- $(use_enable jit)
$(use_enable readline)
$(use_with curl)
$(use_with fftw fftw3)
diff --git a/sci-mathematics/octave/octave-4.0.3.ebuild b/sci-mathematics/octave/octave-4.0.3.ebuild
index ef685a24492..117d91708c9 100644
--- a/sci-mathematics/octave/octave-4.0.3.ebuild
+++ b/sci-mathematics/octave/octave-4.0.3.ebuild
@@ -12,7 +12,7 @@ HOMEPAGE="http://www.octave.org/"
SRC_URI="mirror://gnu/${PN}/${P}.tar.xz"
SLOT="0/${PV}"
-IUSE="curl doc fftw +glpk gnuplot graphicsmagick gui hdf5 +imagemagick java jit opengl
+IUSE="curl doc fftw +glpk gnuplot graphicsmagick gui hdf5 +imagemagick java opengl
postscript +qhull +qrupdate readline +sparse static-libs X zlib"
REQUIRED_USE="?? ( graphicsmagick imagemagick )"
KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
@@ -32,9 +32,6 @@ RDEPEND="
graphicsmagick? ( media-gfx/graphicsmagick:=[cxx] )
imagemagick? ( media-gfx/imagemagick:=[cxx] )
java? ( >=virtual/jre-1.6.0:* )
- jit? (
- >=sys-devel/autoconf-archive-2015.02.04
- >=sys-devel/llvm-3.3:0= <sys-devel/llvm-3.6:0= )
opengl? (
media-libs/freetype:2=
media-libs/fontconfig:1.0=
@@ -87,12 +84,6 @@ src_prepare() {
use gui && append-ldflags -Wl,-rpath,"${EPREFIX}/usr/$(get_libdir)/qt4"
fi
- # Octave fails to build with LLVM 3.5 https://savannah.gnu.org/bugs/?41061
- use jit && has_version ">=sys-devel/llvm-3.5" && \
- PATCHES+=(
- "${FILESDIR}"/${PN}-4.0.0-llvm-3.5.patch
- )
-
# Fix bug 501756
sed -i \
-e 's@A-Za-z0-9@[:alnum:]@g' \
@@ -125,12 +116,12 @@ src_configure() {
--with-blas="$($(tc-getPKG_CONFIG) --libs blas)" \
--with-lapack="$($(tc-getPKG_CONFIG) --libs lapack)" \
--disable-64 \
+ --disable-jit \
--enable-shared \
$(use_enable static-libs static) \
$(use_enable doc docs) \
$(use_enable java) \
$(use_enable gui) \
- $(use_enable jit) \
$(use_enable readline) \
$(use_with curl) \
$(use_with fftw fftw3) \