summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2015-11-10 20:26:49 -0500
committerMike Frysinger <vapier@gentoo.org>2015-11-10 20:53:23 -0500
commit2347c6fe886c6b89d93ffac0faf375a613c372b1 (patch)
tree9ac1ed0abe7e86cbfe62a110a23675af21655134 /sci-mathematics/sha1-polyml
parentnet-libs/mbedtls: version bump to 2.1.3 (diff)
downloadgentoo-2347c6fe886c6b89d93ffac0faf375a613c372b1.tar.gz
gentoo-2347c6fe886c6b89d93ffac0faf375a613c372b1.tar.bz2
gentoo-2347c6fe886c6b89d93ffac0faf375a613c372b1.zip
avoid using ${var^} and ${var,} as they do not work in bash-3.2
Once these upgrade to EAPI=6, they can use these case modification features, so leave a reminder note in there.
Diffstat (limited to 'sci-mathematics/sha1-polyml')
-rw-r--r--sci-mathematics/sha1-polyml/sha1-polyml-5.5.0.ebuild10
1 files changed, 6 insertions, 4 deletions
diff --git a/sci-mathematics/sha1-polyml/sha1-polyml-5.5.0.ebuild b/sci-mathematics/sha1-polyml/sha1-polyml-5.5.0.ebuild
index b8150e07cd2b..a5d68567de68 100644
--- a/sci-mathematics/sha1-polyml/sha1-polyml-5.5.0.ebuild
+++ b/sci-mathematics/sha1-polyml/sha1-polyml-5.5.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -60,9 +60,11 @@ src_prepare() {
}
src_compile() {
- arch=$(uname -m)
- uos=$(uname)
- los=${uos,,}
+ local arch=$(uname -m)
+ local uos=$(uname)
+ # Switch to ,, when we switch to EAPI=6.
+ #local los=${uos,,}
+ local los=$(tr '[:upper:]' '[:lower:]' <<<"${uos}")
./build "${arch}-${los}" || die "build failed"
}