summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-05-05 02:00:18 +0100
committerSam James <sam@gentoo.org>2022-05-05 02:07:18 +0100
commite6cc2ca6f0e30f587cd5df3ce4e63d4ec2d09e46 (patch)
treeca77bd9bbba442f69107fa31859092e61d02a042 /sci-mathematics
parentsci-mathematics/octave: tidy up 7.1.0 (diff)
downloadgentoo-e6cc2ca6f0e30f587cd5df3ce4e63d4ec2d09e46.tar.gz
gentoo-e6cc2ca6f0e30f587cd5df3ce4e63d4ec2d09e46.tar.bz2
gentoo-e6cc2ca6f0e30f587cd5df3ce4e63d4ec2d09e46.zip
sci-mathematics/octave: add rapidjson USE flag
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/octave/metadata.xml1
-rw-r--r--sci-mathematics/octave/octave-7.1.0.ebuild6
2 files changed, 5 insertions, 2 deletions
diff --git a/sci-mathematics/octave/metadata.xml b/sci-mathematics/octave/metadata.xml
index cfb2c2525f7c..759ec5c83e0f 100644
--- a/sci-mathematics/octave/metadata.xml
+++ b/sci-mathematics/octave/metadata.xml
@@ -10,6 +10,7 @@
</longdescription>
<use>
<flag name="glpk">Add support for <pkg>sci-mathematics/glpk</pkg> for linear programming</flag>
+ <flag name="json">Allow using jsonencode and jsondecode commands via <pkg>dev-libs/rapidjson</pkg></flag>
<flag name="qhull">Add support for <pkg>media-libs/qhull</pkg>, to allow `delaunay', `convhull', and related functions</flag>
<flag name="qrupdate">Add support for <pkg>sci-libs/qrupdate</pkg>for QR and Cholesky update functions</flag>
<flag name="sparse">Add enhanced support for sparse matrix algebra with SuiteSparse</flag>
diff --git a/sci-mathematics/octave/octave-7.1.0.ebuild b/sci-mathematics/octave/octave-7.1.0.ebuild
index 9d333e018ff1..0f6f332a685b 100644
--- a/sci-mathematics/octave/octave-7.1.0.ebuild
+++ b/sci-mathematics/octave/octave-7.1.0.ebuild
@@ -11,7 +11,7 @@ SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
LICENSE="GPL-3"
SLOT="0/${PV}"
-IUSE="curl doc fftw +glpk gnuplot gui hdf5 java opengl
+IUSE="curl doc fftw +glpk gnuplot gui hdf5 java json opengl
portaudio postscript +qhull +qrupdate readline sndfile +sparse
ssl static-libs sundials X zlib"
# Issue when building w/ SSL needs investigation
@@ -50,6 +50,7 @@ RDEPEND="
)
hdf5? ( sci-libs/hdf5:0= )
java? ( >=virtual/jre-1.6.0:* )
+ json? ( dev-libs/rapidjson )
opengl? (
media-libs/freetype:2=
media-libs/fontconfig:1.0=
@@ -151,6 +152,7 @@ src_configure() {
$(use_enable static-libs static) \
$(use_enable doc docs) \
$(use_enable java) \
+ $(use_enable json rapidjson) \
$(use_enable readline) \
$(use_with curl) \
$(use_with fftw fftw3) \
@@ -162,7 +164,7 @@ src_configure() {
$(use_with opengl fltk) \
$(use_with ssl openssl) \
$(use_with portaudio) \
- $(use_with qhull_r) \
+ $(use_with qhull qhull_r) \
$(use_with qrupdate) \
$(use_with gui qt 5) \
$(use_with sndfile) \