summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Huettel <dilfridge@gentoo.org>2017-01-25 17:25:29 +0100
committerAndreas K. Huettel <dilfridge@gentoo.org>2017-01-25 17:25:53 +0100
commitb80a642876f2a912db1fa095fb3bbc18deb8be5e (patch)
tree89cb9ccf7947de862c474cdeed98abe1b92aa02d /sci-misc/cdfplayer
parentnet-misc/tor: version bump alpha to 0.3.0.2, remove older (diff)
downloadgentoo-b80a642876f2a912db1fa095fb3bbc18deb8be5e.tar.gz
gentoo-b80a642876f2a912db1fa095fb3bbc18deb8be5e.tar.bz2
gentoo-b80a642876f2a912db1fa095fb3bbc18deb8be5e.zip
sci-misc/cdfplayer: Version bump
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'sci-misc/cdfplayer')
-rw-r--r--sci-misc/cdfplayer/Manifest1
-rw-r--r--sci-misc/cdfplayer/cdfplayer-11.0.1.ebuild82
2 files changed, 83 insertions, 0 deletions
diff --git a/sci-misc/cdfplayer/Manifest b/sci-misc/cdfplayer/Manifest
index a8c35fb34f7c..0491ae3d6f3a 100644
--- a/sci-misc/cdfplayer/Manifest
+++ b/sci-misc/cdfplayer/Manifest
@@ -1 +1,2 @@
DIST CDFPlayer_10.4.0_LINUX.sh 1315941152 SHA256 4c202541762839c766d6f484377e3413de9dd7c70f47484da615572c8e44f4ed SHA512 13205dad6d3a57937b55f41d895e6eef5c7ebf1f416622226cbe97a7de4a39c8d1b5c7424194c2aa4bca9020b52f52ef311af118d810c6065a1275e58d9580a1 WHIRLPOOL 36236338c6ec922a6294da34e5379ba5ecf087b307a484abd79c516804d1db6f859b33a1535a9dce6f1980a51972ec1ceff3b39a6270b9d9797beedabc03a0f3
+DIST CDFPlayer_11.0.1_LINUX.sh 1630401312 SHA256 0f5f89d252481ea7fb49bd6c6c9b0a38956d4f0c32c361d02a543a8582c472e8 SHA512 bf52caa6a495ce78670ab6931e8caa3167121d5193e6839bb745026883f32c536d460faa960a59e593486fbf1a90d1ca51cb8e8a52eedff20e48eb1cb1a80701 WHIRLPOOL 9946110dffe973043dc4d89fd015ebcadfbd6e747b3993059cc811ce7e8f09df37db80daf9a3701cbd09de2331c3e534a20064876eabc256561aeca9fe4357a3
diff --git a/sci-misc/cdfplayer/cdfplayer-11.0.1.ebuild b/sci-misc/cdfplayer/cdfplayer-11.0.1.ebuild
new file mode 100644
index 000000000000..2887ea405af8
--- /dev/null
+++ b/sci-misc/cdfplayer/cdfplayer-11.0.1.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit versionator
+
+DESCRIPTION="Wolfram Player for the interactive Computable Document Format (CDF)"
+SRC_URI="CDFPlayer_11.0.1_LINUX.sh"
+HOMEPAGE="http://www.wolfram.com/cdf-player/"
+
+LICENSE="WolframCDFPlayer"
+KEYWORDS="-* ~amd64 ~x86"
+SLOT="0"
+IUSE=""
+
+RESTRICT="strip mirror bindist fetch"
+
+DEPEND=""
+
+# this list comes from lsof output
+# probably there are still some libraries missing
+RDEPEND="
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXau
+ x11-libs/libXcursor
+ x11-libs/libXdmcp
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXi
+ x11-libs/libXmu
+ x11-libs/libXrandr
+ x11-libs/libXrender
+ x11-libs/libXt
+ media-libs/alsa-lib
+ dev-libs/expat
+ media-libs/fontconfig
+ dev-libs/icu
+ x11-libs/libxcb
+ dev-libs/libxml2
+ || ( sys-libs/ncurses:5/5 sys-libs/ncurses:0/5 )
+"
+
+# we need this a few times
+MPV=$(get_version_component_range 1-2)
+
+# we might as well list all files in all QA variables...
+QA_PREBUILT="opt/*"
+
+S=${WORKDIR}
+
+src_unpack() {
+ /bin/sh "${DISTDIR}/${A}" --nox11 --confirm --keep -- -auto "-targetdir=${S}/opt/Wolfram/CDFPlayer/${MPV}" "-execdir=${S}/opt/bin" || die
+}
+
+src_install() {
+ # move all over
+ mv "${S}/opt" "${D}/opt" || die
+
+ # the autogenerated symlinks point into sandbox, redo
+ rm "${D}/opt/bin/"* || die
+ dosym /opt/Wolfram/CDFPlayer/${MPV}/Executables/wolframcdfplayer opt/bin/wolframcdfplayer
+ dosym /opt/Wolfram/CDFPlayer/${MPV}/Executables/WolframCDFPlayer opt/bin/WolframCDFPlayer
+
+ # fix some embedded paths and install desktop files
+ insinto /usr/share/applications
+ for filename in $(find "${D}" -name "wolfram-cdf11.desktop") ; do
+ echo Fixing "${filename}"
+ sed -e "s:${S}::g" -e 's:^\t\t::g' -i "${filename}"
+ echo "Categories=Physics;Science;Engineering;2DGraphics;Graphics;" >> "${filename}"
+ doins "${filename}"
+ done
+}
+
+pkg_nofetch() {
+ einfo "Sadly Wolfram provides no permanent link to the player files."
+ einfo "Please download the Wolfram CFD Player installation file ${SRC_URI} from"
+ einfo "${HOMEPAGE} and place it in ${DISTDIR}"
+}