summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-misc/fitsverify
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-misc/fitsverify')
-rw-r--r--sci-misc/fitsverify/Manifest1
-rw-r--r--sci-misc/fitsverify/fitsverify-4.17.ebuild34
-rw-r--r--sci-misc/fitsverify/metadata.xml10
3 files changed, 45 insertions, 0 deletions
diff --git a/sci-misc/fitsverify/Manifest b/sci-misc/fitsverify/Manifest
new file mode 100644
index 000000000000..7d301ae7dc6a
--- /dev/null
+++ b/sci-misc/fitsverify/Manifest
@@ -0,0 +1 @@
+DIST fitsverify-4.17.tar.gz 42634 SHA256 1ffb76e285715477ac3d7de3cc5ce96e74c3cd81f9b3d840327dda39d0598c3b SHA512 0d15b8e4ae5098126bed2bb2dfaa47ac20d977ed707352dc7930ebaf23a7a20cc69458fd77f9e76888e2ec4ef8a2a2f180c2fe03b9b7a4c9299aeea6df831879 WHIRLPOOL f666800c32603027ea07dff975d104b525643e13bc7920bf6056d8ff2f5c0dc1701a4a7d870e5c0a64ca1399f199b3d542ffcbed6a6a280202d193c615305b0f
diff --git a/sci-misc/fitsverify/fitsverify-4.17.ebuild b/sci-misc/fitsverify/fitsverify-4.17.ebuild
new file mode 100644
index 000000000000..5b82bfe0c38e
--- /dev/null
+++ b/sci-misc/fitsverify/fitsverify-4.17.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit toolchain-funcs
+
+DESCRIPTION="FITS file format checker"
+HOMEPAGE="http://heasarc.gsfc.nasa.gov/docs/software/ftools/fitsverify/"
+SRC_URI="${HOMEPAGE}/${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND=">=sci-libs/cfitsio-3:0="
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S="${WORKDIR}/${PN}"
+
+src_compile() {
+ $(tc-getCC) -DSTANDALONE ${CFLAGS} ${LDFLAGS} \
+ $($(tc-getPKG_CONFIG) --cflags cfitsio) \
+ ftverify.c fvrf*.c \
+ $($(tc-getPKG_CONFIG) --libs cfitsio) -o ${PN} \
+ || die "compiled failed"
+}
+
+src_install() {
+ dobin fitsverify
+ dodoc README
+}
diff --git a/sci-misc/fitsverify/metadata.xml b/sci-misc/fitsverify/metadata.xml
new file mode 100644
index 000000000000..0398d6d922a2
--- /dev/null
+++ b/sci-misc/fitsverify/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci</herd>
+<longdescription lang='en'>
+ fitsverify is a computer program that rigorously checks whether a
+ FITS format data file conforms to all the requirements defined in
+ the FITS (Flexible Image Transport System) standard document.
+</longdescription>
+</pkgmetadata>