summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2022-12-26 13:52:14 +0100
committerDavid Seifert <soap@gentoo.org>2022-12-26 13:52:14 +0100
commitf8935fe091b274b52843192ec4aa489fe267ea9d (patch)
tree660b9267043f808c21ada0100ac38775ed021cbb /sci-misc/ncview/ncview-2.1.8.ebuild
parentprofiles/features/wd40: mask more mkdocs-* (diff)
downloadgentoo-f8935fe091b274b52843192ec4aa489fe267ea9d.tar.gz
gentoo-f8935fe091b274b52843192ec4aa489fe267ea9d.tar.bz2
gentoo-f8935fe091b274b52843192ec4aa489fe267ea9d.zip
sci-misc/ncview: add 2.1.8
Bug: https://bugs.gentoo.org/741584 Bug: https://bugs.gentoo.org/828639 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sci-misc/ncview/ncview-2.1.8.ebuild')
-rw-r--r--sci-misc/ncview/ncview-2.1.8.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/sci-misc/ncview/ncview-2.1.8.ebuild b/sci-misc/ncview/ncview-2.1.8.ebuild
new file mode 100644
index 000000000000..f85dbe848aa1
--- /dev/null
+++ b/sci-misc/ncview/ncview-2.1.8.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools desktop
+
+DESCRIPTION="X-based viewer for netCDF files"
+HOMEPAGE="http://meteora.ucsd.edu/~pierce/ncview_home_page.html"
+SRC_URI="ftp://cirrus.ucsd.edu/pub/ncview/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ media-libs/libpng:0=
+ sci-libs/netcdf[hdf5]
+ sci-libs/udunits
+ x11-libs/libXaw
+"
+DEPEND="${RDEPEND}"
+
+PATCHES=( "${FILESDIR}"/${P}-autotools.patch )
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_install() {
+ default
+
+ doman data/ncview.1
+
+ insinto /usr/share/X11/app-defaults
+ newins Ncview-appdefaults Ncview
+
+ insinto /usr/share/ncview
+ doins *.ncmap
+
+ make_desktop_entry ncview
+}