summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Eden <yamakuzure@gmx.net>2017-05-23 16:04:27 +0200
committerMichał Górny <mgorny@gentoo.org>2017-06-04 18:59:01 +0200
commit74027c867f3d93a6355ad0e6878b30fc26176956 (patch)
tree036f413422b428413799ee39203c6027d09689d0 /sci-misc
parentdev-python/scripttest: Tested on pypy{,3} (diff)
downloadgentoo-74027c867f3d93a6355ad0e6878b30fc26176956.tar.gz
gentoo-74027c867f3d93a6355ad0e6878b30fc26176956.tar.bz2
gentoo-74027c867f3d93a6355ad0e6878b30fc26176956.zip
sci-misc/boinc: Support CURL_SSL="gnutls"
Enabling gnutls USE flag on curl broke boinc ability to connect to WorldCommunityGrid (WCG) servers. This situation seems to have changed, as I have no problem connecting to WCG using CURL_SSL="gnutls" any more. Bug: https://bugs.gentoo.org/619032 Package-Manager: portage-2.3.6
Diffstat (limited to 'sci-misc')
-rw-r--r--sci-misc/boinc/boinc-7.2.44-r3.ebuild6
-rw-r--r--sci-misc/boinc/boinc-7.4.52-r3.ebuild6
-rw-r--r--sci-misc/boinc/boinc-7.6.33-r3.ebuild6
3 files changed, 9 insertions, 9 deletions
diff --git a/sci-misc/boinc/boinc-7.2.44-r3.ebuild b/sci-misc/boinc/boinc-7.2.44-r3.ebuild
index 1b17b96b1a8..7a190292049 100644
--- a/sci-misc/boinc/boinc-7.2.44-r3.ebuild
+++ b/sci-misc/boinc/boinc-7.2.44-r3.ebuild
@@ -18,9 +18,9 @@ RESTRICT="mirror"
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
-IUSE="X cuda curl_ssl_libressl +curl_ssl_openssl static-libs"
+IUSE="X cuda curl_ssl_gnutls curl_ssl_libressl +curl_ssl_openssl static-libs"
-REQUIRED_USE="^^ ( curl_ssl_libressl curl_ssl_openssl ) "
+REQUIRED_USE="^^ ( curl_ssl_gnutls curl_ssl_libressl curl_ssl_openssl ) "
# libcurl must not be using an ssl backend boinc does not support.
# If the libcurl ssl backend changes, boinc should be recompiled.
@@ -28,7 +28,7 @@ RDEPEND="
!sci-misc/boinc-bin
!app-admin/quickswitch
>=app-misc/ca-certificates-20080809
- net-misc/curl[-curl_ssl_gnutls(-),curl_ssl_libressl(-)=,-curl_ssl_nss(-),curl_ssl_openssl(-)=,-curl_ssl_axtls(-),-curl_ssl_cyassl(-),-curl_ssl_polarssl(-)]
+ net-misc/curl[curl_ssl_gnutls(-)=,curl_ssl_libressl(-)=,-curl_ssl_nss(-),curl_ssl_openssl(-)=,-curl_ssl_axtls(-),-curl_ssl_cyassl(-),-curl_ssl_polarssl(-)]
sys-apps/util-linux
sys-libs/zlib
cuda? (
diff --git a/sci-misc/boinc/boinc-7.4.52-r3.ebuild b/sci-misc/boinc/boinc-7.4.52-r3.ebuild
index 440eb1d4e12..d33072c9535 100644
--- a/sci-misc/boinc/boinc-7.4.52-r3.ebuild
+++ b/sci-misc/boinc/boinc-7.4.52-r3.ebuild
@@ -18,9 +18,9 @@ RESTRICT="mirror"
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
-IUSE="X cuda curl_ssl_libressl +curl_ssl_openssl static-libs"
+IUSE="X cuda curl_ssl_gnutls curl_ssl_libressl +curl_ssl_openssl static-libs"
-REQUIRED_USE="^^ ( curl_ssl_libressl curl_ssl_openssl ) "
+REQUIRED_USE="^^ ( curl_ssl_gnutls curl_ssl_libressl curl_ssl_openssl ) "
# libcurl must not be using an ssl backend boinc does not support.
# If the libcurl ssl backend changes, boinc should be recompiled.
@@ -28,7 +28,7 @@ RDEPEND="
!sci-misc/boinc-bin
!app-admin/quickswitch
>=app-misc/ca-certificates-20080809
- net-misc/curl[-curl_ssl_gnutls(-),curl_ssl_libressl(-)=,-curl_ssl_nss(-),curl_ssl_openssl(-)=,-curl_ssl_axtls(-),-curl_ssl_cyassl(-),-curl_ssl_polarssl(-)]
+ net-misc/curl[curl_ssl_gnutls(-)=,curl_ssl_libressl(-)=,-curl_ssl_nss(-),curl_ssl_openssl(-)=,-curl_ssl_axtls(-),-curl_ssl_cyassl(-),-curl_ssl_polarssl(-)]
sys-apps/util-linux
sys-libs/zlib
cuda? (
diff --git a/sci-misc/boinc/boinc-7.6.33-r3.ebuild b/sci-misc/boinc/boinc-7.6.33-r3.ebuild
index 440eb1d4e12..d33072c9535 100644
--- a/sci-misc/boinc/boinc-7.6.33-r3.ebuild
+++ b/sci-misc/boinc/boinc-7.6.33-r3.ebuild
@@ -18,9 +18,9 @@ RESTRICT="mirror"
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
-IUSE="X cuda curl_ssl_libressl +curl_ssl_openssl static-libs"
+IUSE="X cuda curl_ssl_gnutls curl_ssl_libressl +curl_ssl_openssl static-libs"
-REQUIRED_USE="^^ ( curl_ssl_libressl curl_ssl_openssl ) "
+REQUIRED_USE="^^ ( curl_ssl_gnutls curl_ssl_libressl curl_ssl_openssl ) "
# libcurl must not be using an ssl backend boinc does not support.
# If the libcurl ssl backend changes, boinc should be recompiled.
@@ -28,7 +28,7 @@ RDEPEND="
!sci-misc/boinc-bin
!app-admin/quickswitch
>=app-misc/ca-certificates-20080809
- net-misc/curl[-curl_ssl_gnutls(-),curl_ssl_libressl(-)=,-curl_ssl_nss(-),curl_ssl_openssl(-)=,-curl_ssl_axtls(-),-curl_ssl_cyassl(-),-curl_ssl_polarssl(-)]
+ net-misc/curl[curl_ssl_gnutls(-)=,curl_ssl_libressl(-)=,-curl_ssl_nss(-),curl_ssl_openssl(-)=,-curl_ssl_axtls(-),-curl_ssl_cyassl(-),-curl_ssl_polarssl(-)]
sys-apps/util-linux
sys-libs/zlib
cuda? (