summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Eden <yamakuzure@gmx.net>2017-12-24 15:24:24 +0100
committerMart Raudsepp <leio@gentoo.org>2017-12-27 13:55:54 +0200
commite5f2f2be84c3b6a791f53864d397372d41308430 (patch)
tree1a45c697dc65fbd12e3ca780b1eb5bb58f275bcf /sci-misc
parentapp-editors/vim: stable 8.0.1298 for ppc, bug #639710 (diff)
downloadgentoo-e5f2f2be84c3b6a791f53864d397372d41308430.tar.gz
gentoo-e5f2f2be84c3b6a791f53864d397372d41308430.tar.bz2
gentoo-e5f2f2be84c3b6a791f53864d397372d41308430.zip
sci-misc/boinc: Clean up old ebuilds
As it was discussed in bug 640822, said bug is now closed with cleaning up the old ebuilds. The newest no longer depends on gtk2 based wxWidgets, and remains. Closes: https://bugs.gentoo.org/640822 Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'sci-misc')
-rw-r--r--sci-misc/boinc/Manifest1
-rw-r--r--sci-misc/boinc/boinc-7.8.1-r1.ebuild189
-rw-r--r--sci-misc/boinc/boinc-7.8.1.ebuild181
3 files changed, 0 insertions, 371 deletions
diff --git a/sci-misc/boinc/Manifest b/sci-misc/boinc/Manifest
index d4d77311581..669f224b49a 100644
--- a/sci-misc/boinc/Manifest
+++ b/sci-misc/boinc/Manifest
@@ -1,3 +1,2 @@
-DIST boinc-7.8.1.tar.gz 52056850 BLAKE2B ddedde30c18e231e4820e8ecf66a9a5042b25527a1ce670ddeae314ee08b9549601aab4e920871ff30933474bdf5a1ff2d2772daa76eb602fce1d98a1f9d425f SHA512 32a30f19dd6b7e6b6050de9952091c2a60e27f4891542f70a449a7d7af347d9b0eecae4501bfb7465f453d1bbe321369f911be74b882384aa5216db3bf569656
DIST boinc-7.8.4.tar.gz 52035132 BLAKE2B 4234bd6f3ad3bbb4d7d518e45c16b8843de35f37d2cfd40ff149d85d14cb6d6bed2cbd682ba1d16099c1261eb000f8bb2e4f637b47d12e84e43266b4de076ed0 SHA512 d888f6c1586b57cdad7c4c783b2e58ae3bc3da8d0183eaacfe43f9798519e65129324222e6190a8ee1f00be2dfd31ee54fe2a88ef77950506e29552ce32de8aa
DIST boinc.tif 288208 BLAKE2B 156a99f08dcabc62a46874830600b9d237e64b650b8edf35db67b82006a67039a3965707194e8f0b25cfd65138b8700c0bfb877507418393b9cd3df32e94d260 SHA512 548e19b87fd70dbeb05687320b86aad39981c161b5b5b7e02fc3ce886d4c464c9bb763d5652d9895dd505ce247c7ff4490caa3d407e28f54ce889ffbab22d046
diff --git a/sci-misc/boinc/boinc-7.8.1-r1.ebuild b/sci-misc/boinc/boinc-7.8.1-r1.ebuild
deleted file mode 100644
index 885e7ebb207..00000000000
--- a/sci-misc/boinc/boinc-7.8.1-r1.ebuild
+++ /dev/null
@@ -1,189 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-WX_GTK_VER=3.0
-
-inherit autotools eutils gnome2-utils linux-info systemd user versionator wxwidgets
-
-MY_PV=$(get_version_component_range 1-2)
-
-DESCRIPTION="The Berkeley Open Infrastructure for Network Computing"
-HOMEPAGE="http://boinc.ssl.berkeley.edu/"
-SRC_URI="https://github.com/BOINC/boinc/archive/client_release/${MY_PV}/${PV}.tar.gz -> ${P}.tar.gz
- X? ( http://boinc.berkeley.edu/logo/boinc_glossy2_512_F.tif -> ${PN}.tif )"
-RESTRICT="mirror"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
-IUSE="X cuda curl_ssl_gnutls curl_ssl_libressl +curl_ssl_openssl static-libs"
-
-REQUIRED_USE="^^ ( curl_ssl_gnutls curl_ssl_libressl curl_ssl_openssl ) "
-
-# libcurl must not be using an ssl backend boinc does not support.
-# If the libcurl ssl backend changes, boinc should be recompiled.
-RDEPEND="
- !sci-misc/boinc-bin
- !app-admin/quickswitch
- >=app-misc/ca-certificates-20080809
- net-misc/curl[curl_ssl_gnutls(-)=,curl_ssl_libressl(-)=,-curl_ssl_nss(-),curl_ssl_openssl(-)=,-curl_ssl_axtls(-),-curl_ssl_cyassl(-)]
- sys-apps/util-linux
- sys-libs/zlib
- cuda? (
- >=dev-util/nvidia-cuda-toolkit-2.1
- >=x11-drivers/nvidia-drivers-180.22
- )
- X? (
- dev-db/sqlite:3
- media-libs/freeglut
- sys-libs/glibc:2.2
- virtual/jpeg:0=
- x11-libs/gtk+:2
- >=x11-libs/libnotify-0.7
- x11-libs/wxGTK:${WX_GTK_VER}[X,opengl,webkit]
- )
-"
-DEPEND="${RDEPEND}
- sys-devel/gettext
- app-text/docbook-xml-dtd:4.4
- app-text/docbook2X
- X? ( virtual/imagemagick-tools[png,tiff] )
-"
-
-PATCHES=(
- # >=x11-libs/wxGTK-3.0.2.0-r3 has webview removed, bug 587462
- "${FILESDIR}"/fix_webview.patch
-)
-
-S="${WORKDIR}/${PN}-client_release-${MY_PV}-${PV}"
-
-pkg_setup() {
- # Bug 578750
- if use kernel_linux; then
- linux-info_pkg_setup
- if ! linux_config_exists; then
- ewarn "Can't check the linux kernel configuration."
- ewarn "You might be missing vsyscall support."
- elif kernel_is -ge 4 4 \
- && linux_chkconfig_present LEGACY_VSYSCALL_NONE; then
- ewarn "You do not have vsyscall emulation enabled."
- ewarn "This will prevent some boinc projects from running."
- ewarn "Please enable vsyscall emulation:"
- ewarn " CONFIG_LEGACY_VSYSCALL_EMULATE=y"
- ewarn "in /usr/src/linux/.config, to be found at"
- ewarn " Processor type and features --->"
- ewarn " vsyscall table for legacy applications (None) --->"
- ewarn " (X) Emulate"
- ewarn "Alternatively, you can enable CONFIG_LEGACY_VSYSCALL_NATIVE."
- ewarn "However, this has security implications and is not recommended."
- fi
- fi
-}
-
-src_prepare() {
- default
-
- # prevent bad changes in compile flags, bug 286701
- sed -i -e "s:BOINC_SET_COMPILE_FLAGS::" configure.ac || die "sed failed"
-
- eautoreconf
-
- use X && need-wxwidgets unicode
-}
-
-src_configure() {
- econf --disable-server \
- --enable-client \
- --enable-dynamic-client-linkage \
- --disable-static \
- --enable-unicode \
- --with-ssl \
- $(use_with X x) \
- $(use_enable X manager) \
- $(usex X --with-wx-config="${WX_CONFIG}" --without-wxdir)
-}
-
-src_install() {
- default
-
- keepdir /var/lib/${PN}
-
- if use X; then
- # Create new icons. bug 593362
- local s SIZES=(16 22 24 32 36 48 64 72 96 128 192 256)
- for s in "${SIZES[@]}"; do
- convert "${DISTDIR}"/${PN}.tif -resize ${s}x${s} "${WORKDIR}"/boinc_${s}.png || die
- newicon -s $s "${WORKDIR}"/boinc_${s}.png boinc.png
- done
- make_desktop_entry boincmgr "${PN}" "${PN}" "Math;Science" "Path=/var/lib/${PN}"
-
- # Rename the desktop file to boincmgr.desktop to (hot)fix bug 599910
- mv "${ED%/}"/usr/share/applications/boincmgr{-${PN},}.desktop || \
- die "Failed to rename desktop file"
- fi
-
- # cleanup cruft
- rm -rf "${ED%/}"/etc || die "rm failed"
-
- sed -e "s/@libdir@/$(get_libdir)/" "${FILESDIR}"/${PN}.init.in > ${PN}.init || die
- newinitd ${PN}.init ${PN}
- newconfd "${FILESDIR}"/${PN}.conf ${PN}
- systemd_dounit "${FILESDIR}"/${PN}.service
-}
-
-pkg_preinst() {
- gnome2_icon_savelist
-
- enewgroup ${PN}
- # note this works only for first install so we have to
- # elog user about the need of being in video group
- local groups="${PN}"
- if use cuda; then
- groups+=",video"
- fi
- enewuser ${PN} -1 -1 /var/lib/${PN} "${groups}"
-}
-
-pkg_postinst() {
- gnome2_icon_cache_update
-
- elog
- elog "You are using the source compiled version of boinc."
- use X && elog "The graphical manager can be found at /usr/bin/boincmgr"
- elog
- elog "You need to attach to a project to do anything useful with boinc."
- elog "You can do this by running /etc/init.d/boinc attach"
- elog "The howto for configuration is located at:"
- elog "http://boinc.berkeley.edu/wiki/Anonymous_platform"
- elog
- # Add warning about the new password for the client, bug 121896.
- if use X; then
- elog "If you need to use the graphical manager the password is in:"
- elog "/var/lib/boinc/gui_rpc_auth.cfg"
- elog "Where /var/lib/ is default RUNTIMEDIR, that can be changed in:"
- elog "/etc/conf.d/boinc"
- elog "You should change this password to something more memorable (can be even blank)."
- elog "Remember to launch init script before using manager. Or changing the password."
- elog
- fi
- if use cuda; then
- elog "To be able to use CUDA you should add boinc user to video group."
- elog "Run as root:"
- elog "gpasswd -a boinc video"
- elog
- fi
- # Add information about BOINC supporting OpenCL
- elog "BOINC supports OpenCL. To use it you have to eselect"
- if use cuda; then
- elog "nvidia as the OpenCL implementation, as you are using CUDA."
- else
- elog "the correct OpenCL implementation for your graphic card."
- fi
- elog
-}
-
-pkg_postrm() {
- gnome2_icon_cache_update
-}
diff --git a/sci-misc/boinc/boinc-7.8.1.ebuild b/sci-misc/boinc/boinc-7.8.1.ebuild
deleted file mode 100644
index 59a13dfeba9..00000000000
--- a/sci-misc/boinc/boinc-7.8.1.ebuild
+++ /dev/null
@@ -1,181 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-WX_GTK_VER=3.0
-
-inherit autotools eutils linux-info systemd user versionator wxwidgets
-
-MY_PV=$(get_version_component_range 1-2)
-
-DESCRIPTION="The Berkeley Open Infrastructure for Network Computing"
-HOMEPAGE="http://boinc.ssl.berkeley.edu/"
-SRC_URI="https://github.com/BOINC/boinc/archive/client_release/${MY_PV}/${PV}.tar.gz -> ${P}.tar.gz
- X? ( http://boinc.berkeley.edu/logo/boinc_glossy2_512_F.tif -> ${PN}.tif )"
-RESTRICT="mirror"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
-IUSE="X cuda curl_ssl_gnutls curl_ssl_libressl +curl_ssl_openssl static-libs"
-
-REQUIRED_USE="^^ ( curl_ssl_gnutls curl_ssl_libressl curl_ssl_openssl ) "
-
-# libcurl must not be using an ssl backend boinc does not support.
-# If the libcurl ssl backend changes, boinc should be recompiled.
-RDEPEND="
- !sci-misc/boinc-bin
- !app-admin/quickswitch
- >=app-misc/ca-certificates-20080809
- net-misc/curl[curl_ssl_gnutls(-)=,curl_ssl_libressl(-)=,-curl_ssl_nss(-),curl_ssl_openssl(-)=,-curl_ssl_axtls(-),-curl_ssl_cyassl(-)]
- sys-apps/util-linux
- sys-libs/zlib
- cuda? (
- >=dev-util/nvidia-cuda-toolkit-2.1
- >=x11-drivers/nvidia-drivers-180.22
- )
- X? (
- dev-db/sqlite:3
- media-libs/freeglut
- sys-libs/glibc:2.2
- virtual/jpeg:0=
- x11-libs/gtk+:2
- >=x11-libs/libnotify-0.7
- x11-libs/wxGTK:${WX_GTK_VER}[X,opengl,webkit]
- )
-"
-DEPEND="${RDEPEND}
- sys-devel/gettext
- app-text/docbook-xml-dtd:4.4
- app-text/docbook2X
- X? ( virtual/imagemagick-tools[png,tiff] )
-"
-
-PATCHES=(
- # >=x11-libs/wxGTK-3.0.2.0-r3 has webview removed, bug 587462
- "${FILESDIR}"/fix_webview.patch
-)
-
-S="${WORKDIR}/${PN}-client_release-${MY_PV}-${PV}"
-
-pkg_setup() {
- # Bug 578750
- if use kernel_linux; then
- linux-info_pkg_setup
- if ! linux_config_exists; then
- ewarn "Can't check the linux kernel configuration."
- ewarn "You might be missing vsyscall support."
- elif kernel_is -ge 4 4 \
- && linux_chkconfig_present LEGACY_VSYSCALL_NONE; then
- ewarn "You do not have vsyscall emulation enabled."
- ewarn "This will prevent some boinc projects from running."
- ewarn "Please enable vsyscall emulation:"
- ewarn " CONFIG_LEGACY_VSYSCALL_EMULATE=y"
- ewarn "in /usr/src/linux/.config, to be found at"
- ewarn " Processor type and features --->"
- ewarn " vsyscall table for legacy applications (None) --->"
- ewarn " (X) Emulate"
- ewarn "Alternatively, you can enable CONFIG_LEGACY_VSYSCALL_NATIVE."
- ewarn "However, this has security implications and is not recommended."
- fi
- fi
-}
-
-src_prepare() {
- default
-
- # prevent bad changes in compile flags, bug 286701
- sed -i -e "s:BOINC_SET_COMPILE_FLAGS::" configure.ac || die "sed failed"
-
- eautoreconf
-
- use X && need-wxwidgets unicode
-}
-
-src_configure() {
- econf --disable-server \
- --enable-client \
- --enable-dynamic-client-linkage \
- --disable-static \
- --enable-unicode \
- --with-ssl \
- $(use_with X x) \
- $(use_enable X manager) \
- $(usex X --with-wx-config="${WX_CONFIG}" --without-wxdir)
-}
-
-src_install() {
- default
-
- keepdir /var/lib/${PN}
-
- if use X; then
- # Create new icons. bug 593362
- local s SIZES=(16 22 24 32 36 48 64 72 96 128 192 256)
- for s in "${SIZES[@]}"; do
- convert "${DISTDIR}"/${PN}.tif -resize ${s}x${s} "${WORKDIR}"/boinc_${s}.png || die
- newicon -s $s "${WORKDIR}"/boinc_${s}.png boinc.png
- done
- make_desktop_entry boincmgr "${PN}" "${PN}" "Math;Science" "Path=/var/lib/${PN}"
-
- # Rename the desktop file to boincmgr.desktop to (hot)fix bug 599910
- mv "${ED%/}"/usr/share/applications/boincmgr{-${PN},}.desktop || \
- die "Failed to rename desktop file"
- fi
-
- # cleanup cruft
- rm -rf "${ED%/}"/etc || die "rm failed"
-
- sed -e "s/@libdir@/$(get_libdir)/" "${FILESDIR}"/${PN}.init.in > ${PN}.init || die
- newinitd ${PN}.init ${PN}
- newconfd "${FILESDIR}"/${PN}.conf ${PN}
- systemd_dounit "${FILESDIR}"/${PN}.service
-}
-
-pkg_preinst() {
- enewgroup ${PN}
- # note this works only for first install so we have to
- # elog user about the need of being in video group
- local groups="${PN}"
- if use cuda; then
- groups+=",video"
- fi
- enewuser ${PN} -1 -1 /var/lib/${PN} "${groups}"
-}
-
-pkg_postinst() {
- elog
- elog "You are using the source compiled version of boinc."
- use X && elog "The graphical manager can be found at /usr/bin/boincmgr"
- elog
- elog "You need to attach to a project to do anything useful with boinc."
- elog "You can do this by running /etc/init.d/boinc attach"
- elog "The howto for configuration is located at:"
- elog "http://boinc.berkeley.edu/wiki/Anonymous_platform"
- elog
- # Add warning about the new password for the client, bug 121896.
- if use X; then
- elog "If you need to use the graphical manager the password is in:"
- elog "/var/lib/boinc/gui_rpc_auth.cfg"
- elog "Where /var/lib/ is default RUNTIMEDIR, that can be changed in:"
- elog "/etc/conf.d/boinc"
- elog "You should change this password to something more memorable (can be even blank)."
- elog "Remember to launch init script before using manager. Or changing the password."
- elog
- fi
- if use cuda; then
- elog "To be able to use CUDA you should add boinc user to video group."
- elog "Run as root:"
- elog "gpasswd -a boinc video"
- elog
- fi
- # Add information about BOINC supporting OpenCL
- elog "BOINC supports OpenCL. To use it you have to eselect"
- if use cuda; then
- elog "nvidia as the OpenCL implementation, as you are using CUDA."
- else
- elog "the correct OpenCL implementation for your graphic card."
- fi
- elog
-}