summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2022-03-05 22:40:17 +0100
committerDavid Seifert <soap@gentoo.org>2022-03-05 22:40:17 +0100
commit761c3a98a6da89e7ada0ac6173b2a9fb3525a717 (patch)
treeed14c416e99549ea534aca15c604c75e08431850 /sci-physics/hepmc/hepmc-2.06.09-r1.ebuild
parentmedia-libs/libuvc: port to EAPI 8 (diff)
downloadgentoo-761c3a98a6da89e7ada0ac6173b2a9fb3525a717.tar.gz
gentoo-761c3a98a6da89e7ada0ac6173b2a9fb3525a717.tar.bz2
gentoo-761c3a98a6da89e7ada0ac6173b2a9fb3525a717.zip
sci-physics/hepmc: port to EAPI 8
Closes: https://bugs.gentoo.org/834297 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sci-physics/hepmc/hepmc-2.06.09-r1.ebuild')
-rw-r--r--sci-physics/hepmc/hepmc-2.06.09-r1.ebuild95
1 files changed, 0 insertions, 95 deletions
diff --git a/sci-physics/hepmc/hepmc-2.06.09-r1.ebuild b/sci-physics/hepmc/hepmc-2.06.09-r1.ebuild
deleted file mode 100644
index e8453c9991df..000000000000
--- a/sci-physics/hepmc/hepmc-2.06.09-r1.ebuild
+++ /dev/null
@@ -1,95 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit cmake-utils
-
-MYP=HepMC-${PV}
-
-DESCRIPTION="Event Record for Monte Carlo Generators"
-HOMEPAGE="https://hepmc.web.cern.ch/hepmc/"
-SRC_URI="http://lcgapp.cern.ch/project/simu/HepMC/download/${MYP}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
-IUSE="cm doc examples gev static-libs test"
-RESTRICT="!test? ( test )"
-
-RDEPEND=""
-DEPEND="${RDEPEND}
- doc? (
- app-doc/doxygen
- dev-texlive/texlive-latex
- dev-texlive/texlive-latexextra
- dev-texlive/texlive-latexrecommended
- )"
-
-S="${WORKDIR}/${MYP}"
-
-DOCS=( ChangeLog AUTHORS )
-
-src_prepare() {
- cmake-utils_src_prepare
-
- sed -i -e '/add_subdirectory(doc)/d' CMakeLists.txt || die
- # CMake doc building broken
- # gentoo doc directory
- #sed -i \
- # -e "s:share/HepMC/doc:share/doc/${PF}:" \
- # doc/CMakeLists.txt || die
-
- # gentoo examples directory
- sed -i \
- -e "s:share/HepMC:share/doc/${PF}:" \
- $(find examples -name CMakeLists.txt) || die
-
- # respect user's flags
- sed -i \
- -e "s/-O -ansi -pedantic -Wall//g" \
- cmake/Modules/HepMCVariables.cmake || die
-
- # gentoo libdir love
- sed -i \
- -e '/DESTINATION/s/lib/lib${LIB_SUFFIX}/g' \
- {src,fio}/CMakeLists.txt || die
-
- # remove targets if use flags not set
- if ! use examples; then
- sed -i -e '/add_subdirectory(examples)/d' CMakeLists.txt || die
- fi
- if ! use test; then
- sed -i -e '/add_subdirectory(test)/d' CMakeLists.txt || die
- fi
- if ! use static-libs; then
- sed -i \
- -e '/(HepMC\(fio\|\)S/d' \
- -e '/TARGETS/s/HepMC\(fio\|\)S//' \
- {src,fio}/CMakeLists.txt || die
- fi
-}
-
-src_configure() {
- # use MeV over GeV and mm over cm
- local mycmakeargs=(
- -Dlength=$(usex cm CM MM)
- -Dmomentum=$(usex gev GEV MEV)
- )
- cmake-utils_src_configure
-}
-
-src_compile() {
- cmake-utils_src_compile
- if use doc; then
- cd doc
- ./buildDoc.sh || die
- ./buildDoxygen.sh || die
- fi
-}
-
-src_install() {
- use doc && HTML_DOCS=( doc/html/. )
- use doc && dodoc doc/*.pdf
- cmake-utils_src_install
-}