summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuilherme Amadio <amadio@gentoo.org>2020-06-15 11:33:13 +0200
committerGuilherme Amadio <amadio@gentoo.org>2020-06-15 11:45:22 +0200
commit30155f2646e28cc2a287088be3cac2c9de0f125d (patch)
tree36bac95df501d83ca09d6f973339ba687bcd34f6 /sci-physics/root
parentsci-physics/root: version bump to 6.22.00 (diff)
downloadgentoo-30155f2646e28cc2a287088be3cac2c9de0f125d.tar.gz
gentoo-30155f2646e28cc2a287088be3cac2c9de0f125d.tar.bz2
gentoo-30155f2646e28cc2a287088be3cac2c9de0f125d.zip
sci-physics/root: update live ebuild for EAPI=7
EAPI=7, cmake.eclass, drop eutils, update build options. Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Guilherme Amadio <amadio@gentoo.org>
Diffstat (limited to 'sci-physics/root')
-rw-r--r--sci-physics/root/root-9999.ebuild44
1 files changed, 23 insertions, 21 deletions
diff --git a/sci-physics/root/root-9999.ebuild b/sci-physics/root/root-9999.ebuild
index c8b16d196ea1..54b3cc2715b1 100644
--- a/sci-physics/root/root-9999.ebuild
+++ b/sci-physics/root/root-9999.ebuild
@@ -1,15 +1,14 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
# ninja does not work due to fortran
CMAKE_MAKEFILE_GENERATOR=emake
FORTRAN_NEEDED="fortran"
PYTHON_COMPAT=( python2_7 python3_{6,7,8} )
-inherit cmake-utils cuda eapi7-ver elisp-common eutils fortran-2 \
- prefix python-single-r1 toolchain-funcs
+inherit cmake cuda elisp-common fortran-2 prefix python-single-r1 toolchain-funcs
DESCRIPTION="C++ data analysis framework and interpreter from CERN"
HOMEPAGE="https://root.cern"
@@ -24,7 +23,7 @@ RESTRICT="!test? ( test )"
if [[ ${PV} =~ "9999" ]] ; then
inherit git-r3
KEYWORDS=""
- EGIT_REPO_URI="http://root.cern/git/root.git"
+ EGIT_REPO_URI="https://github.com/root-project/root.git"
if [[ ${PV} == "9999" ]]; then
SLOT="0"
else
@@ -40,7 +39,7 @@ LICENSE="LGPL-2.1 freedist MSttfEULA LGPL-3 libpng UoI-NCSA"
REQUIRED_USE="
^^ ( c++11 c++14 c++17 )
- cuda? ( tmva !c++17 )
+ cuda? ( tmva )
cudnn? ( cuda )
!X? ( !asimage !opengl !qt5 )
davix? ( ssl xml )
@@ -138,12 +137,14 @@ pkg_setup() {
src_prepare() {
use cuda && cuda_src_prepare
- cmake-utils_src_prepare
+ cmake_src_prepare
sed -i "/CLING_BUILD_PLUGINS/d" interpreter/CMakeLists.txt || die
# CSS should use local images
sed -i -e 's,http://.*/,,' etc/html/ROOT.css || die "html sed failed"
+
+ eapply_user
}
# Note: ROOT uses bundled clang because it is patched and API-incompatible
@@ -166,7 +167,6 @@ src_configure() {
-DCMAKE_INSTALL_LIBDIR="lib"
-DDEFAULT_SYSROOT="${EPREFIX}"
-DCLING_BUILD_PLUGINS=OFF
- -Dexplicitlink=ON
-Dexceptions=ON
-Dfail-on-missing=ON
-Dgnuinstall=OFF
@@ -196,11 +196,9 @@ src_configure() {
-Dbuiltin_xxhash=OFF
-Dbuiltin_zlib=OFF
-Dbuiltin_zstd=OFF
- -Dx11=$(usex X)
-Dalien=OFF
-Darrow=OFF
-Dasimage=$(usex asimage)
- -Dlibcxx=$(usex libcxx)
-Dccache=OFF # use ccache via portage
-Dcefweb=OFF
-Dclad=OFF
@@ -208,22 +206,21 @@ src_configure() {
-Dcuda=$(usex cuda)
-Dcudnn=$(usex cudnn)
-Dcxxmodules=OFF # requires clang, unstable
- -Ddavix=$(usex davix)
-Ddataframe=ON
+ -Ddavix=$(usex davix)
-Ddcache=OFF
-Dfcgi=$(usex http)
-Dfftw3=$(usex fftw)
-Dfitsio=$(usex fits)
-Dfortran=$(usex fortran)
- -Dftgl=$(usex opengl)
-Dgdml=$(usex gdml)
-Dgfal=OFF
- -Dgl2ps=$(usex opengl)
-Dgminimal=OFF
-Dgsl_shared=$(usex gsl)
-Dgviz=$(usex graphviz)
-Dhttp=$(usex http)
-Dimt=$(usex tbb)
+ -Dlibcxx=$(usex libcxx)
-Dmathmore=$(usex gsl)
-Dmemstat=OFF # deprecated
-Dminimal=OFF
@@ -238,19 +235,20 @@ src_configure() {
-Doracle=$(usex oracle)
-Dpgsql=$(usex postgres)
-Dpythia6=$(usex pythia6)
- -Dpythia8=$(usex pythia8)
-Dpyroot=$(usex python) # python was renamed to pyroot
- -Dpython=$(usex python) # kept for backward compatibility
- -Dpyroot_experimental=OFF # use standard PyROOT for now
+ #-Dpyroot_legacy=OFF # set to ON to use legacy PyROOT (6.22 and later)
+ #-Dpyroot_experimental=OFF # set to ON to use new PyROOT (6.20 and earlier)
+ -Dpythia8=$(usex pythia8)
-Dqt5web=$(usex qt5)
+ -Dr=$(usex R)
-Droofit=$(usex roofit)
-Droot7=$(usex root7)
-Drootbench=OFF
-Droottest=OFF
-Drpath=OFF
- -Druntime_cxxmodules=OFF # does not work yet
- -Dr=$(usex R)
+ -Druntime_cxxmodules=OFF
-Dshadowpw=$(usex shadow)
+ -Dspectrum=ON
-Dsqlite=$(usex sqlite)
-Dssl=$(usex ssl)
-Dtcmalloc=OFF
@@ -258,28 +256,32 @@ src_configure() {
-Dtmva=$(usex tmva)
-Dtmva-cpu=$(usex tmva)
-Dtmva-gpu=$(usex cuda)
+ -Dtmva-pymva=$(usex tmva)
+ -Dtmva-rmva=$(usex R)
-Dunuran=$(usex unuran)
-Dvc=$(usex vc)
- -Dvmc=$(usex vmc)
-Dvdt=OFF
-Dveccore=OFF
+ -Dvecgeom=OFF
+ -Dvmc=$(usex vmc)
+ -Dx11=$(usex X)
-Dxml=$(usex xml)
-Dxrootd=$(usex xrootd)
${EXTRA_ECONF}
)
CMAKE_BUILD_TYPE=$(usex debug Debug Release) \
- cmake-utils_src_configure
+ cmake_src_configure
}
src_compile() {
# needed for hsimple.root
addwrite /dev/random
- cmake-utils_src_compile
+ cmake_src_compile
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
ROOTSYS=${EPREFIX}/usr/lib/${PN}/$(ver_cut 1-2)