summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2017-12-16 14:03:40 +0700
committerAndrey Grozin <grozin@gentoo.org>2017-12-16 14:03:40 +0700
commit5cc4e599fd68ca31c3d2d0824c4ffaa8ed877e54 (patch)
tree5a9129acd90b8491e99905c772e1e42c8e98f5f7 /sci-physics
parentsci-physics/reduze: bump to 2.2 (diff)
downloadgentoo-5cc4e599fd68ca31c3d2d0824c4ffaa8ed877e54.tar.gz
gentoo-5cc4e599fd68ca31c3d2d0824c4ffaa8ed877e54.tar.bz2
gentoo-5cc4e599fd68ca31c3d2d0824c4ffaa8ed877e54.zip
sci-physics/reduze: cleaning old
Package-Manager: Portage-2.3.18, Repoman-2.3.6
Diffstat (limited to 'sci-physics')
-rw-r--r--sci-physics/reduze/Manifest2
-rw-r--r--sci-physics/reduze/files/reduze-2.0.9-gcc6.patch58
-rw-r--r--sci-physics/reduze/files/reduze-2.1-gcc6.patch29
-rw-r--r--sci-physics/reduze/reduze-2.0.9.ebuild67
-rw-r--r--sci-physics/reduze/reduze-2.1.ebuild67
5 files changed, 0 insertions, 223 deletions
diff --git a/sci-physics/reduze/Manifest b/sci-physics/reduze/Manifest
index 2879a9c53844..b83b647d5cd7 100644
--- a/sci-physics/reduze/Manifest
+++ b/sci-physics/reduze/Manifest
@@ -1,3 +1 @@
-DIST reduze-2.0.9.tar.gz 568570 BLAKE2B 95eb5b89cb67cb91e6909b245499ac2f1cd944d0ff1c9d714ec37dfcdde0e6a19b1a4014cbb1f45dfc1bc9f502322c624ba2f2cd6b3e972067d4792ce4433cf6 SHA512 69818d7edaf3c69996d3f703401865f67722ec8d33b285642c71030f2852273b4b4028a00f0c639589cb801def739f93a05d504d4fb2edf228674962897d5f01
-DIST reduze-2.1.tar.gz 650423 BLAKE2B e1497ce54067bf82f98a07396becbac8f7e8b9fd53412219e6b4276b502b99367aafc60b2c616913cf5a6a8abf8f2bcc49b42e3163d840b4216923981430edae SHA512 e27f711639fe4b95c2aef4e73a7f6d9dd1574d1a62bc531d0f5177c505ffd353193548f29332f3b5320d4907bebd404ef082d3fea1dd392b83573d085b4a795a
DIST reduze-2.2.tar.gz 669858 BLAKE2B 52c48f5547055087dc2969fe5a7a42281519cf1d9a454a675ea54741f3d5912cd9b135816994241fa206585038d683ba5a3849308ff0403f1d3507ec9b77fe00 SHA512 ca4ed6f754fc75511b0916e8c2eea26a69e0e30c604a714af76995038a8e11dc3b129157bf1a170e639ea0fc39f9f5102bba4ad503874f044ac91855d9a95dab
diff --git a/sci-physics/reduze/files/reduze-2.0.9-gcc6.patch b/sci-physics/reduze/files/reduze-2.0.9-gcc6.patch
deleted file mode 100644
index 9864163cdec9..000000000000
--- a/sci-physics/reduze/files/reduze-2.0.9-gcc6.patch
+++ /dev/null
@@ -1,58 +0,0 @@
---- a/reduze/amplitude.cpp
-+++ b/reduze/amplitude.cpp
-@@ -782,7 +782,7 @@
-
- ex resultLeadingNc = result;
- for (exset::const_iterator it = found.begin(); it != found.end(); ++it) {
-- VERIFY(is_a<function>(*it) && ex_to<function>(*it).get_name() == "Color");
-+ VERIFY(is_a<GiNaC::function>(*it) && ex_to<GiNaC::function>(*it).get_name() == "Color");
- VERIFY(is_a<lst>(it->op(0)));
- ex res(1);
- for (size_t i = 0; i < it->op(0).nops(); ++i)
-@@ -823,7 +823,7 @@
- timer.restart();
- exmap m;
- for (exset::const_iterator it = found.begin(); it != found.end(); ++it) {
-- VERIFY(is_a<function>(*it) && ex_to<function>(*it).get_name() == "Lorentz");
-+ VERIFY(is_a<GiNaC::function>(*it) && ex_to<GiNaC::function>(*it).get_name() == "Lorentz");
- VERIFY(is_a<lst>(it->op(0)));
-
- ex res(1);
---- a/reduze/files.cpp
-+++ b/reduze/files.cpp
-@@ -420,7 +420,7 @@
- get_filename_sectormappings(m.integralfamily()->name());
- ofstream file(file_name.c_str());
- if (!file)
-- ABORT("Can't write to " << file);
-+ ABORT("Can't write to " << file_name);
- os << YAML::BeginMap << YAML::Key << "sectormappings" << YAML::Value;
- os << m << YAML::EndMap;
- file << os.c_str();
-@@ -617,7 +617,7 @@
-
- bool is_readable_file(const string& filename) {
- ifstream is(filename.c_str());
-- bool ok = is;
-+ bool ok = !is.fail();
- is.close();
- return ok;
- }
---- a/reduze/sectormappings.cpp
-+++ b/reduze/sectormappings.cpp
-@@ -757,13 +757,13 @@
- const Node& z_node = node["zero_sectors"];
- for (Iterator n = z_node.begin(); n != z_node.end(); ++n)
- for (Iterator s = n.second().begin(); s != n.second().end(); ++s)
-- m.zero_sectors_.insert(*s);
-+ m.zero_sectors_.insert((const int) *s);
-
- if (node.FindValue("sectors_without_graph")) {
- const Node& ng_node = node["sectors_without_graph"];
- for (Iterator n = ng_node.begin(); n != ng_node.end(); ++n)
- for (Iterator s = n.second().begin(); s != n.second().end(); ++s)
-- m.sectors_without_graph_.insert(*s);
-+ m.sectors_without_graph_.insert((const int) *s);
- }
-
- const Node& rel_node = node["sector_relations"];
diff --git a/sci-physics/reduze/files/reduze-2.1-gcc6.patch b/sci-physics/reduze/files/reduze-2.1-gcc6.patch
deleted file mode 100644
index 3b347ef413c3..000000000000
--- a/sci-physics/reduze/files/reduze-2.1-gcc6.patch
+++ /dev/null
@@ -1,29 +0,0 @@
---- a/reduze/files.cpp
-+++ b/reduze/files.cpp
-@@ -723,7 +723,7 @@
- string file_name_tmp = file_name + ".tmp";
- ofstream file(file_name_tmp.c_str());
- if (!file)
-- ABORT("Can't write to " << file);
-+ ABORT("Can't write to " << file_name_tmp);
- Emitter os;
- os << BeginMap;
- os << Key << "crossings" << Value;
-@@ -752,7 +752,7 @@
- string file_name_tmp = file_name + ".tmp";
- ofstream file(file_name_tmp.c_str());
- if (!file)
-- ABORT("Can't write to " << file);
-+ ABORT("Can't write to " << file_name_tmp);
- os << YAML::BeginMap << YAML::Key << "sectormappings" << YAML::Value;
- os << m << YAML::EndMap;
- file << os.c_str();
-@@ -1036,7 +1036,7 @@
-
- bool is_readable_file(const string& filename) {
- ifstream is(filename.c_str());
-- bool ok = is;
-+ bool ok = !is.fail();
- is.close();
- return ok && !is_readable_directory(filename);
- }
diff --git a/sci-physics/reduze/reduze-2.0.9.ebuild b/sci-physics/reduze/reduze-2.0.9.ebuild
deleted file mode 100644
index 3c0713e8e163..000000000000
--- a/sci-physics/reduze/reduze-2.0.9.ebuild
+++ /dev/null
@@ -1,67 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit cmake-utils
-
-DESCRIPTION="Program for reducing Feynman integrals"
-HOMEPAGE="http://reduze.hepforge.org/"
-SRC_URI="http://reduze.hepforge.org/download/${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="berkdb doc mpi"
-
-RDEPEND=">=sci-mathematics/ginac-1.4.1
- berkdb? ( sys-libs/db[cxx] )
- mpi? ( virtual/mpi )"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
- doc? ( app-doc/doxygen )"
-
-DOCS=( ChangeLog README )
-
-src_prepare() {
- epatch "${FILESDIR}"/${P}-gcc6.patch
-
- # gentoo doc directory
- sed -i \
- -e "s:share/reduze:share/doc/${PF}:g" \
- CMakeLists.txt || die
- use doc || sed -i -e '/share/d' CMakeLists.txt
- # prefix fix
- sed -i \
- -e "s:/usr:${EPREFIX}/usr:g" \
- reduze/CMakeLists.txt || die
-
- # remove bundled yaml-cpp
- # no: it does not build. is it patched?
- # sed -i -e '/add_subdirectory ("yaml")/d' CMakeLists.txt || die
-}
-
-src_configure() {
- local mycmakeargs=(
- -DUSE_HASH_TABLE=ON
- $(cmake-utils_use berkdb USE_DATABASE)
- $(cmake-utils_use mpi USE_MPI)
- )
- cmake-utils_src_configure
-}
-
-src_compile() {
- cmake-utils_src_compile all $(use doc && echo doc)
-}
-
-src_test() {
- cd "${CMAKE_BUILD_DIR}"
- emake check
- use mpi && emake check_mpi
-}
-
-src_install() {
- cmake-utils_src_install
- use doc && dohtml -r "${CMAKE_BUILD_DIR}"/doc/code/html/*
-}
diff --git a/sci-physics/reduze/reduze-2.1.ebuild b/sci-physics/reduze/reduze-2.1.ebuild
deleted file mode 100644
index ad6f52292b44..000000000000
--- a/sci-physics/reduze/reduze-2.1.ebuild
+++ /dev/null
@@ -1,67 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit cmake-utils
-
-DESCRIPTION="Program for reducing Feynman integrals"
-HOMEPAGE="http://reduze.hepforge.org/"
-SRC_URI="http://reduze.hepforge.org/download/${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="berkdb doc mpi"
-
-RDEPEND=">=sci-mathematics/ginac-1.4.1
- berkdb? ( sys-libs/db:=[cxx] )
- mpi? ( virtual/mpi )"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
- doc? ( app-doc/doxygen )"
-
-PATCHES=( "${FILESDIR}"/${P}-gcc6.patch )
-
-src_prepare() {
- cmake-utils_src_prepare
- # gentoo doc directory
- sed -i \
- -e "s:share/reduze:share/doc/${PF}:g" \
- CMakeLists.txt || die
- if ! use doc ; then
- sed -i -e '/share/d' CMakeLists.txt || die
- fi
- # prefix fix
- sed -i \
- -e "s:/usr:${EPREFIX}/usr:g" \
- reduze/CMakeLists.txt || die
-
- # remove bundled yaml-cpp
- # no: it does not build. is it patched?
- # sed -i -e '/add_subdirectory ("yaml")/d' CMakeLists.txt || die
-}
-
-src_configure() {
- local mycmakeargs=(
- -DUSE_HASH_TABLE=ON
- -DUSE_DATABASE=$(usex berkdb)
- -DUSE_MPI=$(usex mpi)
- )
- cmake-utils_src_configure
-}
-
-src_compile() {
- cmake-utils_src_compile all $(usev doc)
-}
-
-src_test() {
- cmake-utils_src_compile check
- use mpi && cmake-utils_src_compile check_mpi
-}
-
-src_install() {
- use doc && HTML_DOCS+=( "${BUILD_DIR}"/doc/code/html/. )
- cmake-utils_src_install
-}