summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Bock <nicolasbock@gentoo.org>2015-12-17 08:12:28 -0700
committerNicolas Bock <nicolasbock@gentoo.org>2015-12-17 08:13:01 -0700
commit7ef51291018b4ac018b40fc36574900264285a53 (patch)
treefa0928571a63034b98f585ce4158fd7a1023de8e /sci-physics
parentapp-emulation/qemu: drop versions <2.4.1-r2 (diff)
downloadgentoo-7ef51291018b4ac018b40fc36574900264285a53.tar.gz
gentoo-7ef51291018b4ac018b40fc36574900264285a53.tar.bz2
gentoo-7ef51291018b4ac018b40fc36574900264285a53.zip
sci-physics/lammps: Version bump
Package-Manager: portage-2.2.24
Diffstat (limited to 'sci-physics')
-rw-r--r--sci-physics/lammps/Manifest1
-rw-r--r--sci-physics/lammps/lammps-20151211.ebuild217
2 files changed, 218 insertions, 0 deletions
diff --git a/sci-physics/lammps/Manifest b/sci-physics/lammps/Manifest
index a8d944c1df70..feecc9afb785 100644
--- a/sci-physics/lammps/Manifest
+++ b/sci-physics/lammps/Manifest
@@ -1,5 +1,6 @@
DIST lammps-10Aug15.tar.gz 87890369 SHA256 450a765f94b70a6f38637854f1d7496dca98d359414c527f8de99bed1fdd94d2 SHA512 fc395cf7e59de7e71bad64e2500224d33ff0f76bb79530fdcde5ec9879b91c332d1421a25e5d5bb9cc47a55745e760d01b2ac8ad29f9e71c8a90a0ace9212618 WHIRLPOOL 3f50513137283f4deb9b6a2c13a7ba63814b0ddd59d33e428fba9d3f94f61baa1b3b9d9d080982453a7828d2a98e619cded4d27716fd165db595832a157c9f6b
DIST lammps-10Feb15.tar.gz 62912048 SHA256 59373e9b5592f7b697a144bbce1fb742726e03536b7bb355dac7a9e013ddf9b8 SHA512 a7804377a23f03f338bdaf443439dffcdc52293b4c45e6369b340a1107510fed0b8a198e3b5afcff2e04e109985b52ee62e7b28276697bae37ac6f783d1ab9f2 WHIRLPOOL 09f29cadf8b072d388abe45ec219341d2a14a6c9cc9e4010a0f7945e930e9984738f7837748d117ab95ca76ce0c8d9160fe88dcec17e8d21b81f385dec8f7005
+DIST lammps-11Dec15.tar.gz 82386057 SHA256 f95cce2efa5f9d5649de22c19c96281f3af7b0f65a1f051a268131fe526542d9 SHA512 dce3c29811ee25b8404774b69d7e9746535bed5c4ae9a1c21aaf6979e411bb4b777ca95a4f788d16f6093785e074dbc5275c2d99b1c1d6a28aa0706069855a77 WHIRLPOOL a0b7fcf202745d22511ced803c8bc55b0487a8cdb2c32a0c9a121569a7e5641b072ccbcc70ef7a1529da736d6166d6d2afd80769fc84fc4f07af25b023710a57
DIST lammps-11Sep15.tar.gz 87274144 SHA256 79a40bc395a9052345cf1c7caa8da69f6ec0603e0be09503b060c51672a9734f SHA512 a478470d6e90c870dad606649009c085451d3890632dfc05a84890ff9d69e8465eff52d4853b4dc4a82ebcb15074c8f2fd07bbde132404a01c1c5df0867ee3f2 WHIRLPOOL 21225df1baadd02dbdc9f0b7aea6a2323ac1a1ac177453b67d5387b87a711e505395d17efada9ca5d079d919842da69c6d41d9a3a6ec6375d8526c3ed32f8ad3
DIST lammps-15May15.tar.gz 63835027 SHA256 0233ea98c7d77d31bd0a538bb674c0ee8f000f1d0ee1b8c049072873192aa228 SHA512 a23c16b98117590b15ca7662b878fb2f76ec41399c329c98deb48e28a0ffce293443269513a96c2503389894b598787b19dadc210d4b4dbc6a7432caf633e7d1 WHIRLPOOL 4c4edfd772bbf534e42fc43e1feaf3b8f76e74c58ec1e985e3c29ee0d8e64aa8c501b8e45e078643409c320a1d834b0d5eb699e7d1ec29df06be0126d12492f1
DIST lammps-20Nov15.tar.gz 90227651 SHA256 7c392c848e73335226b2fef6bb8034b1152f91862d955a3bae00502bf9d8e8fe SHA512 4bff70e45fb30be10a33b4c6c60b73cceddf8d42588b0630b4802f1e61dea3c237c01c3667585ad210ef2cdb811491b1b8495718a90bb57853c58245e29d1fe4 WHIRLPOOL a01f54911a5edb666ef5af5302cf60d61d58d20f2112578e4d7bd16787b2bf59da09e9fe7ffa021fb6a97db40b23301ed77010f48a05e5471742c0e71413b7e1
diff --git a/sci-physics/lammps/lammps-20151211.ebuild b/sci-physics/lammps/lammps-20151211.ebuild
new file mode 100644
index 000000000000..e692e6fc4cb5
--- /dev/null
+++ b/sci-physics/lammps/lammps-20151211.ebuild
@@ -0,0 +1,217 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit eutils flag-o-matic fortran-2 multilib python-r1
+
+convert_month() {
+ local months=( "" Jan Feb Mar Apr May Jun Jul Aug Sep Oct Nov Dec )
+ echo ${months[${1#0}]}
+}
+
+MY_P=${PN}-$((10#${PV:6:2}))$(convert_month ${PV:4:2})${PV:2:2}
+
+DESCRIPTION="Large-scale Atomic/Molecular Massively Parallel Simulator"
+HOMEPAGE="http://lammps.sandia.gov/"
+SRC_URI="http://lammps.sandia.gov/tars/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples gzip lammps-memalign mpi python static-libs"
+
+DEPEND="
+ mpi? (
+ virtual/blas
+ virtual/lapack
+ virtual/mpi
+ )
+ gzip? ( app-arch/gzip )
+ sci-libs/voro++
+ python? ( ${PYTHON_DEPS} )
+ "
+RDEPEND="${DEPEND}"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+S="${WORKDIR}/${MY_P}"
+
+lmp_emake() {
+ local LAMMPS_INCLUDEFLAGS
+ LAMMPS_INCLUDEFLAGS="$(usex gzip '-DLAMMPS_GZIP' '')"
+ LAMMPS_INCLUDEFLAGS+="$(usex lammps-memalign ' -DLAMMPS_MEMALIGN=64' '')"
+
+ # The lammps makefile uses CC to indicate the C++ compiler.
+ emake \
+ ARCHIVE="$(tc-getAR)" \
+ CC="$(usex mpi "mpic++" "$(tc-getCXX)")" \
+ F90="$(usex mpi "mpif90" "$(tc-getFC)")" \
+ LINK="$(usex mpi "mpic++" "$(tc-getCXX)")" \
+ CCFLAGS="${CXXFLAGS}" \
+ F90FLAGS="${FCFLAGS}" \
+ LINKFLAGS="${LDFLAGS}" \
+ LMP_INC="${LAMMPS_INCLUDEFLAGS}" \
+ MPI_INC="$(usex mpi "" "-I../STUBS")" \
+ MPI_PATH="$(usex mpi "" "-L../STUBS")" \
+ MPI_LIB="$(usex mpi "" "-lmpi_stubs")" \
+ user-atc_SYSLIB="$(usex mpi "$($(tc-getPKG_CONFIG) --libs blas) $($(tc-getPKG_CONFIG) --libs lapack)" '')"\
+ "$@"
+}
+
+lmp_activate_packages() {
+ # Build packages
+ local packages=( yes-asphere yes-body yes-class2 yes-colloid \
+ yes-coreshell yes-dipole yes-fld yes-granular yes-kspace \
+ yes-manybody yes-mc yes-meam yes-misc \
+ $(usex mpi "yes-user-atc" "") \
+ yes-molecule yes-opt yes-peri yes-poems yes-qeq yes-reax \
+ yes-replica yes-rigid yes-shock yes-snap yes-srd \
+ yes-user-eff yes-user-fep \
+ $(usex mpi "yes-user-lb" "") \
+ yes-user-phonon yes-user-sph yes-voronoi yes-xtc )
+
+ for p in ${packages[@]}; do
+ lmp_emake -C src ${p}
+ done
+}
+
+lmp_build_packages() {
+ lmp_emake -C lib/meam -j1 -f Makefile.gfortran
+ lmp_emake -C lib/poems -f Makefile.g++
+ lmp_emake -C lib/reax -j1 -f Makefile.gfortran
+ use mpi && lmp_emake -C lib/atc -f Makefile.g++
+}
+
+lmp_clean_packages() {
+ lmp_emake -C lib/meam -f Makefile.gfortran clean
+ lmp_emake -C lib/poems -f Makefile.g++ clean
+ lmp_emake -C lib/reax -f Makefile.gfortran clean
+ use mpi && lmp_emake -C lib/atc -f Makefile.g++ clean
+}
+
+src_prepare() {
+ # Fix inconsistent use of SHFLAGS.
+ sed -i \
+ -e 's:voronoi_SYSINC\s\+=.*$:voronoi_SYSINC = -I/usr/include/voro++:' \
+ -e 's:voronoi_SYSPATH\s\+=.*$:voronoi_SYSPATH =:' \
+ lib/voronoi/Makefile.lammps || die
+
+ # Fix missing .so name.
+ sed -i \
+ -e 's:SHLIBFLAGS\s\+=\s\+:SHLIBFLAGS = -Wl,-soname,liblammps.so.0 :' \
+ src/MAKE/Makefile.serial || die
+
+ # Fix makefile in tools.
+ sed -i \
+ -e 's:g++:$(CXX) $(CXXFLAGS):' \
+ -e 's:gcc:$(CC) $(CCFLAGS):' \
+ -e 's:ifort:$(FC) $(FCFLAGS):' \
+ tools/Makefile || die
+
+ # Patch python.
+ epatch "${FILESDIR}/lammps-python3-r1.patch"
+ epatch "${FILESDIR}/python-shebang.patch"
+}
+
+src_compile() {
+ # Fix atc...
+ append-cxxflags -I../../src
+
+ # Acticate packages.
+ elog "Activating lammps packages..."
+ lmp_activate_packages
+
+ # STUBS/mpi.c is using '#include <mpi.h>' now instead of '#include
+ # "mpi.h"' which requires an additional '-I.'.
+ append-cxxflags -I.
+
+ # Compile stubs for serial version.
+ use mpi || lmp_emake -C src mpi-stubs
+
+ elog "Building packages..."
+ lmp_build_packages
+
+ if use static-libs; then
+ # Build static library.
+ elog "Building static library..."
+ lmp_emake -C src mode=lib serial
+ fi
+
+ # Clean out packages (that's not done by the build system with the clean
+ # target), so we can rebuild the packages with -fPIC.
+ elog "Cleaning packages..."
+ lmp_clean_packages
+
+ # The build system does not rebuild the packages with -fPIC, adding flag
+ # manually.
+ append-cxxflags -fPIC
+ append-fflags -fPIC
+
+ # Compile stubs for serial version.
+ use mpi || lmp_emake -C src mpi-stubs
+
+ elog "Building packages..."
+ lmp_build_packages
+
+ # Build shared library.
+ elog "Building shared library..."
+ lmp_emake -C src mode=shlib serial
+
+ # Compile main executable. The shared library is always built, and
+ # mode=shexe is simply a way to re-use the object files built in the
+ # "shlib" step when linking the executable. The executable is not actually
+ # using the shared library. If we have built the static library, then we
+ # link that into the executable.
+ elog "Linking executable..."
+ if use static-libs; then
+ lmp_emake -C src mode=exe serial
+ else
+ lmp_emake -C src mode=shexe serial
+ fi
+
+ # Compile tools.
+ elog "Building tools..."
+ lmp_emake -C tools binary2txt chain data2xmovie micelle2d
+}
+
+src_install() {
+ use static-libs && newlib.a src/liblammps_serial.a liblammps.a
+ newlib.so src/liblammps_serial.so liblammps.so.0.0.0
+ dosym liblammps.so.0.0.0 /usr/$(get_libdir)/liblammps.so
+ dosym liblammps.so.0.0.0 /usr/$(get_libdir)/liblammps.so.0
+ newbin src/lmp_serial lmp
+ dobin tools/binary2txt
+ dobin tools/chain
+ dobin tools/data2xmovie
+ dobin tools/micelle2d
+ # Don't forget to add header files of optional packages as they are added
+ # to this ebuild. There may also be .mod files from Fortran based
+ # packages.
+ insinto "/usr/include/${PN}"
+ doins -r src/*.h lib/meam/*.mod
+
+ local LAMMPS_POTENTIALS="usr/share/${PN}/potentials"
+ insinto "/${LAMMPS_POTENTIALS}"
+ doins potentials/*
+ echo "LAMMPS_POTENTIALS=${EROOT}${LAMMPS_POTENTIALS}" > 99lammps
+ doenvd 99lammps
+
+ # Install python script.
+ use python && python_foreach_impl python_domodule python/lammps.py
+
+ if use examples; then
+ local LAMMPS_EXAMPLES="/usr/share/${PN}/examples"
+ insinto "${LAMMPS_EXAMPLES}"
+ doins -r examples/*
+ fi
+
+ dodoc README
+ if use doc; then
+ dodoc doc/Manual.pdf
+ dohtml -r doc/*
+ fi
+}