summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Savchenko <bircoph@gentoo.org>2016-12-06 01:24:17 +0300
committerAndrew Savchenko <bircoph@gentoo.org>2016-12-06 01:41:55 +0300
commit9ceb49004ed4abc74a166dc20d65fd9e6dd17090 (patch)
tree470a5a57f99e563704a8107e9cb4142a7511fa99 /sci-physics
parentnet-misc/tor: version bumps to 0.2.8.10 and 0.2.9.6_rc (diff)
downloadgentoo-9ceb49004ed4abc74a166dc20d65fd9e6dd17090.tar.gz
gentoo-9ceb49004ed4abc74a166dc20d65fd9e6dd17090.tar.bz2
gentoo-9ceb49004ed4abc74a166dc20d65fd9e6dd17090.zip
sci-physics/root: rename USE flag avahi -> zeroconf
As suggested by pacho in bug 601682. Package-Manager: portage-2.3.3 Signed-off-by: Andrew Savchenko <bircoph@gentoo.org>
Diffstat (limited to 'sci-physics')
-rw-r--r--sci-physics/root/root-5.34.26.ebuild8
-rw-r--r--sci-physics/root/root-5.34.32.ebuild9
-rw-r--r--sci-physics/root/root-5.34.36.ebuild9
3 files changed, 14 insertions, 12 deletions
diff --git a/sci-physics/root/root-5.34.26.ebuild b/sci-physics/root/root-5.34.26.ebuild
index ccb48984a24c..a99893b4fc59 100644
--- a/sci-physics/root/root-5.34.26.ebuild
+++ b/sci-physics/root/root-5.34.26.ebuild
@@ -22,10 +22,10 @@ HOMEPAGE="https://root.cern.ch"
SLOT="0/$(get_version_component_range 1-3 ${PV})"
LICENSE="LGPL-2.1 freedist MSttfEULA LGPL-3 libpng UoI-NCSA"
-IUSE="+X afs avahi c++11 c++14 doc emacs examples fits fftw
+IUSE="+X afs c++11 c++14 doc emacs examples fits fftw
graphviz http kerberos ldap +math minimal mpi mysql odbc
+opengl openmp oracle postgres prefix pythia6 pythia8
- python qt4 +reflex ruby sqlite ssl xinetd xml xrootd"
+ python qt4 +reflex ruby sqlite ssl xinetd xml xrootd zeroconf"
# TODO: add support for: davix
# TODO: unbundle: vdt
@@ -74,7 +74,6 @@ CDEPEND="
)
!minimal? (
afs? ( net-fs/openafs )
- avahi? ( net-dns/avahi:0= )
emacs? ( virtual/emacs )
fits? ( sci-libs/cfitsio:0= )
fftw? ( sci-libs/fftw:3.0= )
@@ -102,6 +101,7 @@ CDEPEND="
ssl? ( dev-libs/openssl:0= )
xml? ( dev-libs/libxml2:2= )
xrootd? ( >=net-libs/xrootd-3.3.5:0= )
+ zeroconf? ( net-dns/avahi:0= )
)"
DEPEND="${CDEPEND}
@@ -307,7 +307,6 @@ src_configure() {
$(use_enable X asimage)
$(use_enable X xft)
$(use_enable afs)
- $(use_enable avahi bonjour)
$(use_enable c++11 cxx11)
$(use_enable c++14 cxx14)
$(use_enable fits fitsio)
@@ -342,6 +341,7 @@ src_configure() {
$(use_enable ssl)
$(use_enable xml)
$(use_enable xrootd)
+ $(use_enable zeroconf bonjour)
${EXTRA_ECONF}
)
fi
diff --git a/sci-physics/root/root-5.34.32.ebuild b/sci-physics/root/root-5.34.32.ebuild
index b888d83cda80..fe92a83364c3 100644
--- a/sci-physics/root/root-5.34.32.ebuild
+++ b/sci-physics/root/root-5.34.32.ebuild
@@ -22,10 +22,11 @@ HOMEPAGE="https://root.cern.ch"
SLOT="0/$(get_version_component_range 1-3 ${PV})"
LICENSE="LGPL-2.1 freedist MSttfEULA LGPL-3 libpng UoI-NCSA"
-IUSE="+X afs avahi c++11 c++14 doc emacs examples fits fftw gdml
+IUSE="+X afs c++11 c++14 doc emacs examples fits fftw gdml
graphviz http kerberos ldap +math +memstat mpi mysql odbc
+opengl openmp oracle postgres prefix pythia6 pythia8
- python qt4 +reflex ruby shadow sqlite ssl table +tiff xinetd xml xrootd"
+ python qt4 +reflex ruby shadow sqlite ssl table +tiff xinetd
+ xml xrootd zeroconf"
# TODO: add support for: davix
# TODO: unbundle: vdt
@@ -67,7 +68,6 @@ CDEPEND="
x11-libs/libXft:0=
)
afs? ( net-fs/openafs )
- avahi? ( net-dns/avahi:0= )
emacs? ( virtual/emacs )
fits? ( sci-libs/cfitsio:0= )
fftw? ( sci-libs/fftw:3.0= )
@@ -96,6 +96,7 @@ CDEPEND="
ssl? ( dev-libs/openssl:0= )
xml? ( dev-libs/libxml2:2= )
xrootd? ( >=net-libs/xrootd-3.3.5:0= )
+ zeroconf? ( net-dns/avahi:0= )
"
DEPEND="${CDEPEND}
@@ -287,7 +288,6 @@ src_configure() {
$(use_enable X asimage)
$(use_enable X xft)
$(use_enable afs)
- $(use_enable avahi bonjour)
$(use_enable c++11 cxx11)
$(use_enable c++14 cxx14)
$(use_enable fits fitsio)
@@ -329,6 +329,7 @@ src_configure() {
$(use_enable tiff astiff)
$(use_enable xml)
$(use_enable xrootd)
+ $(use_enable zeroconf bonjour)
${EXTRA_ECONF}
)
diff --git a/sci-physics/root/root-5.34.36.ebuild b/sci-physics/root/root-5.34.36.ebuild
index cb13f8fabf60..0872b4d5b238 100644
--- a/sci-physics/root/root-5.34.36.ebuild
+++ b/sci-physics/root/root-5.34.36.ebuild
@@ -22,10 +22,11 @@ HOMEPAGE="https://root.cern.ch"
SLOT="0/$(get_version_component_range 1-3 ${PV})"
LICENSE="LGPL-2.1 freedist MSttfEULA LGPL-3 libpng UoI-NCSA"
-IUSE="+X afs avahi c++11 c++14 doc emacs examples fits fftw gdml
+IUSE="+X afs c++11 c++14 doc emacs examples fits fftw gdml
graphviz http kerberos ldap +math +memstat mpi mysql odbc
+opengl openmp oracle postgres prefix pythia6 pythia8
- python qt4 +reflex ruby shadow sqlite ssl table +tiff xinetd xml xrootd"
+ python qt4 +reflex ruby shadow sqlite ssl table +tiff xinetd
+ xml xrootd zeroconf"
# TODO: add support for: davix
# TODO: unbundle: vdt
@@ -67,7 +68,6 @@ CDEPEND="
x11-libs/libXft:0=
)
afs? ( net-fs/openafs )
- avahi? ( net-dns/avahi:0= )
emacs? ( virtual/emacs )
fits? ( sci-libs/cfitsio:0= )
fftw? ( sci-libs/fftw:3.0= )
@@ -96,6 +96,7 @@ CDEPEND="
ssl? ( dev-libs/openssl:0= )
xml? ( dev-libs/libxml2:2= )
xrootd? ( >=net-libs/xrootd-3.3.5:0= )
+ zeroconf? ( net-dns/avahi:0= )
"
DEPEND="${CDEPEND}
@@ -284,7 +285,6 @@ src_configure() {
$(use_enable X asimage)
$(use_enable X xft)
$(use_enable afs)
- $(use_enable avahi bonjour)
$(use_enable c++11 cxx11)
$(use_enable c++14 cxx14)
$(use_enable fits fitsio)
@@ -326,6 +326,7 @@ src_configure() {
$(use_enable tiff astiff)
$(use_enable xml)
$(use_enable xrootd)
+ $(use_enable zeroconf bonjour)
${EXTRA_ECONF}
)